ALM requirements synchronization error (203 Views)
Reply
Advisor
Vasily_Martynov
Posts: 16
Registered: ‎08-22-2011
Message 1 of 2 (203 Views)
Accepted Solution

ALM requirements synchronization error

Hello.

I have an Integration which is built from SM Change to ALM Requirements on ALM Synchronizer.

Got a promblem with ALM synchronizer, new Requrements are not created with error

 

"Create: threw an exception,skipping this entity and moving to the next, exception:QCRequirementTypeRecord constructor caught exception: AutomationException: " Required field can't be blank or filled with spaces ().

And that's the key issue: mapping in Syncronizer is correct, the fields are filled with  constant values or data from SM fields
All mandatory fields for ALM entity are mapped. Integrity check is OK. The same integration works fine for another project in ALM. Link in synchronizer was reseted and recreated in tries to get it work.

 

The Logs clearly states that mandatory field is filled:

 

SetConstantFields: Set the Constant value 'smqcintuser' to field RQ_REQ_AUTHOR.

 

Has anyone met such issue or have any ideas how to resolve this?

 

 

Best Regards

Advisor
Vasily_Martynov
Posts: 16
Registered: ‎08-22-2011
Message 2 of 2 (120 Views)

Re: ALM requirements synchronization error

After some time the issue was resolved as following:
The core problem is that incorrect error is logged in Synchronizer. The real issue was the that the Name for Requirement is duplicated to the one allready present in the system.
Make some changes  on SM and Synchronizer mapping so that ALM field is mapped to SM one containing something like datestamp or change number. (ReqName mapped to(ChangerNumber+ChangeName))

Best regards.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.