ALM Patch 10 (1735 Views)
Reply
Occasional Contributor
Steve Barnash
Posts: 7
Registered: ‎08-09-2010
Message 1 of 6 (1,735 Views)
Accepted Solution

ALM Patch 10

Has anyone successfully installed ALM Patch 10?  I get a failure when it trys to deploy the change.  I've installed Patch 3,5 and 9 without issues

Advisor
Fred_Gaumont
Posts: 13
Registered: ‎01-12-2012
Message 2 of 6 (1,702 Views)

Re: ALM Patch 10

Hi Steve.  I'm currently in the middle of attempting this myself.  What error message(s) are you getting?  I'm running into "SA Schema is not accessible".

Occasional Contributor
Steve Barnash
Posts: 7
Registered: ‎08-09-2010
Message 3 of 6 (1,700 Views)

Re: ALM Patch 10

I'm getting the same message.  Here is the entire message:

 

WorkerTask: Deploy engine failed com.mercury.optane.core.CTdException: SA Schema is not accessible at com.hp.qc.install.setup.QcServerConfigurationBean.setRepositoryPathFromSASchema(QcServerConfigurationBean.java:735) at com.hp.qc.install.core.configuration.AbstractInstallationConfiguration.takeRepositoryFromSATables(AbstractInstallationConfiguration.java:552) at com.hp.qc.install.deploy.wizard.QcDeployWorkerTask$1.run(QcDeployWorkerTask.java:96) at com.hp.qc.install.setup.AbstractWorkerTask$ActualTask.<init>(AbstractWorkerTask.java:143) at com.hp.qc.install.setup.AbstractWorkerTask$2.construct(AbstractWorkerTask.java:75) at com.hp.qc.install.setup.SwingWorker$2.run(SwingWorker.java:114) at java.lang.Thread.run(Thread.java:619)

Advisor
Fred_Gaumont
Posts: 13
Registered: ‎01-12-2012
Message 4 of 6 (1,695 Views)

Re: ALM Patch 10

Steve, we have solved the problem - in our case, it was because we had relocated the DB server since the last patch (9), and there was a configuration file that was still pointing to the old DB server.

 

The file is located at 'C:\ProgramData\HP\ALM\conf'\qcConfigFile.properties'.

 

The 'dbConnectionString' value was still pointing to the old DB server.

 

I think that the Server Configuration Wizard might have been able to fix this, but we just updated the file directly and the patch installed successfully!

 

Hopefully this will help you solve your problem.


Regards,

 

Fred Gaumont

Advisor
OlivierJacques
Posts: 34
Registered: ‎04-09-2010
Message 5 of 6 (1,612 Views)

Re: ALM Patch 10

Well done. Thank you Mr. Gaumont!

--
Forj: continuous integration & delivery for the masses
http://www.hp.com/go/forj
Do not hesitate to mark a question as closed if you think you have all you need (Kudos do help too :-) )
Occasional Advisor
Michzar
Posts: 6
Registered: ‎02-25-2009
Message 6 of 6 (1,082 Views)

Re: ALM Patch 10

HI

There three firlds to change
dbServerName
dbaPassword
dbConnectionString

Then start to work for me.

Thank you for solution !!!
Michał Zarzycki
Volvo IT Poland
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.