Re: ALM 11 REST API test execution status change not reflected in WebUI (1449 Views)
Reply
Visitor
Posts: 3
Registered: ‎04-24-2014
Message 1 of 8 (1,591 Views)
Accepted Solution

ALM 11 REST API test execution status change not reflected in WebUI

Hello all, 

 

Can anybody give me a hint over here please? I am trying to update a status of a test in test lab set via REST API. I have no problems creating a run and updating an exec-status value of the test i intend to change. Responsed of my requests prove that change has been commited, but for some reason HP QC execution grid shows still old status. If i open a test i can see my last run created via REST API, but no change on level of test in execution grid at all. 

 

Any suggestions? 

 

Thank you

Karol

Visitor
Posts: 3
Registered: ‎04-24-2014
Message 2 of 8 (1,525 Views)

Re: ALM 11 REST API test execution status change not reflected in WebUI

[ Edited ]

Ok, another observation:

 

If I update <Field Name="exec-status"> to something lets say Passed, REST response shows that it was successfully updated. However if i look at the execution grip view Status still holds old value, but (and this is weird), Test: Execution Status field has been updated instead. 

 

If you create a report in dashboard on top of tests this report shows new value, but execution grid and also email from execution grid shows old value. What is happening? How come REST API is updating Test Instance entity instead of Test entity? 

 

As per field description it should update TS_EXECUTION_STATUS, but seems TC_STATUS is updated instead.

<Field PhysicalName="TS_EXEC_STATUS" Name="exec-status" Label="Execution Status">

 

Still no suggestion?

Karol

Senior Member
Posts: 5
Registered: ‎04-11-2014
Message 3 of 8 (1,469 Views)

Re: ALM 11 REST API test execution status change not reflected in WebUI

Hi,

I am new to HP ALM and my requirement is to update test execution status.

Could you share code to update a status of a test in test lab set via REST API?

 

Thanks

Visitor
Posts: 3
Registered: ‎04-24-2014
Message 4 of 8 (1,449 Views)

Re: ALM 11 REST API test execution status change not reflected in WebUI

Thanks to the bdkakde i have reviewed my scripts rather more carefully and found out that i was updating wrong entity.

Thank you for making me see! All works like a charm now.

Karol
Senior Member
Posts: 5
Registered: ‎04-11-2014
Message 5 of 8 (1,438 Views)

Re: ALM 11 REST API test execution status change not reflected in WebUI

Hi,

 

Congratulation you got solution.

Kind request please share code for me as it is very urgent.

mail id - bdkakde@rediffmail.com

Advisor
Posts: 19
Registered: ‎10-13-2008
Message 6 of 8 (1,250 Views)

Re: ALM 11 REST API test execution status change not reflected in WebUI

Hi Karol,

 

I seem to be having a very similar issue.  First I create a new Run.  Then I update the test-instance and it modifies the status on the Execution Grid, but it also adds another "Run" to the list of Runs for that test instance.  (it's called "Fast_***")

 

from test-instance I update: exec-date,exec-time, status, actual-tester.

 

What entity are you changing for the status to be updated?  Do you get a second run added to the test-instance details?  

 

regards,

Chuck

 

 

Occasional Visitor
Posts: 1
Registered: ‎08-29-2010
Message 7 of 8 (827 Views)

Re: ALM 11 REST API test execution status change not reflected in WebUI

Hi Mates,

I have similar requirement to update Test script status (PASS\FAIL)in Test Lab in QC ALM in my project. Could you plase help me with the code and steps.

Occasional Visitor
Posts: 1
Registered: a month ago
Message 8 of 8 (161 Views)

Re: ALM 11 REST API test execution status change not reflected in WebUI

[ Edited ]

Hi,

 

I am facing same issue that i can create a run id (by POST method) and run id is getting generated successfully.

But when i go to ALM Test lab, the Run and status are not created. Looks like my POST is not saving the run.

I also tried to update the runid by PUT method, but its not reflecting in test lab.

 

Can you please give more info on how you could fix the issue? please mail me at ravi.v.nair@gmail.com

 

Regards,

Ravi

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.