ppm 9.14 send email notification error (697 Views)
Reply
Advisor
Jermias_1
Posts: 21
Registered: ‎02-25-2009
Message 1 of 3 (697 Views)

ppm 9.14 send email notification error

Hi All,

 

The PPM is 9.14 running on Windows Server 2008 Enterprise Edition used database is Oracle 11g and running on VMWare machine.

 

our problem is :

PPM cannot send email notification for several times.

 

we already tired some troubleshooting steps like : restart the notification service (open > administration > scheduled service > disable and enable the notification service for several times, stop and start the PPM service by windows services (service.msc) and cygwin, but when we stop and start the PPM service by cyqwin (the process hang / not progress anything) and the PPM console still accessible and we can login to the PPM console.

 

This problem can temporary solve by restart the PPM server. we need help to find out the root cause why the notification unstable for several month need to restart, do we need to restart the service regularly? Or is there any maintenance way of PPM aplication that we should to know. Please give us enlightenment for this case. :)

 

Thanks all.

 

Regards,

Jermias

Honored Contributor
dirkf
Posts: 466
Registered: ‎04-07-2010
Message 2 of 3 (663 Views)

Re: ppm 9.14 send email notification error

Hi Jermias,

 

a restart of the PPM-services is ok every so often in order to free up all the processes. What you might do experiencing the kind of problems you do is to check in the task manager if you have hanging java-processes there. Kill those processes and then start PPM again.

When you stop and start PPM, you could also run kRunCacheManager.sh with the option 'A' to free up all the cache and bring everything up to date.

 

Regarding the email-notification issue, there's not much I can say without knowing WHICH notifications are failing and if this could be due to some service not running properly. Check first if the issue starts immediately although you just ran up PPM or if this starts occuring over time. In that case check the relevant tables (have a look at the attached data model guide) to see if the table holding the notifications is clogging up with non-sent notifications. Also make sure that all notifications are configured properly. Check the logs for errors.

 

If all fails, open a ticket with HP PPM Support.

 

Best regards,

Dirk

Advisor
Jermias_1
Posts: 21
Registered: ‎02-25-2009
Message 3 of 3 (657 Views)

Re: ppm 9.14 send email notification error

Hi Dirk

 

thanks for your replied,

 

Regarding run kRunCacheManager.sh do we need to run it first before stop and start the PPM service ? because when we stop the ppm service by cyqwin (the process hang / not process anything). For the next, we will try to run the kRunCacheManager with the option 'A' to free up all the cache and bring everything up to date and hope this can affect to notification email.

 

we already check the some of configuration bellow :

01. Restart PPM Notification service by kRunServiceManager.sh command
02. Successfull telnet from PPM server to smtp mail server
03. Successfull testing send email used command from PPM server to smtp mail server.
04. Disable and enable Scheduled notification service from administration console
05. Check server.conf file and no configuration change in server.conf file for smtp configuration
06. Disable and enable Notification service for several time
07. Stop and Start PPM Service from Windows service (services.msc)
 
with the steps above the problem still exist until we restart the ppm server so that why we need to find the root cause of the problem so the problem not occur in the further.
 
thanks and regards.
Jermias
 
 
 

 

 

 

 

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.