Re: PPM - BO Integration impact during PPM upgrade (196 Views)
Reply
Advisor
DivyaMurali
Posts: 37
Registered: ‎03-26-2012
Message 1 of 6 (288 Views)

PPM - BO Integration impact during PPM upgrade

Hi Team,

 

BO (XI 3.1 SP2) has been integrated with PPM 9.14 and BO custom reports are already available.

 

We have a requirement to upgrade PPM to 9.2. I got to know from the PPM guides that the compatible BO version for PPM 9.2 is BO Content pack 1.3

 

As I do not have experience in BO reports, Can anyone pease clarify the below questions:

 

1)  whether the current version of BO has to be upgraded to CP 1.3? If so, how to do it?? any steps to do the same?

 

2) Impact of upgrade in the custom reports already available in BO

 

Appreciate your response!

 

 

Thanks & Regards,

Divya

Please use plain text.
Regular Advisor
pepdwill
Posts: 204
Registered: ‎07-12-2012
Message 2 of 6 (247 Views)

Re: PPM - BO Integration impact during PPM upgrade

[ Edited ]

Divya -

I would be very cautious...

 

If you have BO reports already in place and working - I can't see any reason why upgrading to 9.2 would break anything - even if the notes say that Content Pack 1.3 is the compatible version.

 

And just my opinion, but I'd try to avoid installing CP 1.3 altogether until after installing 9.20 - and only if something breaks as a result of it.  You should try to test in a Dev/Staging environment first.

 

It would probably be safe to deploy parts of the upgrade - but there are things you for sure wouldn't want to do... such as re-deploying the BO universes that come with the Content Pack.  (If you did this, you'd lose any customizations made to the universes, and any reports using such customizations would fail). 

 

-Danny

 

 

Please use plain text.
Advisor
DivyaMurali
Posts: 37
Registered: ‎03-26-2012
Message 3 of 6 (227 Views)

Re: PPM - BO Integration impact during PPM upgrade

Thanks for the reponse Danny!

 

Please note that I do not have any experience in BO.

 

My understanding was that there is some integration that has been established between PPM 9.14 and BO (XI 3.1 SP2) . Since we are upgrading PPM to 9.2 version , the BO that has to be integrated should be of version that is compatible with PPM. So, once PPM is upgraded, it should again be integrated with BO(whichever compatible version it may be)

 

Please correct of my understanding is not correct.

 

 

Regards,

Divya

 

Please use plain text.
Regular Advisor
pepdwill
Posts: 204
Registered: ‎07-12-2012
Message 4 of 6 (220 Views)

Re: PPM - BO Integration impact during PPM upgrade

The BO solution is not directly integrated against the live PPM transactional database but rather a separate database specifically setup for Reporting. 

 

The Operational Reporting content pack would consist of the various scripts that will setup the operational reporting database schema, along with various packages/etc that handle the ETL - which manages the process of refreshing the data into the reporting database.

 

Unless HP changes something with the existing underlying data structure of PPM - upgrading to a new version I don't think would break anything.  You might miss out on new tables added and made available for reporting in BO... but I don't really think anything would break.

 

Hopefully someone else can chime in and provide a better explanation =]

 

 

Please use plain text.
Advisor
DivyaMurali
Posts: 37
Registered: ‎03-26-2012
Message 5 of 6 (217 Views)

Re: PPM - BO Integration impact during PPM upgrade

Thanks for the explanation!

 

I just referred System Reqs and compatbility Matrix pdf for 9.2 and the BO version XI 3.1 SP2 is given under section "Desupported Platforms and Software for PPM 9.2".

 

However, as far as I know data structure is not changed in this version. Can you please explain this?

Please use plain text.
Regular Advisor
pepdwill
Posts: 204
Registered: ‎07-12-2012
Message 6 of 6 (196 Views)

Re: PPM - BO Integration impact during PPM upgrade

Any explanation I could offer about why 3.1 SP2 has been de-supported would be just speculation.  I don't think you'd have issues using it, but you should probably tell the BO team to upgrade to a more current service pack (looks like SP6 is most current).

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation