Re: ML 310 G2 installing Windows Home Server 2011 (373 Views)
Reply
Visitor
Lukeyson
Posts: 3
Registered: ‎04-08-2012
Message 1 of 4 (414 Views)
Accepted Solution

ML 310 G2 installing Windows Home Server 2011

I am having a struggle with this.

 

I am MSDN trialing WIndows Home Server 2011 on a HP Proliant ML310 G2 that has been decommissioned from our data centre. I understand that WHS 2011 is just WIndows 2008 R2 underneath. The server itself is floppyless.

 

I am using the x64 install for WHS 2011.

 

During the install I am unable to see the disks, but only when the controller is in RAID mode. So obviously the next step was to locate SATA RAID drivers and I'd be OK right?

 

Given I have no floppy, I downloaded what I thought were the relevant x64 drivers from the HP site (here http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?prodNameId=3279691&lang=en&cc=us...) and loaded them onto a 2G USB stick (formatted FAT32) and tried to load them during OS install when presented with the 'Load Drivers' option. But no luck - I point the utility to the folder where I have coped the driver files, and it whirs away for a few seconds but then comes back to a screen that continues to be empty (no visible drives). So I looked around further for other ICH6R (I checked that this is the RAID chipset used, it flashes by during POST) drivers on the HP website and tried those (here http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=3279691&...) no luck. I tried older x64 2003 drivers - still no luck. I even went to external websites looking for other 2008 R2 ICH6R drivers - still no luck.

 

So what am I doing wrong? My motivation is to RAID5 up 4 x 3TB drives for WHS 2011 so there's plenty of room for media, and a single partition is desirable, but still retain fault tolerance. My next fall-back is to OS software RAID and, well, I'd like to avoid that.

 

 I updated the BIOS to the latest version I could find just in case. And there aren't very many settings in the Bios. A fellow engineer in the office recalled having to change a setting in a DL310 BIOS he once built for a customer to get W2003 to recognize his RAID drivers during a build, but I couldn't find anything related to the RAID controller other than enable/disable.

 

So here I am, cup in hand. Does anyone know what I could try to get W2008R2/WHS2011 x64 to recognize the ML310 G2 RAID controller during build?

 

 

Lukeyson

Please use plain text.
Esteemed Contributor
Goutham_Sabala
Posts: 372
Registered: ‎02-16-2012
Message 2 of 4 (398 Views)

Re: ML 310 G2 installing Windows Home Server 2011

2011/2008 servers OS  is not supported on ML310 G2 server, here are the QS

http://h18000.www1.hp.com/products/quickspecs/12168_na/12168_na.HTML

 

OS Support Microsoft Windows Server 2003 (Standard & Web Edition)
Microsoft Small Business Server 2003
Microsoft Windows 2000 Server

Was the post useful? Say thanks by clicking the white KUDOS Star!
Goutham Sabala
Please use plain text.
Visitor
Lukeyson
Posts: 3
Registered: ‎04-08-2012
Message 3 of 4 (396 Views)

Re: ML 310 G2 installing Windows Home Server 2011

 

 

Thankyou. That sounds like an 'official' answer. However, that link appears to have been last updated in 2006. The link I provided shows drivers for later OS's. If HP releases drivers for later OS's for the ML310 G2, can I reasonably imply that that means they are supported?

 

On the link I provided earlier I see drivers for Windows Server 2008 x64, but not for Server 2008 R2. So I must be close.

 

Let's step back to 'supported' platforms then. If I were to just ask for the instructions on how to do this with Server 2008 on a ML310 G2, and you pretend I never even mentioned Server 2008 R2 or WHS 2011, would that help?

 

But you've given me an idea at least to change my search queries. I've only been looking for 2008 R2 help up until now. SIlly me.

 

 

Lukeyson

Please use plain text.
Visitor
Lukeyson
Posts: 3
Registered: ‎04-08-2012
Message 4 of 4 (373 Views)

Re: ML 310 G2 installing Windows Home Server 2011

OK, after lots of digging and reading through the finer detail of driver readme's I finally concede.

 

The last Intel driver that has support for ther ICH6R is version 7.0, and this only supported OS versions 2003 x64 or lower.

 

The ICH7R and up is supported in later drivers. I am on the lower side of the chasm. But good news, there is an ML310 G4 sitting in the kit pile unused, and it has an ICH7 in it........

 

 

Luke

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation