DL580 G3 illegal opcode (674 Views)
Reply
Occasional Contributor
kc_kazan
Posts: 6
Registered: ‎10-16-2007
Message 1 of 4 (674 Views)

DL580 G3 illegal opcode

we have recently bought a new line of servers among them is a DL580 G3 P38 server it has 4 AMD64 processors and 18 GB of RAM.we installed RHEL 4 U4 x86_64 linux on it, the installation went ok , error clean, but when reinstalling after a crash the server hangs at a red screen with an illegal opcode error.
we contacted hp support and they advised to upgrade the servers' BIOS - which was already up to date in fact with the latest version 2006.08.08.
i don't know if this is relevant to mention, i read it somewhere, but the server had SAN drives prior to the crash.
but the server kept crashing with the following

illegal opcode
EAX=00007CFE EBX=00007C00 ECX=00000007 EDX=00000180
EBP=0000FBFA ESI=000007BE EDI=00000800
DS=0000 ES=0000 FS=0000 GS=0004
CS:EIP=0000:0000835A SS:ESP=1000:0000B000
EFLAGS=0000213

i've been fighting with this for over 3 days so any help is really appreciated
Please use plain text.
Occasional Contributor
kc_kazan
Posts: 6
Registered: ‎10-16-2007
Message 2 of 4 (674 Views)

Re: DL580 G3 illegal opcode

i've unrepresented the SAN drives for this server but nothing changed.
I then tried applying the smart array 6i firmware update thinking that it could be an array controller issue, so i updated to 2.8 but again that didn't help.
The hardware left on the server now is the same that existed prior to OS installation.
what's even more surprising is that i reinstalled but this time without deleting the RAID and the OS booted just fine.
Frankly, i don't know where the problem is or how to look for it, i'm just assuming it's a BIOS problem because i have seen some hp docs that recommend updating the server's BIOS to prevent such a problem, in fact it's the only place i ever seen a reference to this.
simply,still can't figure it out!
Please use plain text.
Occasional Advisor
atishG
Posts: 7
Registered: ‎07-11-2013
Message 3 of 4 (484 Views)

Re: DL580 G3 illegal opcode

hi,

 

I having also an illegal opcode error. I have an HP DL 580 G5 server running windows server 2008 std. There was a power outage and the server was powered off. Since that i'm getting that op code error with red screen.

 

Please note that before installing windows, the server had Solaris installed.

 

After applying firmware, i was able to boot windows  but after a reboot i again got the red screen and op code error.

 

So whenever i reboot, i have to put the firmware cd, Although nothing is applied (as the firmware is already updated), the system is booted successfully.

 

What can be the problem?

Is it the mbr has been corrupted?

 

 

Thanks for your precious help. 

 

Kind Regards

 

Atish G

Please use plain text.
Honored Contributor
Jimmy Vance
Posts: 1,485
Registered: ‎11-27-2006
Message 4 of 4 (482 Views)

Re: DL580 G3 illegal opcode

Yes, you can get the Red illegal opcode screen when the MBR is corrupted.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation