ProCurve SNMPv3 Troubles (484 Views)
Reply
Occasional Collector
IT-Mark
Posts: 1
Registered: ‎11-13-2013
Message 1 of 1 (484 Views)

ProCurve SNMPv3 Troubles

We have implemented SNMPv3 across our organization; successfully have it working on 97% of our switches. We have SNMPv3 working properly on over 70 other HP Switches.

It seems that we have been having trouble with 6 switches and are unable to to get it to work properly.

 

The switches I am having issues with are;

 

                             Model                  Code
Switch1 J4900A Switch 2626 H.10.108
Switch2 J4899C Switch 2650 H.10.113
Switch3 J4899B Switch 2650 H.10.113
Switch4 J4899C Switch 2650 H.10.113
Switch5 J4899B Switch 2650 H.10.108
Switch6 J8165A Switch 2650-PWR H.10.113

 

I have tried everything, it should be noted that SNMPv2 does work on these switches.

Anytime we attempt a v3 query the switch logs;

 

W 11/13/13 14:33:00 snmp: SNMP Security access violation from <SNMP Server IP Address>

 

Before people start to question the setup of the SNMP Server; a little info.
We are using Nagios via groups.

I have groups setup via HP Switches & Cisco Switches.

So the checks are all the same.

 

I have removed and re-added SNMPv3 on the problem switches several times.

I even went as far as attempting to configure standard creds like password for all fields on the switch and attempting ot run manual checks with no luck;

 

 

 

HP Switches Steps
conf t
snmpv3 enable 
(( answer the questions ))
no to SHA
yes to access

snmpv3 user password auth MD5 password priv aes password 
snmpv3 group ManagerPriv user "password " sec-model ver3 
snmp-server host 192.168.15.232 com "password " 
snmpv3 restricted-access 
no snmpv3 user "initial" 
wr mem

 

Then as an example I try to run a manual check;

./check_snmp -H <IP Address>  -P 3 -L authPriv -U password -a md5 -A password -X password -o .1.3.6.1.4.1.11.2.14.11.1.2.6.1.4.1 -l 'Fan status'

 

I get return;

Fan status problem - No data received from host
CMD: /usr/bin/snmpget -t 1 -r 5 -m '' -v 3 [authpriv] 192.168.206.31:161 .1.3.6.1.4.1.11.2.14.11.1.2.6.1.4.1

 

and on the switch logs again;

W 11/13/13 09:49:50 snmp: SNMP Security access violation from <SNMP Server IP Address>

 

Then I go an compare to some of the other working switches;

                                           Model                             Code
Working Switch J8165A Switch 2650-PWR  H.10.108
Working Switch J4899A Switch 2650             H.10.108

 

Same code but works fine.

 

I am at a complete losss and hope someone out there on the Internets may have a possible solution of has run into a similar issue with their equipment in the past.

 

Thanks in advance.

 

Mark K~

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.