Re: Vugen Citrix Script does not run in BPM 9.03 (774 Views)
Reply
Frequent Advisor
Omri_Ziv_1
Posts: 81
Registered: ‎01-27-2009
Message 1 of 6 (1,054 Views)

Vugen Citrix Script does not run in BPM 9.03

Hello,
I've recorded a Citrix protocol script that works fine when manuallly played on Vugen 11.03.

After loading the script to the BAC and deployed to the BPM, the script seems to fail.

The error I receieve on the BPM is:
20/03/2012 09:08:36 Action.c(7): Error: Connect can not be established - Last Error=64, Last client error=0 [MsgId: MERR-91996]
20/03/2012 09:08:36 Action.c(7): Continuing after error in Vuser script. [MsgId: MMSG-10678]
20/03/2012 09:08:36 Action.c(7): Wake Up and check new event. [MsgId: MMSG0]
20/03/2012 09:08:36 Action.c(7): Number of currently used GDI handles on this machine = 42 [MsgId: MMSG0]
20/03/2012 09:08:36 Action.c(7): Error: ctrx_set_connect_opt("Outlook_8h10merc7.ica") failed. Operation exceeded timeout.

Regards,
Omri


________________________________________________
Maximum performance with minimum resources over time.
Please use plain text.
Super Advisor
Prasenjit Dutta
Posts: 166
Registered: ‎08-30-2010
Message 2 of 6 (1,051 Views)

Re: Vugen Citrix Script does not run in BPM 9.03

Is the script is working fine from the same BPM?? Because the error shows that the connection could not be established with the citrix...it is the possibility that the citrix ICA client is not there in the BPM machine or there is a mismatch of the version of the ICA client.

 

Thanks,

Prasenjit

Please use plain text.
Advisor
Torgeir_1
Posts: 30
Registered: ‎08-25-2010
Message 3 of 6 (1,038 Views)

Re: Vugen Citrix Script does not run in BPM 9.03

[ Edited ]

Hi,

 

I have the same problem. Not to experienced with Citrix scripting so any advice is much appreciated.

Script are running pretty fine on the scripting machine, and I also installed vugen on the BPM to see it the script ran okay there aswell. It does.

 

It is a web + Citrix script connecting to NFUSE , opening av VM/VDI.  Resolution and client config is the same. The Script open, or at least should, a dedicated XenDesktop VDI.

 

Error on BPM/EUM is :

Action.c(36): Error:Connect can not be established -....

 

Error refers to this line in the script:

 ctrx_nfuse_connect("http://xxxlxen001/Citrix/DesktopWeb/site/launch.ica?CTX_Application=Citrix.MPS.Desktop.V_XenDesktop....", CTRX_LAST);


Torgeir

Please use plain text.
Occasional Advisor
hs85
Posts: 7
Registered: ‎08-21-2012
Message 4 of 6 (816 Views)

Re: Vugen Citrix Script does not run in BPM 9.03

Are there any solutions? same problem here and do not know how to solve it.

Please use plain text.
Advisor
SergioB
Posts: 20
Registered: ‎05-31-2012
Message 5 of 6 (774 Views)

Re: Vugen Citrix Script does not run in BPM 9.03

BPM 9.03 has a hotfix for this issue. Sorry I dont have the link with me but you should be able to get it from the hp support site.

File is: BPM_9.03_Patch_00043.zip

Please use plain text.
Frequent Visitor
DavidBach
Posts: 1
Registered: ‎05-01-2012
Message 6 of 6 (602 Views)

Re: Vugen Citrix Script does not run in BPM 9.03

Thanks for the patch info regarding same issue I am having.  I went to search for patch. 

 

Patch BACBPM_00043 is for QTP integration fix.

Patch BACBPM_00034 is for for a few fixes including:

  • LR VuGen does not display all Citrix published applications

I think the number in the patch was transposed.  

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation