SSL Client Certificate error (1051 Views)
Reply
Frequent Advisor
Amar Bukke
Posts: 37
Registered: ‎02-04-2009
Message 1 of 6 (1,051 Views)

SSL Client Certificate error

Hi experts,

Last weekend, dev team has done few changes in the servers of perf envi. So we started getting errors during our execution, as below:

Script #1:

1. Action.c(30): Warning: Client Certificate was requested by SSL server [MsgId: MMSG-26000]
2. Action.c(30): Warning -27780: connect to host "perf.com" failed: [10054] Connection reset by peer [MsgId: MWAR-27780]
3. Action.c(30): Warning -26000: Empty or no response for URL="https://perf.com " [MsgId: MWAR-26000]

Script #2:

1. Continuing after Error -27778: SSL protocol error when attempting to connect with host "perf.com"
2. Warning -26000: Empty or no response for URL="https://perf.com:443/" [MsgId: MWAR-26000]
3. Continuing after Error -26377: No match found for the requested parameter "sessionId".

From here, we can infer that,

1. Load Runner script is sending the request.
2. But the server is not ready to accept the request, as we are not passing a SSL client certificate within the VuGen script.
3. So we are not getting any response (ART is zero) from server as the basic authentication is failed.
4. Earlier, we have got at least few HTTP 200 OK responses from server. But today it’s not happening at all.
5. The below is the function and its format for setting the SSL client certificate in VuGen script:


web_set_certificate_ex("CertFilePath=perf.pem", "CertFormat=PEM", "KeyFilePath=perf.pem", "KeyFormat=PEM", "Password=abc", "LAST");

When I communicated this to the dev team, they have provided me with the certificate and key PEM files as well as password.

I inserted web_set_certificate_ex(along with adding the .PEM files into the vugen script using”add files to script”) I still see the below errors:

4. Action.c(11): Warning -27780: connect to host "perf.com" failed: [10053] Software caused connection abort [MsgId: MWAR-27780]
5. Action.c(11): Warning -26000: Empty or no response for URL=" https://perf.com/

Any help to over come this error would be greatly appreciated.
Please use plain text.
Frequent Advisor
Amar Bukke
Posts: 37
Registered: ‎02-04-2009
Message 2 of 6 (1,051 Views)

Re: SSL Client Certificate error

Hi,

I am particularly looking for the best practices in implementing the SSL Client certificates in VuGen/Load Runner.

Thank you
Please use plain text.
Occasional Visitor
jai_tpr
Posts: 1
Registered: ‎11-09-2009
Message 3 of 6 (1,051 Views)

Re: SSL Client Certificate error

Hi Amar,

I am facing exactly the same issue you faced.Can you please let me know how to resolve your issue?

i am struggling for 2 weeks.Please hlep.
Thanks
Lenin.
Please use plain text.
Occasional Advisor
Viswa Prasanth Adapa
Posts: 6
Registered: ‎06-04-2009
Message 4 of 6 (1,051 Views)

Re: SSL Client Certificate error

Hi Amar,

I Guess the issue here is that you are not passing the appropriate certificate path.
Try placing the certificate in a shared location which is accessed globally, and then point the file path to the folder which contains the files.
ex.[CertFilePath=..\\Global_utilities]
some times the files dose not get loaded correctly or as intended by the load runner hence you have issues if you place the certificate by adding it to the script.

Thank you,
Viswa.

Please use plain text.
Occasional Visitor
kganeshm
Posts: 1
Registered: ‎03-13-2010
Message 5 of 6 (1,051 Views)

Re: SSL Client Certificate error

Hey guys, Was there a resolution to this issue to avoid the "SSL Protocol Error when attempting to"
Appreciate your help
Please use plain text.
Occasional Advisor
Vamsi_T
Posts: 6
Registered: ‎12-14-2007
Message 6 of 6 (1,051 Views)

Re: SSL Client Certificate error

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation