Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId (897 Views)
Reply
Occasional Contributor
madhukumar
Posts: 4
Registered: ‎01-06-2009
Message 1 of 6 (897 Views)

Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

Hi All,
We are using Mercury Load runner 8.1 with VUGen, I created the script and tested on loacal machine and this works fine with our any error.And when I upload this to my load generator and try to execute the script, i get the failed message with below error.Could any one help me with the fix ?
====
Start auto log messages stack. [MsgId: MMSG-10546]
Virtual User Script started [MsgId: MMSG-15967]
Starting action vuser_init. [MsgId: MMSG-15919]
vuser_init.c(11): Think time - Waiting 30.00 seconds (according to limit). [MsgId: MMSG-15946]
vuser_init.c(11): lr_think_time: 30.00 seconds (recorded think time was 16.00 seconds). [MsgId: MMSG-15947]
vuser_init.c(12): Error: Failed to open new connection to server "GEWPT - PRE [ Basis Sandbox ]" Snapshot Info [MSH 0 0 1]. [MsgId: MERR-79999]
vuser_init.c(12): Error: Failed to get active window [MsgId: MERR-79952]
vuser_init.c(12): Error: Failed to find SapGui component by ID "sbar" [MsgId: MERR-79992]
vuser_init.c(12): Error: Failed to get the status bar text [MsgId: MERR-79946]
vuser_init.c(12): Error: Failed to get active window [MsgId: MERR-79952]
End auto log messages stack. [MsgId: MMSG-10544]
======================
Thanks,
Madhu Kumar
Super Advisor
kiranbadi1991_1
Posts: 150
Registered: ‎02-01-2008
Message 2 of 6 (897 Views)

Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

connectivity issue
Valued Contributor
Prakash K_1
Posts: 150
Registered: ‎03-11-2008
Message 3 of 6 (897 Views)

Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

Did you installed the SAPClinet login in the Load generators.
If not first install the SAP in the Loadgeneratos.
Occasional Advisor
sateeshm
Posts: 10
Registered: ‎04-28-2009
Message 4 of 6 (897 Views)

Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

Hi Madhu,
Yes prakash had given right solution, u need to install ur LG with SAPGUI first
Advisor
Musa Azar
Posts: 18
Registered: ‎11-02-2009
Message 5 of 6 (897 Views)

Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

also, if this is for SAP then you might want to check if the scripting parameter is enabled in ECC using Transaction Code RZ11
search for this parameter "sapgui/user_scripting" and make sure that its value is set to TRUE, every time a reboot takes place, this has to be re-done
Occasional Advisor
manti
Posts: 8
Registered: ‎08-12-2011
Message 6 of 6 (758 Views)

Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1

Hi All

 

I notice that once we build the script, it was working fine for a day. Now we are noticing the same error coming up even though the SAP server is available.

 

Regards,

MMT

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.