Re: swinstall (284 Views)
Reply
Regular Advisor
Mark Parsons
Posts: 131
Registered: ‎02-05-2009
Message 1 of 2 (321 Views)
Accepted Solution

swinstall

[ Edited ]

Hi,

 

I was doing a swinstall on my HPUX 11.11 server and my network connection dropped. I now can't get into swremove (to attempt to remove the partial installation) as it comes back with select target path (rather than the screen of installed software). Is there a lock file that needs to be removed somewhere? I know a system reboot will fix it but I don't really want to do that.

 

Kind Regards - Mark P.

 

 

P.S. This thread has been moevd from HP-UX > System Administration to HP-UX > patches - HP Forums Moderator

 

 

Please use plain text.
Honored Contributor
Robert_Jewell
Posts: 1,234
Registered: ‎06-26-2001
Message 2 of 2 (284 Views)

Re: swinstall

The following should work:

 

    - Kill the swagentd process.
          # /sbin/init.d/swagentd stop

    - Run the following command, and if the file swlock exists, rename the file.
          # ls /var/adm/sw/products/swlock
            /var/adm/sw/products/swlock
          # mv /var/adm/sw/products/swlock /var/adm/sw/products/swlock-orig

    - Restart the swagentd process.
          # /sbin/init.d/swagentd start
 
    - Try the swinstall again.  If this works OK, then remove the swlock-orig file.

 

-Bob

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation