Upgrade Patch: Need Help (790 Views)
Reply
Advisor
math_from_france
Posts: 28
Registered: ‎03-09-2007
Message 1 of 4 (790 Views)

Upgrade Patch: Need Help

Hi !

 

I'm new on HP-UX.

I need to upgrade this package: Quality Pack

 

I'm running HPUX 11.31 B

 

This is my current version:

#/usr/sbin/swlist -l bundle |grep QPK

QPKAPPS               B.11.31.0803.318a Applications Patches for HP-UX 11i v3, March 2008
QPKBASE               B.11.31.0803.318a Base Quality Pack Bundle for HP-UX 11i v3, March 2008

 

I need B.11.31.0809.326a version but i dont know where i can download it and how to install it?

 

Moreover, do you know how can i determine my HPUX version ? (entreprise, foundation..)?

 

Thank you very much

Acclaimed Contributor
Torsten.
Posts: 23,367
Registered: ‎10-02-2001
Message 2 of 4 (789 Views)

Re: Upgrade Patch: Need Help

[ Edited ]

You will find the link to the patches from the Home of this support center. http://www.itrc.com should work.
Go to Download Options. You need a valid contract in order to get patches.

 

Regarding the version - post a "swlist" output!


Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Acclaimed Contributor
James R. Ferguson
Posts: 21,184
Registered: ‎07-06-2000
Message 3 of 4 (782 Views)

Re: Upgrade Patch: Need Help

Hi:

 

You can You can determine the OE (Operating Environment) with:

# swlist HPUX11i-\*

Regards!

 

...JRF...

Exalted Contributor
Steven E. Protter
Posts: 33,806
Registered: ‎08-15-2002
Message 4 of 4 (777 Views)

Re: Upgrade Patch: Need Help

Shalom,

 

You state: I need B.11.31.0809.326a version but i dont know where i can download it and how to install it?

 

What this really means in the land of QPK is that is the minimum QPK. Any QPK issued after that, September 2010 or March 2011 will meet oracle and other software application requirements. In this area what you have stated is a minimum

 

swlist -l bundle | grep -i QPK

 

They key area here is 0809

If you have 1009 or 1103, you are good.

 

If there is an OE requirement you need to use update-ux to update the OE(Operating Environment) I'm in the middle of a project to do just that.

 

swlist -l bundle | grep OE

 

That will get you the OE.

 

updateing the OE can be done on a running system or with Dynamic Root Disk(DRD). DRD lets you take care of much of the update process on a clone of the running system, without impacting the running system. That is being used in my process as well and major updates including OE update and QPK have been pulled off with less than 2 hours of down time.

 

I'm in the midst of writing an article on this topic. If you update the OE, you definitely want to follow it with a QPK update. About the only thing DRD can't do on a clone is run swconfig to configure your patches. That requires you to activate and boot your clone.

 

Doc 1

 

Doc 2

 

These links may not be good some months after this post. A hard thing to do when organizing or re-organizinig documentation is make all the links that point to it change.

 

SEP

Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.