SPC1131 vulnerability patch bundle for VSE-OE (248 Views)
Reply
Regular Advisor
silusan
Posts: 136
Registered: ‎08-23-2011
Message 1 of 7 (248 Views)

SPC1131 vulnerability patch bundle for VSE-OE

[ Edited ]

Hi...SPC1131 is expected in our server(hpux11.31 vmhost) which has foundation OE

We recently built a vmhost with 11.31 VSOE.

Not sure if I require this SPC1131 in the new vmhost with 11.31 VSE OE.

Please suggest

 

output from new vmhost:

#> swlist | grep -i oe
  HPUX11i-VSE-OE        B.11.31.1109   HP-UX Virtual Server Operating Environment
#> uname -a
HP-UX <new vmhost> B.11.31 U ia64 1392496050 unlimited-user license
 #>

# swlist | grep -i SPC
#

output from old foundation OE vmhost:

# uname -a
HP-UX <vmhost> B.11.31 U ia64 3565873559 unlimited-user license
# swlist | grep -i oe
  HPUX11i-OE                    B.11.31.0803   HP-UX Foundation Operating Environment
#

# swlist | grep -i SPC
  SPC1131                       B.2009.03.02   March 2009 vulnerability Patch Bundle
# swlist SPC1131
# Initializing...
# Contacting target "vmhost"...
#
# Target:  <vmhost>:/
#

# SPC1131               B.2009.03.02   March 2009 vulnerability Patch Bundle
  SPC1131.PHCO_37811    1.0            logins(1M) cumulative patch
  SPC1131.PHSS_39122    1.0            HP DCE 2.0 client cumulative patch
  SPC1131.PHSS_39094    1.0            linker + fdp cumulative patch
  SPC1131.PHSS_38840    1.0            Xserver cumulative patch
  SPC1131.PHSS_38568    1.0            KRB5-Client Version 1.3.5.03 Cumulative patch
  SPC1131.PHSS_38527    1.0            Aries cumulative patch
  SPC1131.PHSS_37226    1.0            X Font Server Patch
  SPC1131.PHNE_38680    1.0            cumulative ARPA Transport patch
  SPC1131.PHNE_37257    1.0            STREAMS Cumulative Patch
  SPC1131.PHKL_38746    1.0            kernel tunables infrastructure cumulative patch
  SPC1131.PHKL_38398    1.0            sba cumulative patch
  SPC1131.PHKL_36261    1.0            Integrity Virtual Machine Capabilities Interface
  SPC1131.PHCO_38547    1.0            ugm cumulative patch
  SPC1131.PHCO_38048    1.0            libc cumulative patch
#

Honored Contributor
Patrick Wallek
Posts: 13,771
Registered: ‎06-21-2000
Message 2 of 7 (225 Views)

Re: SPC1131 vulnerability patch bundle for VSE-OE

Where did you get this SPC1131 bundle? Was thit built for by HP?  Did you build it yourself?  From what I can find it does not appear to be a standard HP patch bundle.

 

If you patch your new installation as up to date as you can, with the Sep 2011 patch bundle, a lot of the issues covered by your SPC1131 bundle will probably be addressed.

 

It may not hurt to try installing it to make sure though.

Regular Advisor
silusan
Posts: 136
Registered: ‎08-23-2011
Message 3 of 7 (196 Views)

Re: SPC1131 vulnerability patch bundle for VSE-OE

"If you patch your new installation as up to date as you can, with the Sep 2011 patch bundle, a lot of the issues covered by your SPC1131 bundle will probably be addressed."

 

Looks like that bundle I was talking was built by us..may not be a standard HP bundle.

The bundle could be an year old...

I am having doubts...

New server OE is:

HPUX11i-VSE-OE        B.11.31.1109   HP-UX Virtual Server Operating Environment

 

The patch bundle SPC1131 shown above is for/ is in a server whose OE is:

 HPUX11i-OE                    B.11.31.0803   HP-UX Foundation Operating Environment

what if I am installing patches(old patches) which are already superseded by the ones in VSE-OE?

Any suggestions please?

 

thanks 

Acclaimed Contributor
Dennis Handly
Posts: 25,047
Registered: ‎03-06-2006
Message 4 of 7 (192 Views)

Re: SPC1131 vulnerability patch bundle for VSE-OE

>what if I am installing patches (old patches) which are already superseded by the ones in VSE-OE?

 

By default, swinstall would refuse to install them.

Regular Advisor
silusan
Posts: 136
Registered: ‎08-23-2011
Message 5 of 7 (191 Views)

Re: SPC1131 vulnerability patch bundle for VSE-OE

All the patches in the bundle SPC1131P(vulnerability patch bundle) in  our old vm hosts…their equivalent patches are present in our new vm host(VSE OE)  as well… some are exactly the same patches…and some are superseded patches…except this one….

old vm host # swlist -l patch| grep -i "sba cumulative patch"
# PHKL_38398                            1.0            sba cumulative patch
old vm host:/ #

This patch is not present in the new VM host with VSE OE

Acclaimed Contributor
Dennis Handly
Posts: 25,047
Registered: ‎03-06-2006
Message 6 of 7 (188 Views)

Re: SPC1131 vulnerability patch bundle for VSE-OE

># PHKL_38398 sba cumulative patch
>This patch is not present in the new VM host with VSE OE

 

If you need it, go ahead and install it or its replacement.

Regular Advisor
silusan
Posts: 136
Registered: ‎08-23-2011
Message 7 of 7 (186 Views)

Re: SPC1131 vulnerability patch bundle for VSE-OE

I am not sure if we need it...but as it is present in our old servers.... I will try to download it from hp and install in our new VSE OE server.

 

thanks

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.