I need to install atdd but problems (354 Views)
Reply
Occasional Advisor
Raef
Posts: 9
Registered: ‎03-10-2011
Message 1 of 5 (354 Views)

I need to install atdd but problems

Hello i was trying to install atdd (drivers for ibm 3576 tape)
using winscp i have deleted root under var/spool/sw

i m trying to re install or remove the driver but i have errors!

# uname -a -r
HP-UX TNec6qs2 B.11.23 U ia64 2408691456 unlimited-user license

# uname -a -r
HP-UX TNec6qs2 B.11.23 U ia64 2408691456 unlimited-user license

# swlist -d atdd
# Initializing...
# Contacting target "TNec6qs2"...
#
# Target: TNec6qs2:/var/spool/sw
#

# atdd 5.5.2.6 GES IBM tape and changer device driver for TotalStorage
atdd.driver IBM Advanced Tape Device Driver
# atdd 5.6.2.6 GES IBM tape and changer device driver for TotalStorage
atdd.driver IBM Advanced Tape Device Driver


# swinstall -x ask=true atdd

======= 03/10/11 17:00:53 WAT BEGIN swinstall SESSION
(non-interactive) (jobid=TNec6qs2-0139)

* Session started for user "root@TNec6qs2".

* Beginning Selection

* Target connection succeeded for "TNec6qs2:/".
* Source connection succeeded for "TNec6qs2:/var/spool/sw".
ERROR: Could not access remote file "INFO" in software item
"atdd,r=5.5.2.6,a=,v=". The file could not be found on the
remote system.
ERROR: IC software object library error: SOL_ProductOpenAskCatalog
(Internal error)

======= 03/10/11 17:00:54 WAT END swinstall SESSION (non-interactive)
(jobid=TNec6qs2-0139)

swcopy -s /test/ibm/atdd.5.6.2.6.bin atdd
WARNING: The logfile, "/var/adm/sw/swcopy.log" is in use by process
"19810". The log information will be intermixed unless a
different logfile is given. To select a new logfile, specify
the "-x logfile=" option on the command line.

======= 03/10/11 17:02:56 WAT BEGIN swcopy SESSION (non-interactive)
(jobid=TNec6qs2-0143)

* Session started for user "root@TNec6qs2".

* Beginning Selection
* Target connection succeeded for "TNec6qs2:/var/spool/sw".
* Source: /test/ibm/atdd.5.6.2.6.bin
* Targets: TNec6qs2:/var/spool/sw
* Software selections:
atdd.driver,r=5.6.2.6
* Selection succeeded.


* Beginning Analysis and Execution
* Session selections have been saved in the file
"/.sw/sessions/swcopy.last".
* "TNec6qs2:/var/spool/sw": 1 filesets have the selected
revision already installed.
* Analysis and Execution succeeded.


NOTE: More information may be found in the agent logfile using the
command "swjob -a log TNec6qs2-0143 @ TNec6qs2:/var/spool/sw".

======= 03/10/11 17:02:56 WAT END swcopy SESSION (non-interactive)
(jobid=TNec6qs2-0143)

# swinstall -x ask=true atdd

======= 03/10/11 17:03:33 WAT BEGIN swinstall SESSION
(non-interactive) (jobid=TNec6qs2-0144)

* Session started for user "root@TNec6qs2".

* Beginning Selection
* Target connection succeeded for "TNec6qs2:/".
* Source connection succeeded for "TNec6qs2:/var/spool/sw".
ERROR: Could not access remote file "INFO" in software item
"atdd,r=5.5.2.6,a=,v=". The file could not be found on the
remote system.
ERROR: IC software object library error: SOL_ProductOpenAskCatalog
(Internal error)

======= 03/10/11 17:03:34 WAT END swinstall SESSION (non-interactive)
(jobid=TNec6qs2-0144)


Im new on HP ux plz help :)
Occasional Advisor
Raef
Posts: 9
Registered: ‎03-10-2011
Message 2 of 5 (354 Views)

Re: I need to install atdd but problems

swremove atdd

======= 03/10/11 17:10:11 WAT BEGIN swremove SESSION
(non-interactive) (jobid=TNec6qs2-0146)

* Session started for user "root@TNec6qs2".

* Beginning Selection
* Target connection succeeded for "TNec6qs2:/".
ERROR: Could not remove the software selection "atdd"; it is not
available from depot or root "TNec6qs2:/".
* Software selection failed for "TNec6qs2:/".
ERROR: Cannot continue the "swremove" task.
* Selection had errors.



======= 03/10/11 17:10:12 WAT END swremove SESSION (non-interactive)
(jobid=TNec6qs2-0146)

Acclaimed Contributor
Dennis Handly
Posts: 25,206
Registered: ‎03-06-2006
Message 3 of 5 (354 Views)

Re: I need to install atdd but problems

>swlist -d atdd

Any reason you are actually using the default depot at /var/spool/sw?

I typically make a depot, swinstall it, then toss it.
swinstall -s /test/ibm/atdd.5.6.2.6.bin atdd

>swinstall -x ask=true atdd

Why are you using "-x ask"? In some install script?

>ERROR: Could not access remote file "INFO" in software item

The depot is corrupted?

>swremove atdd

Nothing to remove since not installed.
Occasional Advisor
Raef
Posts: 9
Registered: ‎03-10-2011
Message 4 of 5 (354 Views)

Re: I need to install atdd but problems

Thanks for reply
I have solved the problem
I have deleted the folder under /var/spool/sw containing the drivers

so i thinks install remained corrupted
during new install it say that already instaled try reinstall=true
but when i use it info is missing
i have deleted a txt file containing this kind of info
mod_time 1299684948
create_time 1299684947
machine_type ia64*
os_name HP-UX
os_release ?.11.2*
os_version ?
directory /opt/atdd
all_filesets driver
is_locatable true
readme fileset
tag driver
data_model_revision 2.40
instance_id 1
control_directory driver
size 1840510
title "IBM Advanced Tape Device Driver"
description "
This fileset contains the binaries, include files, manual pages,
and debug utilities for the IBM Advanced Tape Device Driver developed
by Gresham Enterprise Storage, Austin, TX.


"
mod_time 1299684948
create_time 1299684947
state available
product
tag atdd
data_model_revision 2.40
instance_id 2
control_directory atdd.2
revision 5.6.2.6
title "GES IBM tape and changer device driver for TotalStorage"
description "
This fileset contains the binaries, include files, manual pages,
and debug utilities for the IBM Advanced Tape Device Driver developed


and it worked!

Thank you again
Occasional Advisor
Raef
Posts: 9
Registered: ‎03-10-2011
Message 5 of 5 (354 Views)

Re: I need to install atdd but problems

:)
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.