Re: Error while using SWA : Failed to access authorization service (918 Views)
Reply
Advisor
abhishekjain_48
Posts: 40
Registered: ‎12-20-2012
Message 1 of 8 (948 Views)

Error while using SWA : Failed to access authorization service

[ Edited ]

Hi ,

 

I am trying to use SWA so as to get security bulliteins at regular intervals. I could successfully install C.02.90 version on my hp-ux 11.21 machine(java 1.5.0.26.00).

 

I also got account details to gain access to the HPSC patch database.

I configured swa.conf as well  and tried generating report using:

 

swa report -X /etc/opt/swa/swa.conf

 

but got the error:

ERROR:   Failed to access authorization service

 

Could someone help on how to correct this.

I also already tried Installing Intermediate Certificates for Software Assistant.

 

Regards

Abhishek

 

 

 

P.S.This thread has been moved from HP-UX>Security to HP-UX > patches- HP Forums Moderator

Honored Contributor
Stephan.
Posts: 512
Registered: ‎10-31-2002
Message 2 of 8 (918 Views)

Re: Error while using SWA : Failed to access authorization service

Advisor
abhishekjain_48
Posts: 40
Registered: ‎12-20-2012
Message 3 of 8 (908 Views)

Re: Error while using SWA : Failed to access authorization service

thanks Stephan for the link....

 

I had already tried instaling certificates as mentioned in link you provided..

 the same procedure i found @ http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c03011766/c03011766.pdf

 

Regards

Abhishek J

Honored Contributor
Stephan.
Posts: 512
Registered: ‎10-31-2002
Message 4 of 8 (902 Views)

Re: Error while using SWA : Failed to access authorization service

Ups, the shiny red error message distracted me from the rest of your post ... sorry for that.

 

Some questions:

 

- Did it work at any time?

- Did you try updating Java and reinstalling SWA?

- Did the installation of SWA went smooth or did you get some warnings/errors? ('swjob')

- Does an 'swverify SWA' provide some warnings/errors?

 

Personally my first try would be upgrading java and reinstall SWA afterwards - I had the the same problem as 2.90 was pretty new and that solved it every time.

 

hth,

Stephan

Advisor
abhishekjain_48
Posts: 40
Registered: ‎12-20-2012
Message 5 of 8 (884 Views)

Re: Error while using SWA : Failed to access authorization service

Hi Stephan ,

 

Its not working from time i  installed SWA...

Installation went quite smooth...

java is alraedy been upgarded to :

 

Java15JDK                     1.5.0.26.00    Java 1.5 JDK for HP-UX
Java60JDK                     1.6.0.16.00    Java 6.0 JDK for HP-UX

 

 is something needs to change in swa conf file.

 

I checked on net and got to know taht 2.90 has some issues...

can i try instaling some older version... please suggest and from i can downnlaod it.

 

 

Regards
Abhishek J

Advisor
abhishekjain_48
Posts: 40
Registered: ‎12-20-2012
Message 6 of 8 (856 Views)

Re: Error while using SWA : Failed to access authorization service

i just tried re-installation on my hp-ux box(11i v3)..

 

 followed by installing certificates and then configuring  /etc/opt/swa/swa.conf.

 

java version is proper as:

 

Java15JDK                     1.5.0.26.00    Java 1.5 JDK for HP-UX
Java60JDK                     1.6.0.16.00    Java 6.0 JDK for HP-UX

I ran SWA in debug mode and found the below error:

 

ERROR:   Failed to access authorization service.
         - SMDExcep was thrown from the following location:
           file: jni/SSWAProxy.cc
           method: SSWAProxy::callGetToken
           line: 610.

It looks like some thing xtra needs to be configured in "/etc/opt/swa/swa.conf".

 

i just added hp_id and hp_pw in file.

 

is some proxy settings needed?

 

Regards

Abhishek Jain

                       

 

Honored Contributor
Stephan.
Posts: 512
Registered: ‎10-31-2002
Message 7 of 8 (847 Views)

Re: Error while using SWA : Failed to access authorization service

A proxy only need to be defined if you use/require one.

 

My wild guess goes back to the certifacte/java problem, did you check this thread?

 

http://h30499.www3.hp.com/t5/Patches/SWA-and-ITRC-to-HPSC-migration/td-p/5326027

 

hth,

Stephan

Advisor
abhishekjain_48
Posts: 40
Registered: ‎12-20-2012
Message 8 of 8 (839 Views)

Re: Error while using SWA : Failed to access authorization service

hi ,

 

i tried swverify SWA and got below o/p:

 

 Software selections:
           + Jre15.JRE15-COM,l=/opt/java1.5,r=1.5.0.26.00,a=HP-UX_B.11.11_32/64,v=HP,fr=1.5.0.26.00,fa=HP-UX_B.11.11_32/64
           + Jre15.JRE15-COM-DOC,l=/opt/java1.5,r=1.5.0.26.00,a=HP-UX_B.11.11_32/64,v=HP,fr=1.5.0.26.00,fa=HP-UX_B.11.11_32/64
           + Judy-lib.JUDY,l=/,r=B.11.31.04.18,a=HP-UX_B.11.31_IA/PA,v=HP,fr=B.11.31.04.18,fa=HP-UX_B.11.31_IA
           + Judy-lib.JUDY-COMMON,l=/,r=B.11.31.04.18,a=HP-UX_B.11.31_IA/PA,v=HP,fr=B.11.31.04.18,fa=HP-UX_B.11.31_IA/PA
             SWA.SWA-JAR,l=/,r=C.02.90,a=HP-UX_B.11.23_IA/PA,v=HP,fr=C.02.90,fa=HP-UX_B.11.23_IA/PA
             SWA.SWA-MX,l=/,r=C.02.90,a=HP-UX_B.11.23_IA/PA,v=HP,fr=C.02.90,fa=HP-UX_B.11.23_IA/PA
             SWA.SWA-REPORT,l=/,r=C.02.90,a=HP-UX_B.11.23_IA/PA,v=HP,fr=C.02.90,fa=HP-UX_B.11.23_IA/PA
             SWA.SWA-SH,l=/,r=C.02.90,a=HP-UX_B.11.23_IA/PA,v=HP,fr=C.02.90,fa=HP-UX_B.11.23_IA/PA
           + SwaMin.SWA-RUN,l=/,r=C.02.90,a=HP-UX_B.11.23_IA/PA,v=HP,fr=C.02.90,fa=HP-UX_B.11.23_IA
       * A "+" indicates an automatic selection due to dependency or
         the automatic selection of a patch or reference bundle.
       * Selection succeeded.


       * Beginning Analysis
       * Session selections have been saved in the file
         "/.sw/sessions/swverify.last".
       * The analysis phase succeeded for "###:/".
       * Verification succeeded.

 

I also tried swjob -a log ###-0027 @ ####:/ and got below o/p:

 

     * Reading source for file information.
       *     Configured    Jre15.JRE15-COM,l=/opt/java1.5,r=1.5.0.26.00
       *     Configured    Jre15.JRE15-COM-DOC,l=/opt/java1.5,r=1.5.0.26.00
       *     Configured    Judy-lib.JUDY,l=/,r=B.11.31.04.18
       *     Configured    Judy-lib.JUDY-COMMON,l=/,r=B.11.31.04.18
       *     Configured    SWA.SWA-JAR,l=/,r=C.02.90
       *     Configured    SWA.SWA-MX,l=/,r=C.02.90
       *     Configured    SWA.SWA-REPORT,l=/,r=C.02.90
       *     Configured    SWA.SWA-SH,l=/,r=C.02.90
       *     Configured    SwaMin.SWA-RUN,l=/,r=C.02.90

       * Summary of Analysis Phase:
           + Verified      Jre15.JRE15-COM,l=/opt/java1.5,r=1.5.0.26.00
           + Verified      Jre15.JRE15-COM-DOC,l=/opt/java1.5,r=1.5.0.26.00
           + Verified      Judy-lib.JUDY,l=/,r=B.11.31.04.18
           + Verified      Judy-lib.JUDY-COMMON,l=/,r=B.11.31.04.18
             Verified      SWA.SWA-JAR,l=/,r=C.02.90
             Verified      SWA.SWA-MX,l=/,r=C.02.90
             Verified      SWA.SWA-REPORT,l=/,r=C.02.90
             Verified      SWA.SWA-SH,l=/,r=C.02.90
           + Verified      SwaMin.SWA-RUN,l=/,r=C.02.90
       * 9 of 9 filesets had no Errors or Warnings.
       * The Analysis Phase succeeded.

 

and regarding certificates i executed openssl x509 -in /etc/CA-V3C3Gint -fingerprint -md5
 and got correct md5 fingerprint


I had currently placed cert. in /etc/CA-V3C3Gint should i move this somewhere else... cert. installation was also successfull...

 

it would helpfull ifu can provide sample swa conf file which i can refer to.

 

Regards

Abhishek Jain

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.