Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11 (1343 Views)
Reply
Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 1 of 16 (1,504 Views)

No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11.02"

Good day

I have the problem in HP Performance Manager to check the system information of a node I send the message:

No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds

But the revised coda this working well:
C:\Documents and Settings\hpnahg > ovcodautil - status - n 172.16.254.90
CODA daemon running

C:\Documents and Settings\hpnahg > ovcodautil - ping - n 172.16.254.90
Ping of 'OvBbcCb' at: ' http://172.16.254.90: 383/Hewlett-Packard OpenView/BBC/pin
g' successful
Ping of 'coda' at: ' http://172.16.254.90: 383/Hewlett-Packard/OpenView/Coda /' suc
cessful

on the managed node, this is the output of ovcodautil support:

[root@apclmsql01 bin] #. /ovcodautil - support
Data source CODA disabled.
Data source SCOPE enabled.
= 10/04/13 12:30:00 PM
Instance: 0
GBL_STATTIME: 12:35:01
GBL_INTERVAL: 300
GBL_INTERRUPT_RATE: 185.80
GBL_ACTIVE_CPU: 16
GBL_CPU_TOTAL_UTIL: 1.86
GBL_CPU_SYS_MODE_UTIL: 1.33
GBL_CPU_USER_MODE_UTIL: 0.53
GBL_DISK_PHYS_IO_RATE: 6.90
GBL_FS_SPACE_UTIL_PEAK: 77.69
GBL_MEM_UTIL: 23.21
GBL_SWAP_SPACE_UTIL: 0.00
GBL_MEM_PAGEOUT_RATE: 0.00
GBL_MEM_PAGEIN_RATE: 0.00
GBL_NET_ERROR_RATE: 0.00
GBL_NET_IN_PACKET_RATE: 82.30
GBL_NET_OUT_PACKET_RATE: 94.20
GBL_RUN_QUEUE: 1.00
GBL_NUM_DISK: 7
GBL_SWAP_SPACE_AVAIL: 8189
GBL_NUM_NETWORK: 6
GBL_COLLECTOR: SCOPE/UX 11.02.009 (2)
GBL_OSNAME: Linux
GBL_OSRELEASE: 2.6.18-348.16.1. el5PAE
GBL_OSVERSION: #1 SMP Sat Jul 27 01:08:12 EDT 2013
GBL_MACHINE: i686
GBL_NUM_CPU: 16
GBL_MEM_PHYS: 8119



All my services are initiated

CODA OV Performance Core COREXT (13140) Running
opcacta OVO Action Agent AGENT, EA (13058) Running
opcle OVO Logfile Encapsulator AGENT, EA (13158) Running
opcmona OVO Monitor Agent AGENT, EA (13168) Running
opcmsga OVO Message Agent AGENT, EA (13108) Running
opcmsgi OVO Message Interceptor AGENT, EA (13049) Running
ovbbccb OV Communication Broker CORE (12960) Running
ovcd OV Control CORE (12867) Running
ovconfd OV Config and Deploy COREXT (13012) Running
rtmd HP Real Time Measurement AGENT (13183) Running
[root@apclmsql01 bin] #. /opcagt
scopeux Perf Agent data collector (12944) Running
mydaemon Measurement Interface (12843) Running daemon
TTD ARM registration daemon Running (8897)
perfalarm Alarm generator (13213) Running
perfd real time server (12837) Running
CODA OV Performance Core COREXT (13140) Running
opcacta OVO Action Agent AGENT, EA (13058) Running
opcle OVO Logfile Encapsulator AGENT, EA (13158) Running
opcmona OVO Monitor Agent AGENT, EA (13168) Running
opcmsga OVO Message Agent AGENT, EA (13108) Running
opcmsgi OVO Message Interceptor AGENT, EA (13049) Running
rtmd HP Real Time Measurement AGENT (13183) Running
Message Agent is not buffering.
[root@apclmsql01 bin] # cd /opt/perf/bin
[root@apclmsql01 bin] #. /perfstat - p
**********************************************************
* perfstat for apclmsql01 on Fri Oct 4 12:45:39 CDT 2013
* Linux 2.6.18-348.16.1 apclmsql01. el5PAE #1 SMP Sat Jul 27 01:08:12 EDT 2013 i686 i686 i386 GNU/Linux
**********************************************************

list of performance tool processes:
----------------------------------

Perf Agent status:
Running scopeux (Perf Agent data collector) pid 12944
Running mydaemon (Measurement Interface daemon) pid 12843
Running ttd (ARM registration daemon) pid 8897

Perf Agent Server status:

Ovcd running (OV control component) pid 12867
Running ovbbccb (BBC5 communication broker) pid 12960
Running coda (perf component) pid (s) 13140
configured DataSources (1)
SCOPE

Running perfalarm (alarm generator) pid (s) 13213
Running perfd (perfd daemon (real time server)) pid 12837
OV Operation Agent status:
CODA OV Performance Core COREXT (13140) Running
opcacta OVO Action Agent AGENT, EA (13058) Running
opcle OVO Logfile Encapsulator AGENT, EA (13158) Running
opcmona OVO Monitor Agent AGENT, EA (13168) Running
opcmsga OVO Message Agent AGENT, EA (13108) Running
opcmsgi OVO Message Interceptor AGENT, EA (13049) Running
ovbbccb OV Communication Broker CORE (12960) Running
ovcd OV Control CORE (12867) Running
ovconfd OV Config and Deploy COREXT (13012) Running
rtmd HP Real Time Measurement AGENT (13183) Running


* (end of perfstat - p output) *


any ideas?

Best regards

HP Expert
Priyadarshini B S
Posts: 39
Registered: ‎06-24-2010
Message 2 of 16 (1,481 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

Hi,

 

How is the managed node added in PM? As ovcodautil -ping  is working fine, try adding the node with IP/short name in PM and check if that works. Something to do with the name resolution..

 

Cheers,

Priya

Honored Contributor
m_vidyasagar
Posts: 636
Registered: ‎04-21-2011
Message 3 of 16 (1,477 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

This happens to me sometimes .. I eventually bounce the agent services , then it starts working normally .. 

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 4 of 16 (1,464 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

Thank you

The node is added in WP in the hosts file and then create on HP PM

Ovcodautil - ping or - status respond well by the short name:


C:\Documents and Settings\hpnahg > ovcodautil - ping - n apclmsql01
Ping of 'OvBbcCb' at: ' http://apclmsql01: 383/Hewlett-Packard/OpenView/BBC/ping '
successful
Ping of 'coda' at: ' http://apclmsql01: 383/Hewlett-Packard/OpenView/Coda /' succes
sful

C:\Documents and Settings\hpnahg > ovcodautil - status - n apclmsql01
CODA daemon running

Best regards

Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 5 of 16 (1,457 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

reviewing the settings on the managed node I found:

. /perfstat - v

Perf Agent Datacomm Type: http

But not this reporting to HP PM

in the following command I found:

. /perfstat - d

Datacomm configuration:
------------------------

CODA Port 53518 (Dynamic)
Single port Communication

BBC communication broker port 383
SSL security NONE
CODA Metric Collection (Prospector) Deprecated



Any ideas?

Honored Contributor
m_vidyasagar
Posts: 636
Registered: ‎04-21-2011
Message 6 of 16 (1,446 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

[ Edited ]

Hi Nestor,

 

In my env I see the output of perfstat -d :

 

List of datacomm servers for node: EMSEC
============================================================
PA Datacomm Type: HTTP

coda is running at port [383] (Dynamic)
Single port Communication
BBC communication broker port 383
SSL security NONE
Coda Metric Collection(Prospector) Deprecated

************* (end of perfstat -d output) ***********

 


By default the Coda needs 2 ports :

(a) port 383 for communicating with the communication broker 

(b) Random port to transfer the performance data whenever you request .

 

As per my knowledge since in your case the coda is running on the port 53518 , so it is not able to listen to the incoming request coming from the communication broker on port 383..

 

Have you stopped the OA agent ( ovc -kill , opcagt -stop ) and PA agent ( ovpacmd stop ) and started ? 

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 7 of 16 (1,434 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

Thank you Vidyasagar


If you run the commands to stop operation and performance services.

In fact, to update the agent of 8.53 to 11.02, but still with the same problem.

I have communication with the 383 port to the server's performance, but I have questions about the port that you mention 53518, if this must have output also to my server from PA.

How can I validate the correct communication with the port 53518?

Best regards

Honored Contributor
m_vidyasagar
Posts: 636
Registered: ‎04-21-2011
Message 8 of 16 (1,424 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

>> Is there any firewall between management server and agent ?

 

>> Check if the port 53518 is getting blocked or not ... You can use the tool like portqry to check connectivity to a specific port ..

 

>> Also from the OMW/PM server , can you get the output for the below command :

      ovcodautil -support -n HOSTNAME_OF_THE_AGENT

 

>> On the Agent side , what is the output of : ovconfget coda.comm

 

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 9 of 16 (1,417 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

Thanks Vidyasagar


Tea shipping the output of the commands that you requested:

C:\Documents and Settings\hpnahg > ovcodautil - support - n aclmsql01_OF_THE_AGENT
CODA daemon NOT running.
CODA daemon NOT running.




[root@apclmsql01 bin] #. /ovconfget coda.comm
LOG_SERVER_ACCESS = false
SERVER_BIND_ADDR = localhost
SERVER_PORT = 0



The coda is not running with that command, but if I have active services


[root@apclmsql01 bin] #. /ovc
CODA OV Performance Core COREXT (8342) Running
opcacta OVO Action Agent AGENT, EA (8309) Running
opcle OVO Logfile Encapsulator AGENT, EA (8376) Running
opcmona OVO Monitor Agent AGENT, EA (8363) Running
opcmsga OVO Message Agent AGENT, EA (8285) Running
opcmsgi OVO Message Interceptor AGENT, EA (8335) Running
ovbbccb OV Communication Broker CORE Running (4951)
ovcd OV Control CORE (4926) Running
ovconfd OV Config and Deploy COREXT (8238) Running
rtmd HP Real Time Measurement AGENT (8326) Running
[root@apclmsql01 bin] #. /opcagt
scopeux Perf Agent data collector Running (7199)
mydaemon Measurement Interface daemon Running (4919)
TTD ARM registration daemon Running (5155)
perfalarm Alarm generator (7236) Running
perfd real time server Running (4914)
CODA OV Performance Core COREXT (8342) Running
opcacta OVO Action Agent AGENT, EA (8309) Running
opcle OVO Logfile Encapsulator AGENT, EA (8376) Running
opcmona OVO Monitor Agent AGENT, EA (8363) Running
opcmsga OVO Message Agent AGENT, EA (8285) Running
opcmsgi OVO Message Interceptor AGENT, EA (8335) Running
rtmd HP Real Time Measurement AGENT (8326) Running
Message Agent is not buffering.


And shipment of core id, becomes the OMU HP and HP OMU can send you the certificates.

rare case.

Best regards

Honored Contributor
m_vidyasagar
Posts: 636
Registered: ‎04-21-2011
Message 10 of 16 (1,395 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

Hi Nestor,

 

Hope you are doing good ..!!

 

[ You have executed "ovcodautil - support - n aclmsql01" on the omw server , but checked the status on "apclmsql01" ..  i can see both are different servers .. have a cross check once  ]

 

Rather than assigning the dynamic port to the CODA , make it static by assigning it to run on the port 381 [ port 381 must be opened in case if you are dealing with firewall environment ] :

 

# ovconfchg -ns coda.comm -set SERVER_PORT 381 

 

# ovc -kill

 

# opcagt -stop

 

# ovc -start

 

# opcagt -start

 

Now try the following command from the OMW server:

 

ovcodautil - support - n HOSTNAME_OF_REMOTE_AGENT

 

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 11 of 16 (1,383 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

Tnks Machani

 

This is the output that I run on the node

[root@apclmsql01 bin] #. /ovconfchg - ns coda.comm - set SERVER_PORT 381
[root@apclmsql01 bin] #. /ovc - kill
[root@apclmsql01 bin] #. /opcagt - stop
[root@apclmsql01 bin] #. /ovc - start
[root@apclmsql01 bin] #. /opcagt - start


All as you indicate

but already running on the server HP PM the result is the same:

C:\Documents and Settings\hpnahg > ovcodautil - support - n aclmsql01_OF_THE_AGENT
CODA daemon NOT running.
CODA daemon NOT running.

 

Best regards

Honored Contributor
m_vidyasagar
Posts: 636
Registered: ‎04-21-2011
Message 12 of 16 (1,379 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

[ Edited ]

Hello Nestor,

 

I haven't received the answer for the Q in the previous post :

 

[ You have executed "ovcodautil - support - n aclmsql01" on the omw server , but checked the status on "apclmsql01" ..  i can see both are different servers .. have a cross check once  ]

Are you sure that hostname you are using in the either case are same and the name resolution is set properly , check once ?? 

 

I guess there could be wrong with the hostname , i mean , check the IP ..

 

Are you sure that port 381 is opened bi-directionally??

 

Execute the following command from the OMWserver , what is the output ? :

 

ovdeploy -cmd "ovcodautil -support" -host REMOTE_AGENT

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 13 of 16 (1,358 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

Gracias

Te copio los resutados de las pruebas:

El puerto si esta bidireccional

Nota: el agente de Operacion si reporta al HP OMU pero el agente de Performance no reporta a HP Performance Manager


Tengo actualmente la version 6 de HP PM, tengo duda si puede estar afectando el nivel de version del Agente 11.02 a la version de HP PM, que en realidad tengo mas equipos con 11.02 y no tengo la misma afectacion.

Pruebas:


C:\Documents and Settings\hpnahg>ovcodautil -status -n apclmsql01
Coda daemon running

C:\Documents and Settings\hpnahg>nslookup apclmsql01
Server:  dnsi-1.triara.apodaca
Address:  172.16.254.70

DNS request timed out.
    timeout was 2 seconds.
*** Request to dnsi-1.triara.apodaca timed-out

Conect

root apmnovo0 / # ovdeploy -cmd "ovcodautil -support" -host apclmsql01
Data source CODA disabled.
Data source SCOPE enabled.
=== 10/21/13 05:05:00 PM
Instance                          : 0
GBL_STATTIME                      : 17:10:00
GBL_INTERVAL                      : 300
GBL_INTERRUPT_RATE                : 296.20
GBL_ACTIVE_CPU                    : 16
GBL_CPU_TOTAL_UTIL                : 7.72
GBL_CPU_SYS_MODE_UTIL             : 5.76
GBL_CPU_USER_MODE_UTIL            : 1.96
GBL_DISK_PHYS_IO_RATE             : 8.00
GBL_FS_SPACE_UTIL_PEAK            : 52.54
GBL_MEM_UTIL                      : 24.43
GBL_SWAP_SPACE_UTIL               : 0.00
GBL_MEM_PAGEOUT_RATE              : 0.00
GBL_MEM_PAGEIN_RATE               : 0.00
GBL_NET_ERROR_RATE                : 0.00
GBL_NET_IN_PACKET_RATE            : 146.30
GBL_NET_OUT_PACKET_RATE           : 231.50
GBL_RUN_QUEUE                     : 2.00
GBL_NUM_DISK                      : 7
GBL_SWAP_SPACE_AVAIL              : 8189
GBL_NUM_NETWORK                   : 6
GBL_COLLECTOR                     : SCOPE/UX 11.02.009(2)
GBL_OSNAME                        : Linux
GBL_OSRELEASE                     : 2.6.18-371.el5PAE
GBL_OSVERSION                     : #1 SMP Thu Sep 5 21:23:35 EDT 2013
GBL_MACHINE                       : i686
GBL_NUM_CPU                       : 16
GBL_MEM_PHYS                      : 8119

Saludos

Honored Contributor
m_vidyasagar
Posts: 636
Registered: ‎04-21-2011
Message 14 of 16 (1,351 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

I'm sorry can you please post in english as I can't understand Spanish ..

 

Also I can see that the agent "apclmsql01" has the name resolution problem ..

 

Make an entry of the "apclmsql01" in the "hosts" files of the PM Server .. and then pull the graph ..

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 15 of 16 (1,343 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

Sorry..

 


You copy the results of the tests:

The port if this bi-directional

Note: Agent operation if he reports to the OMU HP but the agent's Performance not report to HP Performance Manager


I currently have version 6 HP PM, I doubt if it may be affected the level of 11.02 Agent version version of HP PM, actually I have more teams with 11.02 and not have the same effect.

Tests:


C:\Documents and Settings\hpnahg > ovcodautil - status - n apclmsql01
CODA daemon running

C:\Documents and Settings\hpnahg > nslookup apclmsql01
Server: dnsi-1.triara.apodaca
Address: 172.16.254.70

DNS request timed out.
timeout was 2 seconds.
* Request to dnsi-1.triara.apodaca timed-out

Conect

root apmnovo0 / # ovdeploy - cmd "ovcodautil - support"-host apclmsql01
Data source CODA disabled.
Data source SCOPE enabled.
= 10/21/13 05:05:00 PM
Instance: 0
GBL_STATTIME: 17:10:00
GBL_INTERVAL: 300
GBL_INTERRUPT_RATE: 296.20
GBL_ACTIVE_CPU: 16
GBL_CPU_TOTAL_UTIL: 7.72
GBL_CPU_SYS_MODE_UTIL: 5.76
GBL_CPU_USER_MODE_UTIL: 1.96
GBL_DISK_PHYS_IO_RATE: 8.00
GBL_FS_SPACE_UTIL_PEAK: 52.54
GBL_MEM_UTIL: 24.43
GBL_SWAP_SPACE_UTIL: 0.00
GBL_MEM_PAGEOUT_RATE: 0.00
GBL_MEM_PAGEIN_RATE: 0.00
GBL_NET_ERROR_RATE: 0.00
GBL_NET_IN_PACKET_RATE: 146.30
GBL_NET_OUT_PACKET_RATE: 231.50
GBL_RUN_QUEUE: 2.00
GBL_NUM_DISK: 7
GBL_SWAP_SPACE_AVAIL: 8189
GBL_NUM_NETWORK: 6
GBL_COLLECTOR: SCOPE/UX 11.02.009 (2)
GBL_OSNAME: Linux
GBL_OSRELEASE: 2.6.18-371.el5PAE
GBL_OSVERSION: #1 SMP Thu Sep 5 21:23:35 EDT 2013
GBL_MACHINE: i686
GBL_NUM_CPU: 16
GBL_MEM_PHYS: 8119

Best regards
Knowing is not enough, we must apply. Being willing is not enough: we must implement it.
(Goethe)

Honored Contributor
m_vidyasagar
Posts: 636
Registered: ‎04-21-2011
Message 16 of 16 (1,334 Views)

Re: No CODA data source was found (OVO-EPC or OVPA BBC datacomm) after 42.02 seconds "HP OA 11

Have you done what mentioned in my previous post :

 

Also I can see that the agent "apclmsql01" has the name resolution problem ..

 

Make an entry of the "apclmsql01" in the "hosts" files of the PM Server .. and then pull the graph ..

 

Also I remember that while adding the nodes in the older vesions PM  like 6,7 , you have to select the datasource of the Node either as CODA or SCOPE , you might have selected the CODA ..

 

Remove the Node from PM and then add again by selecting the Datasource as Scope ( before this make the etc/hosts entry on either servers )..

- Vidyasagar Machani -

Tell me and I forget. Teach me and I remember. Involve me and I learn. -- Benjamin Franklin
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.