usb port not detecting devices when plugged into usb port. (369 Views)
Reply
Occasional Visitor
cracker
Posts: 1
Registered: ‎12-17-2009
Message 1 of 3 (369 Views)

usb port not detecting devices when plugged into usb port.

I have a Omnibook 6000 and been having problems with my usb port. It was working fine, than one day just quit. I checked the device manager and it reads "device working properly", no conflict's listed. I'm unable to run diagnostic test. I had a usb "4 way external hub", with only cooling fan, and camera plugged in. One day it just quit. In desperate need of direction. My o/s is XP Professional sp3.
Regular Advisor
P
Posts: 95
Registered: ‎08-10-2003
Message 2 of 3 (369 Views)

Re: usb port not detecting devices when plugged into usb port.

Try connecting another USB device directly (without the hub) like a mouse, keyboard, camera, or flash drive. If the new device is recognized, the port is working fine and your hub is defective. If the new device is not recognized, try the following: In Device Manager, highlight the USB port and uninstall it. Restart your laptop and let XP reinstall the USB device...

Merry Xmas,

pl
Honored Contributor
Mark W.
Posts: 2,091
Registered: ‎11-30-2001
Message 3 of 3 (369 Views)

Re: usb port not detecting devices when plugged into usb port.

Heavily used USB ports can come loose from the motherboard. Oftentimes this can be repaired by an electronics technician who is very good with a soldering iron though. Alternatively you could purchase a CardBus USB card. This has the advantage of giving you USB 2.0 high speed capability.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.