NC6400 Card Reader Not Working - Showing in Device Mgr (1612 Views)
Reply
Advisor
Tom Scott_2
Posts: 30
Registered: ‎11-10-2005
Message 1 of 13 (1,612 Views)

NC6400 Card Reader Not Working - Showing in Device Mgr

I have a Compaq NC6400 laptop. I recently installed XP from scratch (format , install , no recovery CD).

After installing I downloaded all the drivers from HP's site (including the Texas Instruments Media Card driver)..

It shows up in device manager (attached screen shot) but doesn't do anything when I put a SD card in (no Windows sound ack me putting it in..)

Any ideas?

Thanks
Please use plain text.
Honored Contributor
banhien
Posts: 3,667
Registered: ‎08-21-2007
Message 2 of 13 (1,612 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

Hi Scott,

I would uninstall it and then install it again. Note: totally uninstall it first.

BH
BH
====
**Click the KUDOS star on the left to say 'Thanks'**
Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.
Please use plain text.
Advisor
Tom Scott_2
Posts: 30
Registered: ‎11-10-2005
Message 3 of 13 (1,612 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

I tried that already and it didn't work..

I tried it again just for grins and it didn't work this time either.

Thanks
Please use plain text.
Advisor
hy_vong
Posts: 10
Registered: ‎05-15-2008
Message 4 of 13 (1,612 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

I'm concerned about the missing "HP Integrated Module" driver shown in Device Manager with the yellow exclamation mark. The unknown device I believe can be resolved by installing the Quick Launch Buttons driver. If not, try installing "HP ProtectTools Security Manager" and "HP Embedded Security for ProtectTools and Infineon TPM Driver".

Here's the link to the drivers page for your laptop:
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=1847704&...

Under Operating System - Enhancements and QFEs download "Intel Chipset Installation Utility for ICH7" and the "High-Speed Secure Digital Card Driver".

If the "HP Integrated Module" still shows up w/ the yellow exclamation mark, double click on it and select the Driver tab then click the Reinstall Driver button. Hopefully, it can automatically locate the correct drivers for you. If not, go through the tabs and see what information is provided and post that information here. Hope that helps.
Please use plain text.
Frequent Advisor
Steve_668
Posts: 41
Registered: ‎04-19-2007
Message 5 of 13 (1,612 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

I just had a similar sort of problem with a yellow exclamation mark with my nc 4010 laptop.
The problem device was the SD card reader and it was solved by installing the following 2 files...

1 .... 02Micro Smart CardBus Reader software for windows 2000/XP
2 .... 02Micro Memory CardBus Accelerator driver

Obviously, the files that worked for me may not work for you. Different laptop etc but you may find something similar if you have a poke around inside the Software - System management section in your own laptops driver files section.
Please use plain text.
Advisor
Tom Scott_2
Posts: 30
Registered: ‎11-10-2005
Message 6 of 13 (1,612 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

Thanks for the replies..

Still not working. I've installed every piece of driver / software off the driver page for my laptop and still nothing.. Like I said, it shows up in device manager, but doesn't do ANYTHING when I insert the card..

I had this happen to me with another HP laptop before as well.. After formatting and reinstalling XP from scratch on it and downloading the drivers from their site it wouldn't work.. I ended up finding the CD that came with the laptop and installed those drivers for it and poof.. It worked..

Sadly, I don't have the CD that came with this one :(

The "HP Integrated Module" is the bluetooth module and I don't use it so I don't want to install the bloatware that is bluetooth..
Please use plain text.
Frequent Advisor
Steve_668
Posts: 41
Registered: ‎04-19-2007
Message 7 of 13 (1,612 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

These guys will maybe have the restore and driver CDs for your make/model of laptop.
Only snag is that they are in UK and they aren't cheap.
I can say from personal experience that they are very efficient though. I ordered my disks at 3:30 pm and received them at 8am the next morning.
Won't hurt to send them an e-mail, huh?

http://www.gennersales.co.uk/recovery/recovery.htm
Please use plain text.
Occasional Visitor
Jaroslav Ridilla
Posts: 1
Registered: ‎05-20-2008
Message 8 of 13 (1,612 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

I had the same...XP from scratch, no recovery CD, drivers from hp's site...

I just uninstalled Texas Instruments Media Card Driver v 2.0.0.7 B and after reboot installed v 2.0.0.6 A (SP33416)

Now it works .
Please use plain text.
Advisor
Tom Scott_2
Posts: 30
Registered: ‎11-10-2005
Message 9 of 13 (1,612 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

:( That did not work for me..

I uninstalled, rebooted, and installed the 2.0.0.6 A.

Please use plain text.
Occasional Visitor
Blue Smoke
Posts: 4
Registered: ‎05-29-2008
Message 10 of 13 (1,612 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

Please use plain text.
Advisor
Tom Scott_2
Posts: 30
Registered: ‎11-10-2005
Message 11 of 13 (1,369 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

:(

Tried that just now.. Didn't work either..

Please use plain text.
Advisor
Tom Scott_2
Posts: 30
Registered: ‎11-10-2005
Message 12 of 13 (1,369 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

Any other ideas? I am needed the reader again and I still can't get the SOB to work no matter what I try!!!!

Just went on the driver page and downloaded the latest driver (2.0.0.9) but still nothing. :(

Thanks!
Please use plain text.
Occasional Visitor
karoberts1
Posts: 1
Registered: ‎09-25-2009
Message 13 of 13 (1,369 Views)

Re: NC6400 Card Reader Not Working - Showing in Device Mgr

I just ran into the same problem. I installed the drivers and it still didn't work.

Then I had an idea.

I was putting in a 4GB SDHC card.
I then tried a 1GB SD card, and it worked perfectly.

Apparently the SD card reader on NC6400s are NOT SDHC COMPATIBLE!
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation