Compaq 8510p : Unknown device under Win XP (684 Views)
Reply
Occasional Advisor
Reonekot
Posts: 10
Registered: ‎10-03-2007
Message 1 of 15 (684 Views)

Compaq 8510p : Unknown device under Win XP

Hi
I have a problem with our new Compaq 8510p laptops, since we need to run Win XP on them for some months yet.
I have installed all the drivers from the HP support XP Pro site, but I still have one unknown device. It claims the device is on the HD Audio bus, but I already have the soundcard and modem there. (Which is the two devices there on the preinstalled Vista installation)

The device id is:
HDAUDIO\FUNC_01&VEN_1002&DEV_AA01&SUBSYS_00AA0100&REV_1000\5&EFE8BE0&1&0001

Anyone have any idea to what it might be and where I can find the driver for it?

I have attached a zip file with images of the installed components. (Unfortunately their names are in Danish)
Please use plain text.
Valued Contributor
Paulo Guerreiro
Posts: 137
Registered: ‎07-15-2007
Message 2 of 15 (684 Views)

Re: Compaq 8510p : Unknown device under Win XP

I'd install Microsoft Universal Audio Architecture (UAA) Bus Driver for High Definition Audio (SP32646) but wait for other post.

ftp://ftp.hp.com/pub/softpaq/sp32501-33000/sp32646.exe

Regs.
Please use plain text.
Occasional Advisor
Reonekot
Posts: 10
Registered: ‎10-03-2007
Message 3 of 15 (684 Views)

Re: Compaq 8510p : Unknown device under Win XP

That is already installed though. (Soundcard and modem isn't found if it isn't.)
Please use plain text.
Occasional Advisor
adrian bortun
Posts: 6
Registered: ‎11-25-2007
Message 4 of 15 (684 Views)

Re: Compaq 8510p : Unknown device under Win XP

i'm in the same situation but a little wors

i don't have on screen indicatin bar for volume and ligt modifications so any help will be wellcome thanks
Please use plain text.
Super Advisor
Samoila Mircea
Posts: 206
Registered: ‎12-20-2006
Message 5 of 15 (684 Views)

Re: Compaq 8510p : Unknown device under Win XP

Adrian... you have to "Enable Desktop notifinations" in your Quick Launch Menu.
Please use plain text.
Occasional Advisor
adrian bortun
Posts: 6
Registered: ‎11-25-2007
Message 6 of 15 (684 Views)

Re: Compaq 8510p : Unknown device under Win XP

thank you for help ... now it's working .. at the time i wrote the problem i didn.t have instaled the quick lounch application because is not present in HP support page ...


the only problem that still make me curious is why "cpuz" aplication reports constantly a 8x multiplicator for cpu in idle state ... in desctop with no application started and a sporadic use by 2-3% of CPU i have 1600MHz ????
Please use plain text.
Honored Contributor
Marcin W
Posts: 1,083
Registered: ‎09-01-2006
Message 7 of 15 (684 Views)

Re: Compaq 8510p : Unknown device under Win XP

> the only problem that still make
> me curious is why "cpuz"
> aplication reports constantly a
> 8x multiplicator for cpu in idle state ...
> in desctop with no application started
> and a sporadic use by 2-3% of CPU i
> have 1600MHz ????

this is called cpu throttling - when full CPU power isn't required, it's going slower and it can save a lot of energy. This needs support in CPU chip.
You can see my documents and work (and donate, if you like it) on www.gammu.org and www.mwiacek.com
Please use plain text.
Occasional Advisor
adrian bortun
Posts: 6
Registered: ‎11-25-2007
Message 8 of 15 (684 Views)

Re: Compaq 8510p : Unknown device under Win XP

thank you for the answer

to be more specific my CPU goes 8x-11x so its trolling but what about 6x wich specified for intel T7500 ?
Please use plain text.
Frequent Advisor
Jakub Zdzieblo
Posts: 27
Registered: ‎12-07-2007
Message 9 of 15 (684 Views)

Re: Compaq 8510p : Unknown device under Win XP

I guess You have solved the problem??
I had a unknown device in XP but Windows Updated solved the problem for me :) Check that then!
Please use plain text.
Occasional Advisor
adrian bortun
Posts: 6
Registered: ‎11-25-2007
Message 10 of 15 (684 Views)

Re: Compaq 8510p : Unknown device under Win XP

i've rezolved the problem after a while ... the driver on hd audio bus was in fact "ATI function driver for high definition audio" ...instalation metod was to update driver (device manager) and search in the folder where i'd unpak ati drivers (from HP support page)... i can't tell whi the normal setup let a gap in drivers??!!!
Please use plain text.
Occasional Visitor
Roman Popadiuk
Posts: 1
Registered: ‎12-20-2007
Message 11 of 15 (487 Views)

Re: Compaq 8510p : Unknown device under Win XP

Adrian... How did you find the driver from HP? I rebuilt an 8510 because we do not use the OEM OS. Copied the SWSetup directory from the 8510 prior to reimage, and then loaded the drivers back. CANNOT find this HD audio driver. Only the Microsoft HD driver. That I do have in my SWSetup.
Please use plain text.
Occasional Advisor
Reonekot
Posts: 10
Registered: ‎10-03-2007
Message 12 of 15 (487 Views)

Re: Compaq 8510p : Unknown device under Win XP

You need to install the Microsoft HD audio driver first. Then go into Device Manager. Under the system tree there should be a device that isn't installed probably. Double click it and tell it to reinstall the drivers and it will now install the MS drivers properly! (I don't know why the installer downloaded from HP site doesn't work properly. It's the same for all the HP notebooks I have installed, which is quite a few)

After that you should be able to install the real sound card driver, which can be found at the HP site as well.
Please use plain text.
Occasional Advisor
adrian bortun
Posts: 6
Registered: ‎11-25-2007
Message 13 of 15 (487 Views)

Re: Compaq 8510p : Unknown device under Win XP

if I remember well after installing microsoft hd audio drivers I stiil have a ? in the Device Manager wich was "audio device on hd ....." so ..I tryed to update driver and looked in the folder in wich I unpacked "ATI Video Driver and Control Panel for Microsoft Windows XP" ... I know this is unespected because the ATI was suposed to support just video drivers but if you think at HDMI conector you understand there is a reason
Please use plain text.
Occasional Advisor
adrian bortun
Posts: 6
Registered: ‎11-25-2007
Message 14 of 15 (487 Views)

Re: Compaq 8510p : Unknown device under Win XP

and another good news .. you can install Windows HP and have SATA HDD enabled in the BIOS (poor bios of HP unfortunatly) ... you should use NLITE applicatin to make a custom bootable CD for WinXP in wich you place ICH8 drivers from Intel ... the speed of the HDD grows a little but works much smooter and less ..
Please use plain text.
Occasional Visitor
Mike McNulty
Posts: 1
Registered: ‎02-17-2008
Message 15 of 15 (487 Views)

Re: Compaq 8510p : Unknown device under Win XP

I installed a XP partition on my 8510p and found that when i had finished the installation, while all audio drivers were installed, there was no sound.

I looked in the Control Panel -> Sound+Audio Devices

the issue is with ATI. When you install the ATI drivers after installing sound (which is default for the reinstall disks provided by HP), the ATI takes over the drivers for the default sound. To fix the issue, I simply changed the default sound back to the SoundMAX HD Device and all is normal.

SIDENOTE: The reason that you have the ATI driver taking over the sound from the Soundmax is to enable full functionality on the HDMI Port. If you intend to use the HDMI for both video and sound, i would presume that you would have to set the sound output default back to the ATI driver in the same location...

-Mike
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation