Re: SAM stuck at "Initializing" (79 Views)
Reply
Occasional Advisor
Vitug
Posts: 10
Registered: ‎10-09-2006
Message 1 of 16 (79 Views)
Accepted Solution

SAM stuck at "Initializing"

Hi,

I just started today as the new unix admin and one of the thing on my plate is to fix SAM. My predecessor had configured X Windows to run CDE through cygwin and now SAM stopped working using the TUI for some strange reason. It might just be a coincindence but the problem may or may not be related. We have also tried reinstalling SAM and updating the patch but that didn't help. Please help point me to the right direction.

I've also attached a screen shot.

Thanks,
Vitug
Please use plain text.
Honored Contributor
Yang Qin_1
Posts: 514
Registered: ‎10-23-2002
Message 2 of 16 (79 Views)

Re: SAM stuck at "Initializing"

Can you have a look at /var/sam/log/samlog and see if some errors logged there?

Do you have problem with devices (ioscan -fn) file systems (bdf will hang)?
Please use plain text.
Occasional Advisor
Vitug
Posts: 10
Registered: ‎10-09-2006
Message 3 of 16 (79 Views)

Re: SAM stuck at "Initializing"

I did not see any errors in the /var/sam/log/samlog file (see attached). I only copied the logs when I try to run SAM.

ioscan and bdf are both working fine as well.
Please use plain text.
Occasional Advisor
Vitug
Posts: 10
Registered: ‎10-09-2006
Message 4 of 16 (79 Views)

Re: SAM stuck at "Initializing"

I did not see any errors in the /var/sam/log/samlog file (see attached). I only copied the logs when I try to run SAM.

ioscan and bdf are both working fine as well.
Please use plain text.
Honored Contributor
Bill Hassell
Posts: 14,178
Registered: ‎05-29-2000
Message 5 of 16 (79 Views)

Re: SAM stuck at "Initializing"

Start by making sure the DISPLAY variable is not set (unset DISPLAY). Make sure you never hardcode the TERM variable but have ttytype -s set the terminal type for you:

eval $(ttytype -s)

(this should be run in /etc/profile in place of any other TERM tests)

Now I am ASSUMING by TUI that you are using a simple telnet connection and Xwindows is not used at all. Note that CDE is very confusing because it starts a terminal window not on your PC but on the HP-UX box, and then throws it's display over to your PC. A simple telnet session is just typing the telnet command in the DOS command window on your PC.
Please use plain text.
Trusted Contributor
Prasanth B
Posts: 108
Registered: ‎12-08-1998
Message 6 of 16 (79 Views)

Re: SAM stuck at "Initializing"

Hi,

First check the DISPLAY variable. echo $DISPLAY. If it is set, unset it. Check the users .profile or /etc/profile if DISPLAY variable is set. If so, remove it.

Check to see if another sam process is running/hanging etc

Try rebooting the server, if possible.

-PB


Take life as it comes
Please use plain text.
Honored Contributor
Yang Qin_1
Posts: 514
Registered: ‎10-23-2002
Message 7 of 16 (79 Views)

Re: SAM stuck at "Initializing"

Hi, Vitug, if you attached is a full samlog then it looks like SAM stopped at the point it tried to find two files:
/opt/graphics/common/bin/setmon
/opt/graphics/common/bin/gamma

Can you also check if you have set DISPLAY or not? "echo $DISPLAY"
Please use plain text.
Occasional Advisor
Vitug
Posts: 10
Registered: ‎10-09-2006
Message 8 of 16 (79 Views)

Re: SAM stuck at "Initializing"

I have unset the DISPLAY variable and tried running SAM and it still did not work. I'm using putty btw.
Please use plain text.
Honored Contributor
Bill Hassell
Posts: 14,178
Registered: ‎05-29-2000
Message 9 of 16 (79 Views)

Re: SAM stuck at "Initializing"

Using putty and the DISPLAY variable unset, what does the end of the SAM log look like now?
Please use plain text.
Occasional Advisor
Vitug
Posts: 10
Registered: ‎10-09-2006
Message 10 of 16 (79 Views)

Re: SAM stuck at "Initializing"

I unset the DISPLAY and ran sam again via putty. The end of the log looks exactly the same as the last one I attached previously.

I have also ran swverify and found errors with the SystemAdmin.SAM filesets and couple files with permissions and gui/uid errors. HP Support suggested that I run the following command:

swverify -x fix=true SystemAdmin.\*

After running the above command, I ran sam again but it is still stuck at the "Initialization" screen.

Please help.

Thanks again for all your posts.

Vitug
Please use plain text.
Honored Contributor
Yang Qin_1
Posts: 514
Registered: ‎10-23-2002
Message 11 of 16 (79 Views)

Re: SAM stuck at "Initializing"

Can you have a look at /var/sam/log/samlog and see if you can find some "new" errors?
Please use plain text.
Occasional Advisor
Vitug
Posts: 10
Registered: ‎10-09-2006
Message 12 of 16 (79 Views)

Re: SAM stuck at "Initializing"

There are no new errors.
Please use plain text.
Honored Contributor
Yang Qin_1
Posts: 514
Registered: ‎10-23-2002
Message 13 of 16 (79 Views)

Re: SAM stuck at "Initializing"

Can you remove /var/sam/log/samlog or move it to another file system (/tmp) and re-start sam? Maybe its better to kill all hanging sam sessions (you may need reboot to clean up hanging sam sessions).
Please use plain text.
Advisor
Dinesh MIshra
Posts: 12
Registered: ‎10-15-2006
Message 14 of 16 (79 Views)

Re: SAM stuck at "Initializing"

HI

first try this command
#export DISPLAY=ip address:0.0
# export xterm=vt100

i think it will help.

is there DNS configured on this machine and have to made any changes recently ?

let me know.

regards
dinesh

Please use plain text.
Occasional Advisor
Vitug
Posts: 10
Registered: ‎10-09-2006
Message 15 of 16 (79 Views)

Re: SAM stuck at "Initializing"

SAM is running now.

The problem was setmon file was missing and the test file was corrupted.

I just copied these two files from another machine and it worked.

Thanks to all for your help.

Vitug
Please use plain text.
Occasional Advisor
Vitug
Posts: 10
Registered: ‎10-09-2006
Message 16 of 16 (79 Views)

Re: SAM stuck at "Initializing"

Thanks again!
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation