Re: NFS mount problem on HP Cluster from linux NFS server. (260 Views)
Reply
Trusted Contributor
jerrym
Posts: 134
Registered: ‎02-12-2008
Message 1 of 9 (305 Views)

NFS mount problem on HP Cluster from linux NFS server.

[ Edited ]

I have HP Cluster 11.31 client and Linux SUSE 11 NFS server.

 

Using /etc/auto.direct and restarting /sbin/init.d/autofs on client then cd into directory I get long wait

then doing ls first time I get after long wait:

 

NFS readdirplus failed for server panwppnpd: error 5 (RPC: Timed out)

 

 

Second ls shows files. As long as it is mounted I can see the files. If automounter unmounts it

and I try to again, I get same problem.

 

This problem is only with HP Clusters. Other non HP Clusters mount the same export from Linux NFS server okay.

 

Have not found anything to resolve this problem.

 

P.S. This thread has been moved from HP-UX>System Administration to HP-UX > networking. -HP Forum Moderator

 

 

Please use plain text.
HP Pro
Dave Olker
Posts: 1,424
Registered: ‎10-10-2002
Message 2 of 9 (293 Views)

Re: NFS mount problem on HP Cluster from linux NFS server.

Posting the AutoFS maps would help.  Do you get the same behavior when you manually mount the exact same filesystem from the exact same server using the exact same options?

 

Dave

Please use plain text.
Trusted Contributor
jerrym
Posts: 134
Registered: ‎02-12-2008
Message 3 of 9 (291 Views)

Re: NFS mount problem on HP Cluster from linux NFS server.

Linux panwppnpd 3.0.58-0.6.6-default NFS server /etc/exports file entry:

 

/usr/sap/trans *(rw,sync,no_root_squash,no_subtree_check)

 

# exportfs

/usr/sap/trans  <world>

 

 

 

HP Cluster /etc/auto.direct:

 

/usr/sap/trans  panwppnpd:/usr/sap/trans

 

 

This only happens when using automounter on HP clusters.

If I manually mount it. It is okay.

 

Please use plain text.
HP Pro
Dave Olker
Posts: 1,424
Registered: ‎10-10-2002
Message 4 of 9 (289 Views)

Re: NFS mount problem on HP Cluster from linux NFS server.

Please mount the filesystem manually on the HP-UX client and then post the output of "nfsstat -m" so I can see which mount options are used.

 

Dave

Please use plain text.
Trusted Contributor
jerrym
Posts: 134
Registered: ‎02-12-2008
Message 5 of 9 (287 Views)

Re: NFS mount problem on HP Cluster from linux NFS server.

#nfsstat -m
/usr/sap/trans from panwppnpd:/usr/sap/trans
 Flags:         vers=3,proto=tcp,sec=sys,hard,intr,link,symlink,acl,devs,rsize=32768,wsize=32768,retrans=5,timeo=600
 Attr cache:    acregmin=3,acregmax=60,acdirmin=30,acdirmax=60

/sapmnt/GCP from moss:/export/sapmnt/GCP
 Flags:         vers=3,proto=udp,sec=sys,soft,intr,link,symlink,acl,nodevs,rsize=32768,wsize=32768,retrans=5,timeo=11
 Attr cache:    acregmin=3,acregmax=60,acdirmin=30,acdirmax=60
 Lookups:     srtt=7 (17ms), dev=3 (15ms), cur=2 (40ms)
 Reads:     srtt=7 (17ms), dev=4 (20ms), cur=2 (40ms)
 Writes:     srtt=7 (17ms), dev=3 (15ms), cur=2 (40ms)
 All:     srtt=7 (17ms), dev=3 (15ms), cur=2 (40ms)

Please use plain text.
HP Pro
Dave Olker
Posts: 1,424
Registered: ‎10-10-2002
Message 6 of 9 (281 Views)

Re: NFS mount problem on HP Cluster from linux NFS server.

There are two filesystems. Which one is the problem?
Please use plain text.
Trusted Contributor
jerrym
Posts: 134
Registered: ‎02-12-2008
Message 7 of 9 (279 Views)

Re: NFS mount problem on HP Cluster from linux NFS server.

/usr/sap/trans from panwppnpd:/usr/sap/trans
 Flags:         vers=3,proto=tcp,sec=sys,hard,intr,link,symlink,acl,devs,rsize=32768,wsize=32768,retrans=5,timeo=600
 Attr cache:    acregmin=3,acregmax=60,acdirmin=30,acdirmax=60

Please use plain text.
HP Pro
Dave Olker
Posts: 1,424
Registered: ‎10-10-2002
Message 8 of 9 (275 Views)

Re: NFS mount problem on HP Cluster from linux NFS server.

In your auto.direct map you are not specifying any mount options. What happens if you modify your auto.direct map to specify version 3? The symptom you're describing sounds like an NFS v4 mount point. If you hardcode v3 into the AutoFS map do you get the desired behavior?

Dave
Please use plain text.
Trusted Contributor
jerrym
Posts: 134
Registered: ‎02-12-2008
Message 9 of 9 (260 Views)

Re: NFS mount problem on HP Cluster from linux NFS server.

Its already vers=3 from above.

 

I remounted with automounter again and here is the nfsstat.

 

/usr/sap/trans from panwppnpd:/usr/sap/trans
 Flags:         vers=3,proto=udp,sec=sys,soft,intr,link,symlink,acl,nodevs,rsize=32768,wsize=32768,retrans=5,timeo=11
 Attr cache:    acregmin=3,acregmax=60,acdirmin=30,acdirmax=60
 Lookups:     srtt=50 (125ms), dev=5 (25ms), cur=8 (160ms)
 Reads:     srtt=8 (20ms), dev=8 (40ms), cur=5 (100ms)

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation