Error in creating MX record (222 Views)
Reply
Occasional Contributor
Gesmundo
Posts: 10
Registered: ‎08-06-2004
Message 1 of 3 (222 Views)
Accepted Solution

Error in creating MX record

We have a cluster of Itanium blades running OVMS  V8.3-1H1 and using DNS.

 

We are trying to set up SMTP to send mail out of this cluster.

 

After running the SMTP configuration, we tried to send mail to QAUser1@qasmtp.sgx.com but we are receiving this error in the TCPIP$SMTP_LOGFILE.LOG:

%TCPIP-I-SMTP_SYMBRUN, symbiont is running the queue TCPIP$SMTP_ACCL01_01
Error in MX lookup for destination host qasmtp.sgx.com. IOSB status: 99908

The host is defined in the local database:

     LOCAL database

Host address    Host name

127.0.0.1       LOCALHOST, localhost
10.94.130.190   MMSNL01
10.42.5.41      QASMTP.SGX.COM, qasmtp.sgx.com

 

When we try to create the MX record, we encounter the problem:

TCPIP> sho mx
%TCPIP-E-ROUTEERROR, error accessing routes database (TCPIP$ROUTE)
-TCPIP-W-NORECORD, information not found
TCPIP> set mx_record sgx.com/gate=qasmtp.sgx.com/pref=1
%TCPIP-E-MXERROR, error processing MX request
-RMS-F-RAC, invalid record access mode
TCPIP> set mx_record "sgx.com"/gate="qasmtp.sgx.com"/pref=1
%TCPIP-E-MXERROR, error processing MX request
-RMS-F-RAC, invalid record access mode

 

The remote host is accessible:

ACCL01_SGX> telnet qasmtp.sgx.com 25
%TELNET-I-TRYING, Trying ... 10.42.5.41
%TELNET-I-SESSION, Session 01, host qasmtp.sgx.com, port 25
TELNET> exitCAPE, Escape character is ^]
%TELNET-S-LCLCLOSED, Local connection closed
-TELNET-I-SESSION, Session 01, host qasmtp.sgx.com, port 25

 

However, on another 2-node cluster within the same LAN, e are able to send mail to the same user without creating an MX record. We also created an MX record using the same syntax without error and still could send mail.

TD2MP1_SGX> ucx sho mx

                              Local MX database

Destination                  Preference      Gateway

SGX.COM                         1            10.42.5.41

 

 

Any help will be appreciated.

 

 

Noel Gesmundo

System Administrator

Singapore

Please use plain text.
Honored Contributor
Steven Schweda
Posts: 9,066
Registered: ‎02-23-2005
Message 2 of 3 (200 Views)

Re: Error in creating MX record

Please use plain text.
Occasional Contributor
Gesmundo
Posts: 10
Registered: ‎08-06-2004
Message 3 of 3 (131 Views)

Re: Error in creating MX record

Steven,

Thanks.

Indeed the routes file is sequential. We receated the routes file and we were able to send smtp mail even without creating an MX record.

Noel
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation