Re: CIFS client installation problem (34 Views)
Reply
Occasional Visitor
iskanda
Posts: 3
Registered: ‎03-14-2007
Message 1 of 5 (34 Views)
Accepted Solution

CIFS client installation problem

Hi All,
New to the board and Cifs with HPUX. I'm running on V11.0, and have checked the prerequisites and I look okay. I've installed PAM Kerberos beforehand, and now want to install the Cifs client. Everytime I try, i get the log file entry The dependencies for fileset CIFS-Client CIFSCLIENT-MIS,r=A.01.09.03 cannot be resolved.
The prerequisite KRB5-Client.KRB5-SHLIB,r>=B.11.00 % for fileset CIFS-Client.CIFSCLIENT-RUN,r=A.01.09.03 cannot be successfuly resolved. I thought that PAM kerberos would satisfy this dependency. Does anyone have any ideas please? I'm pulling my hair out!! Thanks
Please use plain text.
Trusted Contributor
Eric Raeburn
Posts: 137
Registered: ‎11-26-2002
Message 2 of 5 (34 Views)

Re: CIFS client installation problem

Iskanda,

This is Eric in the HP CIFS Client software lab.

Note that the error message you get from swinstall states that the prerequisite is KRB5-Client.KRB5-SHLIB,r>=B.11.00 % . That fileset is not present part of the PAM Kerberos bundle. You can determine this with swlist(1M): assuming the PAM-Kerberos bundle is in /tmp:

swlist -l fileset -s

or

swlist -l fileset

In the output of either of these commands you will note there are no KRB5-Client.* filesets.Also note that the table at the bottom of the PAM-Kerberos "Product details & specifications" page at software.hp.com indicates that PAM-Kerberos also depends on the same Kerberos Client fileset as the CIFS Client.

Hence, you also need to install the Kerberos Client, known as KRB5CLIENT. Here you may have two problems for which you would probably need to contact HP Support. First, software.hp.com shows Kerberos Client bundles only as far back as HPUX 11.11. In addition, running swlist against the 11.11 bundle (I just downloaded and tried this), indicates filesets with different names, in particular, the Kerberos fileset you need now has a different name: krb5client.KRB5-SHLIB-A.

HPUX 11.0 was sort of a grey zone for synchronizing versions of these software bundles; we even had difficulty internally. I urge you to contact support; they may be able to provide the 11.0 Kerberos Client, however, it may be time to seriously consider updating to 11.11 or 11.23.

Good luck,
Eric
Please use plain text.
Occasional Visitor
iskanda
Posts: 3
Registered: ‎03-14-2007
Message 3 of 5 (34 Views)

Re: CIFS client installation problem

Thanks for the reply Eric. I'll contact support and ask them as you've suggested. The only reason we've stuck at v11.0 is becuase we're running Openmail V6 on the servers and i'm told by our reseller support guys (although never checked...maybe i should) that v11 was the last version to support Openmail 6. I don't suppose you know whether this is correct?
Thanks again.
I
Please use plain text.
Trusted Contributor
Eric Raeburn
Posts: 137
Registered: ‎11-26-2002
Message 4 of 5 (34 Views)

Re: CIFS client installation problem

Thanks for your understanding, and no, sorry, I do not know about Openmail.

Please post the result of your inquiry to support; I am interested in their response. In fact, there are people in my area who work on Kerberos. So if support does not have access to an 11.0 Kerberos Client depot, and if it does not violate some support policy, you could ask them to contact me (or an HP Kerberos engineer [if you get the right support person they will know who this is]) and we may be able to accommodate you.

Best,
-Eric
Please use plain text.
Occasional Visitor
iskanda
Posts: 3
Registered: ‎03-14-2007
Message 5 of 5 (34 Views)

Re: CIFS client installation problem

Thanks again Eric. You've been more than helpful. As soon as I get any information, i'll post it up to let you know.

I
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation