Re: After IP address change my server cannot work correctly (611 Views)
Reply
Occasional Advisor
AntonioMariaV
Posts: 9
Registered: ‎07-30-2013
Message 1 of 6 (641 Views)
Accepted Solution

After IP address change my server cannot work correctly

Yesterday I changed server IP address. I set wrong IP interface a Volker helped me to solve.

But today server run just in local network and cannot connect host outside LAN.

 

 

See this:

 

$ tcpip sh inter
                                                           Packets
Interface   IP_Addr         Network mask          Receive          Send     MTU

 IE0        192.168.13.61   255.255.255.0            5793          1003    1500
 LO0        127.0.0.1       255.0.0.0                 147           147    4096
 WE0        192.168.13.62   255.255.255.0            1760          2923    1500

 

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

$ tcpip sh rout

                             DYNAMIC

Type           Destination                           Gateway

AH    127.0.0.1                             127.0.0.1
AH    192.168.13.0                          192.168.13.1
AN    192.168.13.0/24                       192.168.13.61
AN    192.168.13.0/24                       192.168.13.62
AH    192.168.13.61                         192.168.13.61
AH    192.168.13.62                         192.168.13.62

 

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

$ ping 192.168.13.1
PING 192.168.13.1 (192.168.13.1): 56 data bytes
64 bytes from 192.168.13.1: icmp_seq=0 ttl=64 time=1 ms
64 bytes from 192.168.13.1: icmp_seq=1 ttl=64 time=1 ms
64 bytes from 192.168.13.1: icmp_seq=2 ttl=64 time=1 ms
64 bytes from 192.168.13.1: icmp_seq=3 ttl=64 time=0 ms


----192.168.13.1 PING Statistics----
4 packets transmitted, 4 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 0/1/1 ms

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

$ ping 4.2.2.1
PING 4.2.2.1 (4.2.2.1): 56 data bytes
ping: sendto: no route to host
ping: wrote 4.2.2.1 64 chars, ret=-1
ping: sendto: no route to host
ping: wrote 4.2.2.1 64 chars, ret=-1
ping: sendto: no route to host
ping: wrote 4.2.2.1 64 chars, ret=-1
ping: sendto: no route to host
ping: wrote 4.2.2.1 64 chars, ret=-1


----4.2.2.1 PING Statistics----
4 packets transmitted, 0 packets received, 100% packet loss
%SYSTEM-F-TIMEOUT, device timeout

 

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

Same ping from PC in same network

C:\>ping 4.2.2.1

Esecuzione di Ping 4.2.2.1 con 32 byte di dati:

Risposta da 4.2.2.1: byte=32 durata=49ms TTL=53
Risposta da 4.2.2.1: byte=32 durata=48ms TTL=53
Risposta da 4.2.2.1: byte=32 durata=48ms TTL=53
Risposta da 4.2.2.1: byte=32 durata=49ms TTL=53

Statistiche Ping per 4.2.2.1:
    Pacchetti: Trasmessi = 4, Ricevuti = 4, Persi = 0 (0% persi),
Tempo approssimativo percorsi andata/ritorno in millisecondi:
    Minimo = 48ms, Massimo =  49ms, Medio =  48ms

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

I am confused. What I wrong ?

 

TIA

 

Antonio M. Vigliotti

 

Antonio M. Vigliotti
Honored Contributor
Volker Halle
Posts: 5,205
Registered: ‎04-26-2004
Message 2 of 6 (634 Views)

Re: After IP address change my server cannot work correctly

Antonio,

 

you don't have a default gateway defined, where packets should be sent to, whose destination is outside your local IP network 192.168.13.0.

 

TCPIP SET ROUTE /DEFAULT/GATE=192.168.13.1 [/PERMANENT]       ! if that is your local routers IP address

 

That route will then show up as destination 0.0.0.0 in TCPIP SHOW ROUTE

 

Volker.

Frequent Advisor
Maurizio De Tommaso_
Posts: 42
Registered: ‎03-11-2004
Message 3 of 6 (627 Views)

Re: After IP address change my server cannot work correctly

Antonio,

 

is your default gateway defined ?

 

$ TCPIP show route /def

 

If it isn't defined, then :

 

$ tcpip set route /def/gat=xx.xx.xx.xx/perm

 

where xx.xx.xx.xx is your default gateway ip address.

 

/Maurizio

Occasional Advisor
AntonioMariaV
Posts: 9
Registered: ‎07-30-2013
Message 4 of 6 (619 Views)

Re: After IP address change my server cannot work correctly

Gateway is defined in permanet DB but there is no trace in current configuration.

 

$  sh hos dns1

     LOCAL database

Host address    Host name

192.168.13.1    DNS1, gw

 

 

 

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
$ sh rout /perm

                             PERMANENT

Type           Destination                           Gateway

PH    192.168.13.0                          DNS1

 

 

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

$set rout 192.168.13.0 /gate=dns1
%TCPIP-E-ROUTEERROR, error accessing routes database (TCPIP$ROUTE)
-SYSTEM-F-FILALRACC, file already accessed on channel

 

 

 

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

$ set rout 192.168.13.0 /gate=192.168.13.1
%TCPIP-E-ROUTEERROR, error accessing routes database (TCPIP$ROUTE)
-SYSTEM-F-FILALRACC, file already accessed on channel

 

Antonio M. Vigliotti
Honored Contributor
Volker Halle
Posts: 5,205
Registered: ‎04-26-2004
Message 5 of 6 (616 Views)

Re: After IP address change my server cannot work correctly

Antonio,

 

you need to use the /DEFAULT qualifier when specifying a default gateway:

 

$ TCPIP SET ROUTE/DEFAULT/GATE=dns1 [/PERM]

 

Volker.

Occasional Advisor
AntonioMariaV
Posts: 9
Registered: ‎07-30-2013
Message 6 of 6 (611 Views)

Re: After IP address change my server cannot work correctly

With /def works!

 

Thanks

 

Antonio M. Vigliotti
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.