Traps from SNMPv3 device not getting captured in NNM (849 Views)
Reply
Honored Contributor
ramesh9
Posts: 1,084
Registered: ‎04-19-2011
Message 1 of 9 (849 Views)

Traps from SNMPv3 device not getting captured in NNM

NNM 9.11.004 on HP Unix

 

We had seeded and discovered SNMPv3 devices in our environment ( Juniper device ) and we had imported the necessary MIB into NNMi

 

When the device sends SNMPv3 traps they are not getting captured in NNMi nor they been shown when we run nnmtrapdump.ovpl command.

 

Is it necessary that the device sends traps in V2 format in order for NNM to capture or is there anything else that can be done when V3 traps arrive.

 

Please help.

 

 

HP Expert
Dave Young
Posts: 565
Registered: ‎09-27-2000
Message 2 of 9 (823 Views)

Re: Traps from SNMPv3 device not getting captured in NNM

Ramesh,

 

  Providing the device has been discovered by NNMi and NNMi is using snmpv3 to communicate to it, and the traps are being sent to NNMi using the same credentials as NNMi is using to talk to the device with, then the traps should be received okay.

 

  Common problems here are

 

1) NNMi is not using v3 to talk to the device

2) the device is using a different user name to send the traps to NNMi

3) the device is using a different auth and privacy passphrases to send the traps

 

  Hope this helps

 

Dave Y

HP Support

The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of HP

If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.
Honored Contributor
ramesh9
Posts: 1,084
Registered: ‎04-19-2011
Message 3 of 9 (815 Views)

Re: Traps from SNMPv3 device not getting captured in NNM

Dear Dave

 

Thanks for your reply.

 

In NNM logs I am seeing following lines,

 

WARNING: com.hp.ov.nms.trapd.NMTrapData parseTrap: Failed to parse trap from /10.21.23.21: Bad authentication code for user xxxxxx, Engine id = 80 00 30 F4 05 5D 8B DC FA 46 EE F1 52

WARNING: com.hp.ov.nms.trapd.MessageProcessor processTrap: com.hp.ov.snmp.exceptions.AuthException: Trap parsing failed. Bad authentication code for user xxxxxx, Engine id = 80 00 30 F4 05 5D 8B DC FA 46 EE F1 52. Dropping trap from /10.21.23.21

 

I checked with device admin and he says there is no authentication change for the device 10.21.23.21

HP Expert
Dave Young
Posts: 565
Registered: ‎09-27-2000
Message 4 of 9 (808 Views)

Re: Traps from SNMPv3 device not getting captured in NNM

Ramesh,

 

  The first thing to check is the trap as it is arriving.  Take a network trace using either tcpdump, wireshark, snoop etc and then display the trace file in wireshark.  You can then configure wireshark with the v3 attributes to allow you to decode the trap.  To do this click through the following

 

Edit -> Preferences - Protocols -> SNMP -> Users Table:  Edit -> New ->

 

The fill out the form with all the information about the device:

 

Engine ID, Username, Auth Protocol, Auth Password, Privacy Protocol, Priv password.

 

click on OK all the way out.

 

Now you should see the snmp trap fully decoded in the middle Wireshark window.  If you don't then some of the information is wrong and it may be the same problem as NNMi.    If the packet displays correctly then you need to look back at NNMi.  Double check the snmpv3 settings, check NNMi is using v3 to this device - use  a config poll and check it says "v3".  Look at the Communitcation settings and confirm the correct v3 profile is used.

 

  If you need help at this stage then I would suggest opening a case with us so we can investigate it more closely.

 

  All the best

 

Dave Y

HP Support

The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of HP

If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.
Honored Contributor
ramesh9
Posts: 1,084
Registered: ‎04-19-2011
Message 5 of 9 (800 Views)

Re: Traps from SNMPv3 device not getting captured in NNM

Dear Dave

 

Network trace shows SNMPv2 traps after decoding.

 

Configuration poll to the device shows the communication is happening over V3. Confirmed 
using follwoing line,

 

L3ConnectionAnalyzer was skipped
L3Analyzer was skipped

 

but getting confused with following line,

 

No SNMP for xxxx-xxxx

 

And everything is correctly used.

 

Is there any way we can trace the issue..

HP Expert
Dave Young
Posts: 565
Registered: ‎09-27-2000
Message 6 of 9 (793 Views)

Re: Traps from SNMPv3 device not getting captured in NNM

Ramesh,

 

  When you look at the trap packet there is an SNMP version number.  Does this say 3 or 1 ?  3 implies version 3, 1 implies version 2c.   If its 3 then you should see the username, engine id, boot count etc, however the payload will look like a normal v2 trap payload.

 

  The main issue would appear to be that NNMi has not discovered the device as an SNMP device, almost certainly because the v3 information is either incorrect, not applied or the set up procedure is not completing correctly.    In order to check this out we would need to see a network trace of the setup procedure.    I think the best thing to do is to open a case with us and provide us with the network trace of the config poll and the v3 configuration details and we can then help investigate this with you.

 

  Note the L3connectionAnalyser refers to Level 3 ie IP layer, not snmp v3.

 

  all the best

 

Dave Y

HP Support

The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of HP

If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.
Honored Contributor
ramesh9
Posts: 1,084
Registered: ‎04-19-2011
Message 7 of 9 (781 Views)

Re: Traps from SNMPv3 device not getting captured in NNM

Hello Dave

 

Could you please tell us how to take network trace of the config poll please

 

Thanks

Ramesh

HP Expert
Dave Young
Posts: 565
Registered: ‎09-27-2000
Message 8 of 9 (778 Views)

Re: Traps from SNMPv3 device not getting captured in NNM

Ramesh,

 

  I see you have opened the case and are already in touch with the online engineer. 

 

  All the best

 

Dave Y

HP Support

The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of HP

If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.
Frequent Advisor
sobejhall
Posts: 31
Registered: ‎12-12-2013
Message 9 of 9 (760 Views)

Re: Traps from SNMPv3 device not getting captured in NNM

Guessing by the sounds of it that the device was setup for V2C and NNMi was setup for V3 ...
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.