Re: NNMi 9.10 Reporting console not opening (3098 Views)
Reply
Respected Contributor
Bharath M R
Posts: 411
Registered: ‎03-10-2010
Message 1 of 25 (3,157 Views)

NNMi 9.10 Reporting console not opening

hi all, 

               i am getting error like below when m trying to open reporting console.

 

""   

          HP NNM iSPI Performance

 

          An error has occurred.

 

          DPR-ERR-2109 The dispatcher cannot service the request at this time. The dispatcher is still initializing. Contact your administrator if this problem persists.   Please try again or contact your administrator      """

 

 

this is very urgent , pls help.

 

Thanks,
Bharath
Respected Contributor
asoloperto
Posts: 193
Registered: ‎03-10-2010
Message 2 of 25 (3,150 Views)

Re: NNMi 9.10 Reporting console not opening

Hello Bharath,

please check %NnmInstallDir%\NNMPerformanceSPI\bin\statusALL.ovpl.

You can use stopALL.ovpl and startALL.ovpl to restart the processes. Also have a look to the log files in %NnmDataDir%\NNMPerformanceSPI\logs.

HTH

Allessandro
Respected Contributor
Bharath M R
Posts: 411
Registered: ‎03-10-2010
Message 3 of 25 (3,151 Views)

Re: NNMi 9.10 Reporting console not opening

i checked by issuing statusALL command, everything is running.

 

  I Restarted the service by using commands

 

               stopALL and startALL.         But i am still facing the same problem.

 

i noticed many failures regarding Content Manager in cogserver.log

 

please check the cogserver.log in the attachment. Please suggest if you find any inconsistency.

 

 

 

Thanks,
Bharath
Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 4 of 25 (3,149 Views)

Re: NNMi 9.10 Reporting console not opening

It looks as though the content manager databse is not responding.  The content manager is a small apache derby database not to be confused with the sybase IQ database where metrics are stored.

 

Have reports ever worked on this system?  If so, what has changed?

 

If not then what is preventing content store responding?  Any firewalls?

 

To help debugging I would first stopETL (ETL detects when BI services are not running and will attempt to restart them, this might cause some confusion so best to avoid it now)

 

I would then if the content store starts properly.  The easiest way to do that is to start it via the BI config UI (runBIConfigUI.ovpl or BI Server - Cognos 8 -> IBM Cognos Configuration from windows start menu).

 

Right Click "Local Configuration" at the root of the tree on the left.  Select Stop.

Then in the tree locate  Environment -> HP NNM iSPI Performance content database, right click and select Start.

If it starts ok click on the close button on the dialog box.

Locate Environment -> HP NNM iSPI Performance BI Server service -> NNM iSPI Performance BIServer in tree, right click and select start.  This can take some time.

If anything fails click on the "details" button snd see if you can determine more about the errors.

Also check derby.log and the cognos bootstrap logs cbs*.log (all in the logs directory)

 

 

 

 

Respected Contributor
Bharath M R
Posts: 411
Registered: ‎03-10-2010
Message 5 of 25 (3,149 Views)

Re: NNMi 9.10 Reporting console not opening

hi cameron,

 

               i followed the steps, i got the errors in details, like below.

 

 

Execution of the external process returns an error code value of '-1'.

Successfully launched a test JVM with the memory setting of '1024'. Note that this does not guarantee that IBM Cognos 8 will start and run successfully.

 

To see which JVM options are based on this setting, view c8_location/bin/bootstrap_<OS>.xml and see your JVM documentation for an explanation of those options.

17:22:42, 'LogService', 'StartService', 'Success'.

17:22:47, CM-CFG-5063 A Content Manager configuration error was detected while connecting to the content store.  CM-CFG-5036 Content Manager failed to connect to the content store. The connection string is "jdbc:derby://localhost:9301/cm".  java.security.PrivilegedActionException : Error opening socket to server localhost on port 9301 with message : null Cause: java.security.PrivilegedActionException : Error opening socket to server localhost on port 9301 with message : null    Runtime Exception stack trace:  org.apache.derby.client.am.DisconnectException: java.security.PrivilegedActionException : Error opening socket to server localhost on port 9301 with message : null          at org.apache.derby.client.net.NetAgent.<init>(Unknown Source)               at org.apache.derby.client.net.NetConnection.newAgent_(Unknown Source)       at org.apache.derby.client.am.Connection.<init>(Unknown Source)            at org.apache.derby.client.net.NetConnection.<init>(Unknown Source)    at org.apache.derby.jdbc.ClientDriver.connect(Unknown Source)                 at java.sql.DriverManager.getConnection(DriverManager.java:562)             at java.sql.DriverManager.getConnection(DriverManager.java:186)             at com.cognos.cm.dbstore.CMDbStoreFactory.getJDBCConnection(CMDbStoreFactory.java:2087)               at com.cognos.cm.dbstore.CMDbStoreFactory.getInitialConnection(CMDbStoreFactory.java:1937)              at com.cognos.cm.dbstore.CMDbStoreFactory.initContentIndependentBeforeLock(CMDbStoreFactory.java:2111)              at com.cognos.cm.dbstore.CMDbStore.initializeContentIndependentBeforeLock(CMDbStore.java:4597)                  at com.cognos.cm.server.CMServlet.initializeContentStoreContentIndependentBeforeLock(CMServlet.java:2321)              at com.cognos.cm.server.CMServlet.init(CMServlet.java:2046)       at com.cognos.cm.server.ContentManager.start(ContentManager.java:314)           at com.cognos.cm.server.ContentManagerLifecycleHandler.start(ContentManagerLifecycleHandler.java:73)          at com.cognos.pogo.services.DefaultHandlerService.start(DefaultHandlerService.java:111)              at com.cognos.pogo.services.DispatcherServices.startInititalServices(DispatcherServices.java:426)               at com.cognos.pogo.transport.PogoServlet$PogoStartup.run(PogoServlet.java:688)            at java.lang.Thread.run(Thread.java:810) 

17:22:48, 'com.cognos.pogo.contentmanager.coordinator.ActiveCMControl', 'pogo', 'Failure'.

DPR-DPR-1035 Dispatcher detected an error.

 

17:22:47, 'ContentManager', 'getActiveContentManager', 'Failure'.

DPR-CMI-4006 Unable to determine the active Content Manager. Will retry periodically.

17:27:58, 'com.cognos.pogo.services.DefaultHandlerService', 'pogo', 'Failure'.

DPR-DPR-1035 Dispatcher detected an error.

 

17:27:58, 'com.cognos.pogo.services.DefaultHandlerService', 'pogo', 'Failure'.

DPR-DPR-1035 Dispatcher detected an error.

 

17:27:59, 'MonitorService', 'StopService', 'Success'.

17:27:59, 'MonitorService', 'StopService', 'Success'.

17:27:59, 'SystemService', 'StopService', 'Success'.

17:27:59, 'SystemService', 'StopService', 'Success'.

17:27:59, 'ReportDataService', 'StopService', 'Success'.

17:27:59, 'ReportDataService', 'StopService', 'Success'.

17:27:59, 'ReportService', 'StopService', 'Success'.

17:27:59, 'ReportService', 'StopService', 'Success'.

17:27:59, 'DeliveryService', 'StopService', 'Success'.

17:27:59, 'DeliveryService', 'StopService', 'Success'.

17:27:59, 'MetadataService', 'StopService', 'Success'.

17:27:59, 'MetadataService', 'StopService', 'Success'.

17:27:59, 'JobService', 'StopService', 'Success'.

17:27:59, 'JobService', 'StopService', 'Success'.

17:27:59, 'EventService', 'StopService', 'Success'.

17:27:59, 'EventService', 'StopService', 'Success'.

17:27:59, 'BatchReportService', 'StopService', 'Success'.

17:27:59, 'BatchReportService', 'StopService', 'Success'.

17:27:59, 'AgentService', 'StopService', 'Success'.

17:27:59, 'AgentService', 'StopService', 'Success'.

17:27:58, 'CPS Producer Registration Service', 'StopService', 'Success'.

17:27:58, 'CPS Producer Registration Service', 'StopService', 'Success'.

17:27:59, 'ContentManagerService', 'StopService', 'Success'.

17:27:59, 'ContentManagerService', 'StopService', 'Success'.

17:27:59, 'LogService', 'StopService', 'Success'.

17:27:59, 'LogService', 'StopService', 'Success'.

[ ERROR ] CFG-ERR-0103 Unable to start IBM Cognos 8 service.

 

 


Thanks,
Bharath
Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 6 of 25 (3,144 Views)

Re: NNMi 9.10 Reporting console not opening

My guess is that the content store has been corrupted somehow but its hard to guess really.

What is in derby.log?

What OS are you running on?

Was this a new install?  An upgrade?

Have you applied patch 1 (I'd get this fixed before trying the patch though)

Like I asked before, has this ever worked on this system?

 

Respected Contributor
Bharath M R
Posts: 411
Registered: ‎03-10-2010
Message 7 of 25 (3,143 Views)

Re: NNMi 9.10 Reporting console not opening

Hi Cameron,

 

               thanks for suggestions, 

we are running on windows 2008

NNMi version is 9.10, this was upgraded from 9.1

Upto yesterday it was working fine, meanwhile we are facing memory issue in the server.

 

Today we have applied a patch for Nortel Passport device support.

 

In derby.log file we are getting like below

 

 

 

Server is ready to accept connections on port 9301.

Connection number: 1.

----------------------------------------------------------------

2011-07-14 12:20:38.462 GMT:

 Booting Derby version The Apache Software Foundation - Apache Derby - 10.1.2.1 - (330608): instance c013800d-0131-2897-106f-0000388daf29

on database directory F:\ProgramData\HP\HP BTO Software\NNMPerformanceSPI\contentstore\cm

 

Database Class Loader started - derby.database.classpath=''

Connection number: 2.

Connection number: 3.

Connection number: 4.

Connection number: 5.

Connection number: 6.

Connection number: 7.

Connection number: 8.

Connection number: 9.

Connection number: 10.

Connection number: 11.

Connection number: 12.

Connection number: 13.

Connection number: 14.

Connection number: 15.

Thanks,
Bharath
Respected Contributor
Bharath M R
Posts: 411
Registered: ‎03-10-2010
Message 8 of 25 (3,140 Views)

Re: NNMi 9.10 Reporting console not opening

and one more thing is Report Console is opening but the when trying to generate reports the same problem is occuring

Thanks,
Bharath
Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 9 of 25 (3,139 Views)

Re: NNMi 9.10 Reporting console not opening

Sorry it is not clear if reporting was installed on 9.0 and also upgraded to 9.10

I guess memory issues could have contributed to the content store becoming corrupted.  Have you backed up the content store since installation/upgrade?

The only things in the content store should be report and package specifications (which should not have changed) and any dynamic content you have subsequently created (like scheduled reports, query studio reports etc..) if you have no dynamic content or would be prepared to lose it then it might be worth trying to recreate the content store from scratch - I think this can be done quite simply but would want to test it to make sure that you didn't inadvertently recreate the metrics store (discarding all your metrics data) as well.

 

What I would definitely do now is to backup the content store if you can.  Try running backup.ovpl with the -c option, if it works then the content database is at least usable, if not then error messages may help track down the issue.

 

In saying all that I still think you should resolve any memory problems in case they are also the root of these other issues.

Respected Contributor
Bharath M R
Posts: 411
Registered: ‎03-10-2010
Message 10 of 25 (3,136 Views)

Re: NNMi 9.10 Reporting console not opening

ya sure, we are trying to resolv the memory issue.

 

Yes everything is upgraded to version 9.10, and also were working fine upto yesterday

we are able to backup the content store successfully without any error.

Thanks,
Bharath
Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 11 of 25 (3,128 Views)

Re: NNMi 9.10 Reporting console not opening

If you have a backup of the contentstore from when this system was working (as 9.10, restoring a 9.0 contentstore will not work) then restore from it and you should be fine.

 

If you don't have a backup then any dynamically created content might be accessible in the backup you just made but I don't know if I could get access to it.

 

If you want to create a new default (empty) content store you need to locate the content store directory:

%NPSDataDir%\contentstore

Stop all NPS services with stopALL.ovpl

Remove the cm directory
runBIConfigGUI.ovpl
start the content store
start the BI server
This time you should see messages about the new content store being created.

To get the extensionpacks resinstalled you need to run installExtensionPack.ovpl for each.
Run a command shell
cd to %NPSInstallDir%
run:

installExtensionPack.ovpl -e extensionPacks\PerfSPI_Diagnostics.tar.gz

installExtensionPack.ovpl -e extensionPacks\InterfaceHealth.tar.gz

installExtensionPack.ovpl -e extensionPacks\Component_Health.tar.gz

Repeat for any other extension packs you had.

Run:

installPathHealth.ovpl

 

Everthing should be okay now.

Metrics are preserved when doing this but you may wish to backup your system beforehand to be safe.

Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 12 of 25 (3,126 Views)

Re: NNMi 9.10 Reporting console not opening

Before trying my last post there is more that is required - this all works for ErsAdmin but it loses the mapping for NNMi users
I'm pretty sure I can find how to add this back again but you may want to hang back until I find how (or if you know how to then you can do it)

Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 13 of 25 (3,121 Views)

Re: NNMi 9.10 Reporting console not opening

Ok, so here is what else I think would need done to add NNM roles to the content store:

 

runBIConfigGUI.ovpl

Click Local Configuration->Security->BI Server

"Allow anonymous access?" should be set to false, change it to True.

Restart BI server

 

Start a bash shell (under the HP start menu)

cd to /opt/OV/Ers/java

 

run the following:

/opt/OV/nonOV/jdk/b/bin/java -cp ./HpErsTools.jar com.hp.ov.bi.setup.SetupRoles -props ../conf/connections.prop
/opt/OV/nonOV/jdk/b/bin/java  -cp ./HpErsTools.jar com.hp.ov.bi.setup.SecureRoles -props ../conf/connections.prop
/opt/OV/nonOV/jdk/b/bin/java  -cp ./HpErsTools.jar com.hp.ov.bi.setup.SetupSSORoles -props ../conf/connections.prop
/opt/OV/nonOV/jdk/b/bin/java  -cp ./HpErsTools.jar com.hp.ov.bi.setup.SetupTenancy -props ../conf/connections.prop

 

Then go back to config GUI, switch anon access back to false and restartBI server again.

 

 

Occasional Advisor
istdc
Posts: 7
Registered: ‎07-14-2011
Message 14 of 25 (3,119 Views)

Re: NNMi 9.10 Reporting console not opening

DPR-ERR-2109 indicates that the dispatcher cannot service the request . The dispatcher is still initializing. This is caused by lack of resources on your system; did you verify the release notes to make sure that you have appropriate RAM and CPU?  This is what I think is causing the DPR-ERR-2109 error.

Frequent Advisor
BharathMR
Posts: 40
Registered: ‎03-03-2011
Message 15 of 25 (3,109 Views)

Re: NNMi 9.10 Reporting console not opening

hi michael

thx for your help, we have folder backup of contentstore directory when it was working (2 days ago) can we simply
replace contentstore folder from backup will it work ?

actually we are facing disk space issue on nps drive and we are increasing disk space shortly

Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 16 of 25 (3,098 Views)

Re: NNMi 9.10 Reporting console not opening

Well if you have a backup of the current (broken) content store then you probably can't do any irreversible damage so if it were me I would try it.

Replace the content store while BI is stopped, start BI, see what happens.

 

Good luck :smileyhappy:

Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 17 of 25 (3,098 Views)

Re: NNMi 9.10 Reporting console not opening

The dispatcher is still initializing because it cannot access the content store.  Accessing the content store is retried periodically so even on a system that is swapping it usually (eventually) comes up and starts to work.  However, in the log files posted it shows that there is an unrecoverable error when trying to access information from the content store so the system will never come up.

 

I think you can actually simulate this issue by removing the contents of (but not the directory for) the content store.  Remove all files/directories from contentstore/cm and the system will not try to recreate a fresh content store but obviously fails to find any contentstore tables which will cause the errors seen.

Respected Contributor
Bharath M R
Posts: 411
Registered: ‎03-10-2010
Message 18 of 25 (3,081 Views)

Re: NNMi 9.10 Reporting console not opening

hi cameron

 

 we tried below steps but still no luck :smileysad:

 

start the BI server

%NPSDataDir%\contentstore

Stop all NPS services with stopALL.ovpl

Remove the cm directory
runBIConfigGUI.ovpl
start the content store

 

 

 

Thanks,
Bharath
Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 19 of 25 (3,077 Views)

Re: NNMi 9.10 Reporting console not opening

What do you mean no luck?

 

I know this has been a long thread and is a bit confused but those steps aren't exactly that I suggested, you would still need to start the BI Server for the content store to be created (if there is no content store database when BI server starts then it is automatically created at that point - starting the contentstore database just starts the database server, it doesn't create the required content.  If you click on the "Details" button you should see messages relating to this)

 

So, have you started the BI Server?  If not then do so.

If that works then you will still need to go through the steps to install the security mappings.

 

If it still doesn't work can you post errors/logs?

 

Respected Contributor
Bharath M R
Posts: 411
Registered: ‎03-10-2010
Message 20 of 25 (3,078 Views)

Re: NNMi 9.10 Reporting console not opening

yes i tried all those..

pls check error i got in the "Details"

Thanks,
Bharath
Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 21 of 25 (3,074 Views)

Re: NNMi 9.10 Reporting console not opening

I don't have a system I can repeat this on but I'm pretty sure what I described should recreate a default empty content store.  Can you try the steps again?  After running stopALL look to see if there are any orphaned processes for derby or cognos.  When you remove the contentstore directory make sure it gets deleted.  I don't know why your system would react differently.

 

If I get a chance to test this later I will.

Respected Contributor
Bharath M R
Posts: 411
Registered: ‎03-10-2010
Message 22 of 25 (3,077 Views)

Re: NNMi 9.10 Reporting console not opening

yes i am able to recreate the CM folder.

 

First i gave 'stopALL' after that it allowed me to remove the folder.

after starting by 'startALL' it created cm folder again , yes i followed your steps but still ending up with the same problem

 

Thanks,
Bharath
Esteemed Contributor
Michael Cameron
Posts: 211
Registered: ‎05-27-2004
Message 23 of 25 (3,069 Views)

Re: NNMi 9.10 Reporting console not opening

I don't think I suggested running startALL, I suggested starting the BI server through the GUI so you could look at any messages while it starts up.

 

 

 

 

Occasional Advisor
vamsirevu
Posts: 6
Registered: ‎06-28-2011
Message 24 of 25 (2,916 Views)

Re: NNMi 9.10 Reporting console not opening

[ Edited ]

hi bharath

 

                    Did this " DPR-ERR-2109 The dispatcher cannot service the request at this time." issue has been solved.we have newly installed not the upgaraditon but here also same problem.

 

                   if u resolved this issue please help us

 

     

regards
vamsi
Occasional Visitor
Jasleen
Posts: 1
Registered: ‎03-17-2012
Message 25 of 25 (2,512 Views)

Re: NNMi 9.10 Reporting console not opening

Hi Bharath,

 

 I am also facing the same issue............... can you plz share the steps to reolve the same.

 

Its very urgent.

 

 

Regards,

Jasleen

 

 

 

 

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.