Mail S/W Failed to work with NNM 6.10 for NT (57 Views)
Reply
Occasional Contributor
Nikos Tassopoulos
Posts: 2
Registered: ‎03-28-2000
Message 1 of 5 (57 Views)

Mail S/W Failed to work with NNM 6.10 for NT

Our company has purchased for evaluation the NNM 6.10 for Windows NT solution.
We tried to configure the Automatic Actions, in order to receive e-mails upon
generation of an event. Our approach was the adaptation of the MKS software (as
prescribed by NNM's online manuals) and followed its instructions :

>Example 3: Send an email message
>Type the following command, all on one line, in the >command for Automatic
Action field. The 'Subject:' >line will cause a subject to be inserted into
the >mail message.
>Windows NT: if you have MKS software,
>echo Subject:Trap Received\nA trap received from >enterprise $E with $#
args:\n$*' | >smtpmail 'root@corp'

unfortunately, it did not work (although it operated perfectly from the command
line, with the commands described in the online manual).

What should we do, in order to eventually get the MKS working from NNM's Action
field ?
Super Advisor
Berlene Herren_1
Posts: 515
Registered: ‎10-15-1999
Message 2 of 5 (57 Views)

Re: Mail S/W Failed to work with NNM 6.10 for NT

1. Change the permissions on the file to allow bin to run the file.

or

2. Change NNM to run actions as a specific user.

Example of usage:
In file $OV_LRF/ovactiond.lrf change last line to read:

OVs_YES_START:pmd:-u netman:OVs_WELL_BEHAVED::

Then do: ovaddobj $OV_LRF/ovactiond.lrf and ovstart

Berlene
Super Advisor
Berlene Herren_1
Posts: 515
Registered: ‎10-15-1999
Message 3 of 5 (57 Views)

Re: Mail S/W Failed to work with NNM 6.10 for NT

1. Change the permissions on the file to allow bin to run the file.

or

2. Change NNM to run actions as a specific user.

Example of usage:
In file $OV_LRF/ovactiond.lrf change last line to read:

OVs_YES_START:pmd:-u netmon:OVs_WELL_BEHAVED::

Then do: ovaddobj $OV_LRF/ovactiond.lrf and ovstart

Berlene
Occasional Visitor
Lee Walter
Posts: 3
Registered: ‎04-26-2000
Message 4 of 5 (57 Views)

Re: Mail S/W Failed to work with NNM 6.10 for NT

I am using MKS and NNM 6.1 for Windows NT also.

I type the following at "command for Automatic Action":
echo 'trap recieved from $E down' | smtpmail -h mail.xxx.com -s '$E down'
wlee@xxx.com

I never recieve the mail. However, the above command works from command line.

The followings are from the ovaction.log:
Wed Apr 26 14:19:40 Command "echo 'trap reciev from compaq down' | smtpmail -s
mai
l.xxx.com -s 'compaq down' wlee@xxx.com" returned standard output data:
'trap reciev from compaq down' | smtpmail -h mail.xxx.com -s 'compaq down'
wlee@xx
x.com

It seems to me the pipe never work. Only echo works.
Echo takes everything after echo as string and does not recongize the "|"
command.
I put c:\\mks\\mksnt\\echo.exe to use the echo from mks. The result is same.

Anyideas? Please help.
Thanks a lot.

Walter.
Advisor
Armindo Guilamba
Posts: 26
Registered: ‎06-09-2000
Message 5 of 5 (57 Views)

Re: Mail S/W Failed to work with NNM 6.10 for NT

Hi,

I used the second option from Berlen. It works.
I am using NNM 6.10 on NT, I used mapisend command line to notify me by e-mail in event of a node down. I have Microsoft Exchange server and no snmp service running.
I have created a account on exchange server, I called it Open View NNM and I gave permission to a valid NT, lets say user1.
I modified ovactiond.lrf to look likes:
OVs_YES_START:pmd:-u user1:OVs_WELL_BEHAVED::
And it works perfectly.


I have to say thanks Berlen, now I can use mapisend with OpenView to send message in NT.
I found mapisend in BackOffice Resource Kit CD.

See attachment for a sample batch file

Thank you
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.