Re: Last state Change Value not receive values (639 Views)
Reply
Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 1 of 9 (705 Views)
Accepted Solution

Last state Change Value not receive values

Good Day

 

My problem is with NNM 9.11 and I are sending this information to my custom poller already set to Last State Change table Value, why are not sending me alerts exceeds the configured threshold.

 

The strange thing is that the Node Component Gauges Tab if I have to monitor interfaces with information.

 

Greetings and thanks

Honored Contributor
AndyKemp
Posts: 751
Registered: ‎05-17-2010
Message 2 of 9 (691 Views)

Re: Last state Change Value not receive values

I might be covering old ground, but based on what I can see (migging columns) in order for custom polling to work  you have to have a few things:

 

1. A mib expression.  This can be a single oid or mathmatical calculation involving multiple oOIDs constants and operands.

2. A polling policy.   this says use a particular mib expression apply it to a defined group of elements t what interval.

3. Threshold (time or counter) or Comparison Matrix. These are the values you want to compare with the value you obtained with your polling policy. Thresholds are seeing if a returned polled value is greater than or less than a number you defined. they can be upper and lower but you must specify a rearm number (the value at which the condition is no longer valid usually one less or one more). Comparison Matricies  allow you to set specific conditions and state values  (normal , major critical, etc) for returned numbers. This is more helpful when you have a tabular set of conditions from the MIB.

 

I dont see #3 as being applied in your jpg.

 

 

Component Gage alarming is an out of the box ability configured by vendor in a binary file that you cannot modify or read. I order for this out of the box alarming to function you must have "Enable Node Component Polling" for the node or element enabled in Monitoring Settings, as well as the associated Management event under Incidents.

Have a nice day :)

Andy Kemp,  CISSP
Valued Contributor
bebu
Posts: 114
Registered: ‎06-14-2011
Message 3 of 9 (686 Views)

Re: Last state Change Value not receive values

Nestor,

 

you need to be look at "Display Attribute" in your mib expression, your field would be blank if you chose none or un-relevant to it. if possible please update your mib expression.

 

// Bebu

Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 4 of 9 (683 Views)

Re: Last state Change Value not receive values

Hello Bebu

 

In the MIB expression if I have complete the fields I show an image

I can have misconfigured?

 

regards

 

 

 

 

Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 5 of 9 (682 Views)

Re: Last state Change Value not receive values

Hi Andy


If I have configured this information you sent me
what was the set had no Comparison Map, even so I still have configured and results.

 

Do not send me the Custom Poller data and does not generate Incidents

 

regards

 

 

Valued Contributor
bebu
Posts: 114
Registered: ‎06-14-2011
Message 6 of 9 (663 Views)

Re: Last state Change Value not receive values

[ Edited ]

Nestor,

you have configured for % calculation but the display variable is in "textual converstion", How a % can be converted to textual thing? so,it displays nothing.

I can suggest you leave the display variable field "empty" and check for the results. you will get the value there.

//Bebu

Honored Contributor
AndyKemp
Posts: 751
Registered: ‎05-17-2010
Message 7 of 9 (657 Views)

Re: Last state Change Value not receive values

Good catch Bebu!

Have a nice day :)

Andy Kemp,  CISSP
Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 8 of 9 (652 Views)

Re: Last state Change Value not receive values

Hi Bebu

 

The only thing I would change was the atribute Display

 

This now shows me the number of MIB instance and as I had set to text displays the name of the interface.

I attached image

 

regards

Trusted Contributor
Nestor Herrera
Posts: 146
Registered: ‎06-13-2011
Message 9 of 9 (639 Views)

Re: Last state Change Value not receive values

I found the problem that will not collect data and this is by Custom Poller and had to delete and recreate collections and policies. Still do not know why the Custom poller not work until you reconfigure.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.