Re: localagent on DL100G2 (933 Views)
Reply
Occasional Advisor
Darwin Reiswig
Posts: 9
Registered: ‎02-02-2007
Message 1 of 20 (1,760 Views)

localagent on DL100G2

Has anyone else ever seen this error? I am receiving it regularly on a newly installed DL100G2 server.

Event Type: Information
Event Source: Application Error
Event Category: (100)
Event ID: 1004
Date: 2/2/2007
Time: 7:54:24 AM
User: N/A
Computer: SERVERNAME
Description:
Reporting queued error: faulting application localagent.exe, version 0.0.0.0, faulting module localagent.exe, version 0.0.0.0, fault address 0x00029b2f.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp .
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 6c 6f 63 ure loc
0018: 61 6c 61 67 65 6e 74 2e alagent.
0020: 65 78 65 20 30 2e 30 2e exe 0.0.
0028: 30 2e 30 20 69 6e 20 6c 0.0 in l
0030: 6f 63 61 6c 61 67 65 6e ocalagen
0038: 74 2e 65 78 65 20 30 2e t.exe 0.
0040: 30 2e 30 2e 30 20 61 74 0.0.0 at
0048: 20 6f 66 66 73 65 74 20 offset
0050: 30 30 30 32 39 62 32 66 00029b2f
Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 2 of 20 (1,760 Views)

Re: localagent on DL100G2

could you install Service Release 6.2 and see if problem goes away ?
JYP
Occasional Advisor
Darwin Reiswig
Posts: 9
Registered: ‎02-02-2007
Message 3 of 20 (1,760 Views)

Re: localagent on DL100G2

SR 6.2 was my first troubleshooting step. This error continued after that was installed.
Occasional Visitor
Chris Athey
Posts: 1
Registered: ‎02-07-2006
Message 4 of 20 (1,760 Views)

Re: localagent on DL100G2

Hi Darwin, yes seen on two DL100s so far. The source of the error - localagent.exe - is part of the HP Server Managment Systam (SMS) software and removing this app. was enough to stop the error appearing on both servers.

A note of caution - might be a genuine fault that SMS is trying to warn you about and the SMS notification function is failing on sending an email. Installing Service Release 6.2 made a difference on my servers and I now leave SMS installed although I don't touch any settings or set alerts.

My fix came about after discussions with HP Support providing logs files and trying out a number of suggestion. At one stage they recommended running a full server Recovery. I choose not to do this as downtime was not really an option then.

If you have the time I strongly recomend working throughly on getting the DL100 build to the best level you can - it could save a lot of time. At minimum read the customer advisories esp. replacement SATA cable and prepare just in case.


Good luck.

Regards
Chris





Occasional Advisor
Darwin Reiswig
Posts: 9
Registered: ‎02-02-2007
Message 5 of 20 (1,760 Views)

Re: localagent on DL100G2

I think I may have it fixed. I removed SMS and reinstalled it using the SR 6.2 setup. I'll keep an eye on it to make sure it's gone, but it looks good so far.
Occasional Advisor
Darwin Reiswig
Posts: 9
Registered: ‎02-02-2007
Message 6 of 20 (1,760 Views)

Re: localagent on DL100G2

Looks like that did not fix it. Anyone have any other ideas?
Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 7 of 20 (1,760 Views)

Re: localagent on DL100G2

post complete eventlogs please
JYP
Occasional Advisor
Darwin Reiswig
Posts: 9
Registered: ‎02-02-2007
Message 8 of 20 (1,760 Views)

Re: localagent on DL100G2

Application log.
Occasional Advisor
Darwin Reiswig
Posts: 9
Registered: ‎02-02-2007
Message 9 of 20 (1,760 Views)

Re: localagent on DL100G2

System Log.
Occasional Visitor
Chrisathey
Posts: 2
Registered: ‎02-22-2007
Message 10 of 20 (1,760 Views)

Re: localagent on DL100G2

Hi Darwin, as suggested earlier removing HP SMS completely will stop the errors appearing. This worked for me on Storage Servers before the 6.2
update was applied.

Another suggestion I have and this has worked on DL100G2 servers running the 6.2 update:
try switching off all snmp and email alerting.

Both of these will provide a quick fix and buy you time to work out the root cause. Either you will identify the hardware/software problem that SMS is trying to warn you about or HP will get round to sorting out the bug in localagent.

Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 11 of 20 (1,580 Views)

Re: localagent on DL100G2

this article will help you i think
JYP
http://support.microsoft.com/kb/261007/en-us
Occasional Advisor
Darwin Reiswig
Posts: 9
Registered: ‎02-02-2007
Message 12 of 20 (1,580 Views)

Re: localagent on DL100G2

The MS article didn't help. DNS was set up correctly.

I tried disabling the SMS service, and still got errors.

I am now trying to remove the SMS service to make sure that stops the problem.
Occasional Visitor
Chrisathey
Posts: 2
Registered: ‎02-22-2007
Message 13 of 20 (1,580 Views)

Re: localagent on DL100G2

Suggest you raise a case directly with HP. There is an alert shown in your logs which you need to resolve.

Look for events like this in the log.

Adaptec Storage Manager Agent

1/29/2007 2:53:31 PM Adaptec Storage Manager Agent Information None 307 N/A USM0647033-
Occasional Advisor
Darwin Reiswig
Posts: 9
Registered: ‎02-02-2007
Message 14 of 20 (1,580 Views)

Re: localagent on DL100G2

I did have a drive failure. That's probably what you saw in the logs. I have already had that replaced since then.
Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 15 of 20 (1,580 Views)

Re: localagent on DL100G2

also do you have nic port disable ?
if yes try to enable it even not connected
BCM
Occasional Visitor
BCM
Posts: 1
Registered: ‎02-23-2007
Message 16 of 20 (1,580 Views)

Re: localagent on DL100G2

Darwin

I am currently experiencing the same issue and have been following the forum. I uninstalled and reinstalled SMS using SR 6.2 just as you did, only to have the errors return at 4:53AM the next day.

I disabled the SMS Local Agent service and have not had the error return in more than 24 hours, but this is not a solution.

If anyone is working with HP on this, I would really be interested.

Thanks
Trusted Contributor
Jon Paul
Posts: 166
Registered: ‎05-28-2003
Message 17 of 20 (1,580 Views)

Re: localagent on DL100G2

Hi All,
There is another update to SMS available at:
http://h18023.www1.hp.com/support/files/server/us/locate/1098_6259.html
This release is specifically targeted to stop the LocalAgent issues.
Please uninstall SMS 2.00 or 2.01 prior to installing 2.02

Hope this helps. Please respond to this forum if you continue to have issues.

Thanks,
JP
Occasional Advisor
Darwin Reiswig
Posts: 9
Registered: ‎02-02-2007
Message 18 of 20 (1,580 Views)

Re: localagent on DL100G2

Looks like the 2.02 update did the trick. No more error messages. Thanks!
Occasional Visitor
Bernard White
Posts: 1
Registered: ‎04-22-2007
Message 19 of 20 (1,580 Views)

Re: localagent on DL100G2

I am running SR6.2. And when I enable the 2nd NIC it fixes the problem. The thing is, I don't really want this NIC enabled if it is not in use as I'm sure other people will agree. HP really should fix this.
Occasional Visitor
MatthewRCarter
Posts: 1
Registered: ‎06-03-2013
Message 20 of 20 (933 Views)

Re: localagent on DL100G2

Thanks peyrache!  Our secondary NIC port was disabled and after enabling it, the error went away.  Kudos to you!

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.