NAS 1500s / DL100 Update to Latest Service Release 6.6 (1627 Views)
Reply
Frequent Advisor
Darrin Addams_1
Posts: 42
Registered: ‎09-02-2006
Message 1 of 22 (1,627 Views)

NAS 1500s / DL100 Update to Latest Service Release 6.6

I've just done a rebuild on my NAS 1500s. It's been a difficult process and I still haven't managed to successfully complete it. Here's how I've done so far:

1. Use the Quick Restore DVD

2. Apply service release 5.6 which includes SP1.

3. Apply the rebranding (change from 1500s to DL100).

4. Install the SP2 installation assistant and use it to install SP2.

5. Apply service release 6.2

6. Apply service release 6.6


Notes:

1. I tried missing out SR 6.2 and got an odd warning message stating that it wasn't the correct type of storage server.

2. I tried installing SP2 as part of the service release but that failed. It seems it must be installed before applying any service release greater than 5.6.

3. The installation of service release 6.6 hung at the very last section, when installing the Intel NIC driver updates. I waited for ages for the machine to finish but had to give up. Apparently this is an issue then.

So, not the easiest process in the world - takes several hours to do (if it works) and then you have to repeat for the second O/S installation!

Has anyone else managed to get these units to SR 6.6 without any indcidents?
Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 2 of 22 (1,627 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

no
JYP
Advisor
Rolf_10
Posts: 10
Registered: ‎01-05-2009
Message 3 of 22 (1,627 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

Could you contact me I have a problem with a similar unit that you might be able to help me with.

Regards
Advisor
Rolf_10
Posts: 10
Registered: ‎01-05-2009
Message 4 of 22 (1,627 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

Is it possible to Quick Restore DVD but only the OS part?

The issue is that I do not have thye original HDDs so trying to Quick Restore DVD gives an error. According to this forum this is because the Segate HDDs that I am using are not supported.

I have tried to use the Release pss, but it cannot run by itself (I assume that it must have the Original HP software installed).
Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 5 of 22 (1,627 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

what is really this issue on this nas ?
which type of disk and size is installed ?
JYP
Advisor
Rolf_10
Posts: 10
Registered: ‎01-05-2009
Message 6 of 22 (1,627 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

I have a HP Storage Server NAS 1500s (now called DL100).

I bought it with all Disks removed.

I places 2 x Seagate Hard Disks into slot #0 and #1. Each disk was 500GB in size.

I configured the RAID controller (Adaptec 2410SA) as Volume (although I tried RAID1 also) and formatted both Drives as NTFS.

I then attached a USB DVD drive and put the Quick Restore DVD into the Drive.

When I boot the StorageWorks NAS initially starts, but when it gets to the part when the restore should happen the following message is displayed.
"QuickRestore failed to detect a supported SATA RAID controller. Please ensure the proper SATA RAID controller is installed in the system".

Selecting "R" reboots the system.

No matter what I did I could not get it to work. In the end I placed the Windows Storage Server 2003 R2 CD into the DVD and formatted the drives that way.

This works but of course I do not have access to the HP StorageWorks software.

Can you help me get it working as it should?

Regards
Rolf Pfotenhauer
Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 7 of 22 (1,627 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

QR should work with 500GB disk drives
please check firmware version of Sata Controller
erase partition on disk, QR will create them for you
JYP
Advisor
Rolf_10
Posts: 10
Registered: ‎01-05-2009
Message 8 of 22 (1,627 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

Firmware for RAID is Adaptec 2410SA. This appears to be working OK, since I can boot and format the HDD's using the Windows Storage Server 2003 R2 CD without any problems in finding the Hard Disk.

The BIOS also shows that the HDD is present and shows "2410SA Sata" Drive. It has shown this since the very first attempt. Like I said, everything appears to be correct but the "Quick Restore" CD cannot see the HDD. Why?

Initailly when I was setting up this configuration the 500 GB hard disks were unformatted. So it is unlikely that the Quick Restore is not working because the HDDs are already formatted.

Trying to use Quick Restore gave me the same error message on each and every attempt at using it as I have already indicated.


Regards
Rolf
Frequent Advisor
Darrin Addams_1
Posts: 42
Registered: ‎09-02-2006
Message 9 of 22 (1,627 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

I can only say that I've used the quick restore on a machine with all four drives installed and not just two. Perhaps this is the problem? Incidentally, my NAS 1500s is running fine on 4x 500GB Seagate drives so there shouldn't be a problem with compatibility. I used the ES and ES.2 types on my two NAS units whih are the "enterprise class" SATA models. Having said that, I experienced one drive failure during a much-needed defrag.

As for my original issue, here's the sequence which worked for me:

1. Run the Quick Restore process â this must be run from the external DVD drive

2. Install service release disk version SR5.6 â this can be run either from the disk supplied by HP or from the downloaded version.

3. Rebrand appliance â this must be run from the disk supplied by HP

4. Using the Service Pack 2 Installation Assistant, install service pack 2 â the installation assistant utility can be downloaded from the HP web site and *must* be used to install service pack 2. Installing service pack 2 will fail without the utility. Service pack 2 can be downloaded from Microsoft.

5. Install service release disk version SR6.2 â this can be run either from the disk supplied by HP or from the downloaded version.

6. Install service release disk version SR6.6 â this can be run either from the disk supplied by HP or from the downloaded version. Note that itâ s probably a good idea to un-tick the Intel NIC driver installation as it may hang at this point in the process. It is possible to restart the machine after installing SR6.6 and re-run the SR6.6 installation from the icon on the desktop. The NIC drivers can then be installed without a problem.

Hope that helps :)
Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 10 of 22 (1,627 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

bios must be match with Driver on QR dvd
and WQ will create volume and format them
so i assume you have trouble with SATA adapter
JYP
Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 11 of 22 (1,257 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

tried to destroy raid under bios setup
an restart QR
JYP
Frequent Advisor
Darrin Addams_1
Posts: 42
Registered: ‎09-02-2006
Message 12 of 22 (1,257 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

The QR will restore to the factory default and as there are only three model variants, all of which are shipped with all four drives, isn't there a possibility that the QR disk is simply expecting four drives rather than just two?
Advisor
Rolf_10
Posts: 10
Registered: ‎01-05-2009
Message 13 of 22 (1,257 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

Can anyone definately confirm that for QR to work it needs 4 hard drives (in whatever configuration)?

second question: why is service release 6.2 needed before applying service release 6.6? Doesn't SR 6.6 contain the SR 6.2 contents?

Regards
Rolf Pfotenhauer
Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 14 of 22 (1,257 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

it's depends on DL100 models
from quickspecs for DL100 disk configuration
supported by QR

Four (4) Hot plug 1" 7200 RPM SATA Hard Disk Drives standard

4 x 80 GB (320 GB Model)
4 x 160 GB (640GB Model)
4 x 250GB (1TB Model)

for DL100G2
Internal Storage
Front loading, hot plug, 7200 RPM SATA Hard Disk Drives

4 x 250GB (1TB Model)

4 x 500GB (2TB Model)

2 x 160 GB (3TB & 6TB Models) (For O/S Only)

about SR upgrade there are some issue from 5.6 to 6.4 , i can work or not
so better to do in 3 steps
hope to help
JYP
Advisor
Rolf_10
Posts: 10
Registered: ‎01-05-2009
Message 15 of 22 (1,257 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

By saying (in my case 1TB Model)
... DL100 disk configuration supported by QR

Four (4) Hot plug 1" 7200 RPM SATA Hard Disk Drives standard
4 x 250GB (1TB Model)

This tells me only what the maximum that is supported.

What I want to know is, do all 4 drives need to be installed to support QR?

Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 16 of 22 (1,257 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

yes because QR create raid1 on 2 first disk
for system partition and Raid1 on two last for spare partition system and create a data
partition on 4 disk in remaining space in raid5
is it clear ?
JYP
Advisor
Rolf_10
Posts: 10
Registered: ‎01-05-2009
Message 17 of 22 (1,257 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

For the benefit of anyone else reading this, this is how the Disks are arranged on a 1500s as I undertstand it.

QR Disk Assignments
===================
Disk #0 - RAID1 (Primary system partition) + RAID5 (Data partition)
Disk #1 - RAID1 (Primary system partition) + RAID5 (Data partition)
Disk #2 - RAID1 (Secondary system partition) + RAID5 (Data partition)
Disk #3 - RAID1 (Secondary system partition) + RAID5 (Data partition)

Trusted Contributor
peyrache
Posts: 383
Registered: ‎09-01-2004
Message 18 of 22 (1,257 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

right, this is also documented in management/user guide
JYP
Occasional Advisor
Raymond Pinkerton
Posts: 6
Registered: ‎04-12-2008
Message 19 of 22 (1,257 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

As a bye the bye on this matter I have two 1500s/DL100G1 devices running with 4 x 1Tb Seagate disks.

Procedure I followed was to use the Recovery DVD as normal to install the device, this completes successfully.

When this has finished it creates and configured the two 9Gb arrays and an other funny sized array (about 350Gb) as drive F:. I downloaded the Adaptec Storage Manager (ASM) software and installed this onto the device. I've used both the orignal and the latest 4.10 versions of ASM successfully, Adaptec's web site says the 2410 is not supported by the 4.10 version but it worked fine for me.

I then removed the large partition in Windows and then deleted the array in ASM. Maximum partition size is 2Tb so to use all the space I created a 720Gb Drive F: and a 2047.441Gb Drive G:.

Devices seem to work fine, boot into either OSs fine but I did have to add the drive letters for the manually created arrays in the second copy of Windows but other than that all was cool.

Hope this is of interest.

Cheers

Ray
Occasional Visitor
cliffie
Posts: 1
Registered: ‎07-26-2009
Message 20 of 22 (1,257 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

The ability to use the QR cd involves making sure that the sata raid card has the correct BIOS installed. If the bios on the sata raid card has ever been updated, the QR cd will fail to function because it cannot recognize that raid card.
Frequent Advisor
roberttco
Posts: 36
Registered: ‎10-03-2006
Message 21 of 22 (1,167 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

The correct firmware version is 7244 - http://www.adaptec.com/en-US/downloads/bios_fw/bios_fw_ver?productId=AAR-2410SA&dn=Adaptec+Serial+AT...
Please considder assigning points if you value my assistance.
Occasional Visitor
ultiman
Posts: 2
Registered: ‎11-25-2010
Message 22 of 22 (1,133 Views)

Re: NAS 1500s / DL100 Update to Latest Service Release 6.6

thank you for this all,

i read and understood but after i reimaged the 2410sa to 7244 bios the SATA Adapter can not be found by QR DVD 4.3.

Is another point to roll back to normal status ?

 

regards from Bremen / Germany

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.