MSM760 / MSM317 and VLANs (292 Views)
Reply
Occasional Collector
RickSmith
Posts: 1
Registered: ‎02-27-2013
Message 1 of 1 (292 Views)

MSM760 / MSM317 and VLANs

[ Edited ]

Hi all,  Little trouble here configuring up a new MSM760 with some (185) MSM317's and a handful of MSM430's.

 

Idea:  Put MSM317's in all rooms of 180 room hotel.   

 

Thought:  Mgmt VLAN for all those 317's to get IPs from.  (VLAN 242)

Thought2: Wireless VLAN for all those 317's to hand out IPs to wifi customers (VLAN 243)

Thought3: Switch Ports on the 317 - two more VLANS (244/245) one for handicapped bandwidth, the other for Pay-BW at 20+mbps.

 

Test Switch Config:   Cisco 3550 - Port 24 brings in all 4 vlans tagged from our router (Mikrotik 751 in this case) - that's what does the DHCP for us....

 

MSM760 Internet port is connected into our corporate network (10.2.211.2)

MSM760 LAN Port is connected into VLAN 242 untagged port on test Cisco switch.

 

1)  I can "untag" 4 different ports on the switch, each in a different vlan, and get the appropriate IP address for each VLAN.

 

2) AP connects up to MSM760 (untagged on VLAN242) successfully and broadcasts VSC "GuestWiFi"

 

3) Here's the config on the port where the test MSM317 is plugged in:

interface FastEthernet0/12
switchport access vlan 242
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 243-245
switchport mode access

 

4) The trunk port in to the Cisco:

interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 242-245
switchport mode trunk

 

5) The MSM760 LAN Port is plugged into FA0/14 which is untagged (mode access) on 242

 

6) VSC Settings - GuestWiFi - no auth / no access control (I want to dump users directly on to the Ethernet and let routers

/ paid gateways, etc handle their traffic based on the VLAN routing we've got set up.

 

7) Group Settings - "Default Group" has this test MSM317 in it, with the VSC Mapping of GuestWiFi and the VSC Binding for GuestWiFi says put it out on VLAN243

 

Problem:   I get connected via WiFi but never get an IP address to the client.

 

Problem 2:  Even though I've set the egress option on Switch Port 2 to be VLAN244, I don't get an IP address from it, either.

 

 

Help here on where to look next ?

 

Thanks!

 

 

 

P.S. This thread has been moved from Communications, Wireless (Legacy ITRC forum) to MSM Series. - Hp Forum Moderator

 

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation