loadrunner recorded scirpts has messy code(broken chinese character) (256 Views)
Reply
Occasional Advisor
kernelkoder
Posts: 33
Registered: ‎12-11-2012
Message 1 of 3 (256 Views)

loadrunner recorded scirpts has messy code(broken chinese character)

hello,

i recorded a script from a chinese website, after recording, i found many url that has chinese character has broken, how to solve this issue? i also set record option to encoding of urtf-8, but it don't work.

Please use plain text.
Frequent Visitor
Lyubomir
Posts: 3
Registered: ‎05-24-2012
Message 2 of 3 (245 Views)

Re: loadrunner recorded scirpts has messy code(broken chinese character)

Hello,

 

1. What is your LR version?

2. Do you get the same problem from another installation?

3. Do you get the same error when recording another chinese sites?

4. Is that site public, so we can try and verify?

 

Best,

Lyubo

Please use plain text.
HP Expert
Editus
Posts: 639
Registered: ‎04-06-2011
Message 3 of 3 (173 Views)

Re: loadrunner recorded scirpts has messy code(broken chinese character)

Hello

To make Vugen able to scan GB23I2 encoded chinese characters
one need to set the local to Chinese simplified and make sure that it has the GB 2312 conversion table. You can do this by going to control panel->Regional settings (Regional and Language options)->Advanced->Code Page conversion tables->Select 10008 (MAC- Simplified Chinese GB2312) and then one can use lr_xml related functions to parse the returned xml reponse with chinese characters.


regards
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation