Re: in RTE protocol exit is not happening giving timeout error (87 Views)
Reply
Frequent Advisor
himanshuk
Posts: 64
Registered: ‎12-17-2013
Message 1 of 2 (111 Views)

in RTE protocol exit is not happening giving timeout error

through script I wrote a code :

 

below I am unable to exit from putty gives 90 timeout error, cursor blink till "sometext>" I expect exit should type here from below bottom lines

 

TE_type("g.ack<kReturn>");
    TE_wait_text("sometext>", 90,1,yStartPos+1,80,600,&xStartPos,&yStartPos);
    TE_wait_sync();
    lr_output_message("=================%d",yStartPos);

    TE_get_text_line(1,yStartPos-1,-1,text);
    //lr_output_message("=========##===%s",text);

        while(row<yStartPos)   //row=1
            {
                TE_get_text_line(1,row,-1,text);
                lr_output_message("##########%s",text);
                row++;
            }


    TE_type("exit<kReturn>");  //exit is not typing after exiting loop
    TE_type("exit<kReturn>");

prod support
telecom

Smile tomorrow will be worse !!!
Frequent Advisor
himanshuk
Posts: 64
Registered: ‎12-17-2013
Message 2 of 2 (87 Views)

Re: in RTE protocol exit is not happening giving timeout error

this issue is resolved
int i=0,xStartPos=0,yStartPos=0,xEndPos=0,yEndPos=0,lineNo=0,xPos=0,yPos=0,row=1;
char gettext[200];
TE_type("cd path\<kReturn>");
TE_wait_text("patterntwait>", 90,1,yStartPos+1,80,200,&xStartPos,&yStartPos);
TE_wait_sync();
TE_type("g.ack<kReturn>");
TE_wait_text("patterntwait>", 90,1,yStartPos+1,80,200,&xEndPos,&yEndPos);
for(lineNo=yStartPos+1;lineNo<yEndPos;lineNo++)
{
TE_get_text_line(1,lineNo,-1,gettext);
lr_output_message("%s",gettext);
}
prod support
telecom

Smile tomorrow will be worse !!!
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.