VUGEN 11.52 Http/WEB and Certification Errors (228 Views)
Reply
Occasional Visitor
leresrick
Posts: 2
Registered: ‎08-22-2013
Message 1 of 2 (228 Views)

VUGEN 11.52 Http/WEB and Certification Errors

I have a problem recording an application in a Test environment that does not have a valid 'Certificate'. The browser generates a browser error that requires the user to click 'Continue', to accept the risk and then continue to the URL that was originally launched. This works manually launching the URL outside VUGEN.

 

From inside VUGEN the recorder never launches the URL, when I do a packet capture I can the recorder sending HTTP SYNC frames but never a HTTP GET request.

 

The browser is IE8, if I switch to FireFox as the browser VUGEN sees the 'Certificate' error.

 

The reason for the Certificate error is the vendor did not spend the money to purchase a Certifcate for the test system, the production system has a valid Certifiate for the application.

 

My company does not support FireFox so changing the browser is not an option.

 

Has anyone seen this problem with IE8 or IE9, IE9 works the same. If so Has anyone worked around the Certifice error and successflly recorded the application with 11.52?

 

Please use plain text.
HP Expert
Editus
Posts: 630
Registered: ‎04-06-2011
Message 2 of 2 (214 Views)

Re: VUGEN 11.52 Http/WEB and Certification Errors

Hello

Try Creating a port mapping entry or recording at winInet level, that will resolve the problem

 

regards

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation