System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7 (2368 Views)
Reply
Occasional Visitor
achyut
Posts: 3
Registered: ‎01-27-2013
Message 1 of 12 (2,368 Views)

System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

Please help after installing Loadrunner11.5 wen i click VUGEN it prompts below error msg.

 

System.Runtime.InteropServices.COMException (0x80040154): Retrieving the COM class factory for component with CLSID {CF405F74-C2F7-4814-AD81-525877D8C9A0} failed

Please use plain text.
Honored Contributor
shiv_p
Posts: 2,841
Registered: ‎04-23-2008
Message 2 of 12 (2,360 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

Do you have ALM installed on the same machine??

Please use plain text.
Occasional Visitor
Vimalalmb
Posts: 2
Registered: ‎01-31-2013
Message 3 of 12 (2,354 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

Am not sure,How should I check them?should i need to downlad them.
Please use plain text.
Occasional Visitor
Vimalalmb
Posts: 2
Registered: ‎01-31-2013
Message 4 of 12 (2,354 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

How to check this?should i need to download them?

Please use plain text.
Honored Contributor
shiv_p
Posts: 2,841
Registered: ‎04-23-2008
Message 5 of 12 (2,338 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

No, if it;s not installed....you don;t need to download.

 

ALM is known to conflict with such error.

 

Install VUGen alone on any other system and check if it goes fine?

Please use plain text.
Visitor
shmilsson
Posts: 3
Registered: ‎02-18-2013
Message 6 of 12 (2,306 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

I am getting this same error message with Windows XP:

 

System.Runtime.InteropServices.COMException (0x80040154): Retrieving the COM class factory for component with CLSID {CF405F74-C2F7-4814-AD81-525877D8C9A0} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

 

I have tried reinstalling .NET 3.5 SP 1 and LoadRunner numerous times. When checking out the registry I can find no entry with a CLSID CF405F74-C2F7-4814-AD81-525877D8C9A0.

 

Let me know if I should start a new thread for thsi rather than adding to this.

 

Cheers,

 

Shmili

Please use plain text.
Visitor
shmilsson
Posts: 3
Registered: ‎02-18-2013
Message 7 of 12 (2,304 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

I should also add this is being done through an evaluation license. This has been setup and when I start up the application it says I have the license until the 23rd of this month. The Proof of Concept I'm developing should only take a few minutes. SO far this installation bug has had me stumped for over a day.

 

There is an application blocking the java update scheduler included in the JRE that is installed with LoadRunner that I'm not able to bypass until tomorrow. Could this be causing the issue?

Please use plain text.
Occasional Visitor
Sundaram_Tata
Posts: 1
Registered: ‎05-20-2013
Message 8 of 12 (2,127 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

I checked the key in the error log, and looks like “SnapshotLoaderWrap.dll” didn’t get registered in your machine.

The DLL should be located in “C:\Program Files\Hp\Virtual User Generation\bin”

 

There are couple of things I would like you to try:

1)      Check if you have DLL in this location

2)      If not copy the DLL from  any machine which has the sucessfull installation of Vu Gen

 

If you have the DLL already or have copied the DLL in to your machine, do the following;

1)      Open the command prompt

2)      Type “reg svr32  C:\Program Files\Hp\Virtual User Generation\bin

3)      Press enter

The DLL will get registered and the error should go away.

Please use plain text.
Occasional Advisor
SundarAK
Posts: 5
Registered: ‎07-08-2013
Message 9 of 12 (1,906 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

Steps to solve the issue..

 

This issue is coming due to registration failure and the log can be found in "C:\Windows\Temp\HP_[ProductName]_RegistrationFailure.log".

 

The below mentioned steps solved the issue in my machine!!

 

Step 1: Copy the Registration failure log (C:\Windows\Temp\HP_[ProductName]_RegistrationFailure.log) to Desktop

 

Step 2: Remove all "ERROR ON COMMAND:" string from the file

 

Step 3: Then change the path from "C:\Windows\SysWOW64\regsvr32.exe" to "C:\Windows\System32\regsvr32.exe"

 

Step 4: Save the file with (<filename.bat>) ".bat" extension

 

Step 5: Double Click the batch file to run

 

Now open the Vugen.. It will open without any issues!!

Please use plain text.
Occasional Visitor
chgiudici
Posts: 1
Registered: ‎09-23-2013
Message 10 of 12 (1,569 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

Hi,

 

what can I do, if there is no RegistrationFailure.log? I run into the same issue... reinstall didn't work.

Win7 64bit, .NET Framework 4.5

 

regards,

Christian

Please use plain text.
Visitor
shmilsson
Posts: 3
Registered: ‎02-18-2013
Message 11 of 12 (1,536 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

[ Edited ]

Thanks for the reply, I did end up sorting it out by cloning the registry from a machine with a successful installation. Something about the infrastructure at this particular site was stopping LoadRunner from registering the snapshotloaderwrap dll properly.

 

Anywho, if it happens again I'll try the steps mentioned here as cloning registries isn't a good idea.

Please use plain text.
Occasional Visitor
BRZR
Posts: 1
Registered: ‎04-13-2014
Message 12 of 12 (648 Views)

Re: System.Runtime.InteropServices.COMException - LoadRunner11.5 in Window 7

Hi,

Try reinstalling LR 11.5 by logging in as "Administrator".

I had the same problem. unregistered class file  {CF405F74-C2F7-4814-AD81-525877D8C9A0}. This happens when your user account on the system does not have complete admin rights and hence the class files will not be regestered in windows registry properly.

 

Solution: Uninstall LR 11.5

Log in as Administrator.

Install 11.5 again.

 

Thanks,

Brijesh Mishra.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation