Script is not recording using Ajax protocol in LR 9.5 (1586 Views)
Reply
Occasional Visitor
shaik
Posts: 3
Registered: ‎04-25-2011
Message 1 of 9 (1,586 Views)

Script is not recording using Ajax protocol in LR 9.5

Hi,

 

I was trying to record the script using Ajax protocol in Vugen 9.5 but I can not. Transactions are not getting recorded because of some issue. If any one knows the exact issue, then please share your answers.

 

Thanks

Ahamed

Advisor
Vivi_1
Posts: 22
Registered: ‎04-14-2011
Message 2 of 9 (1,586 Views)

Re: Script is not recording using Ajax protocol in LR 9.5

Are you using 64 bit Operating System?, Because Vugen recording is not supported in it.

Advisor
Vivi_1
Posts: 22
Registered: ‎04-14-2011
Message 3 of 9 (1,586 Views)

Re: Script is not recording using Ajax protocol in LR 9.5

Makesure your OS is not 64 bit and turn off the firewall while recording.

Occasional Visitor
shaik
Posts: 3
Registered: ‎04-25-2011
Message 4 of 9 (1,586 Views)

Re: Script is not recording using Ajax protocol in LR 9.5

I am working on 32-bit operating system only. I tried to record the script by turning off the Firewall then also no transactions are getting recorded. am using IE6 here. I can successfuly record the script using Http protocol but the problem occurs when am using Ajax protocol only. Is there any change is required in recording options of Vugen while using Ajax?

Advisor
Vivi_1
Posts: 22
Registered: ‎04-14-2011
Message 5 of 9 (1,586 Views)

Re: Script is not recording using Ajax protocol in LR 9.5

did u use protocol analyzer?, does it show ajax?

Advisor
Vivi_1
Posts: 22
Registered: ‎04-14-2011
Message 6 of 9 (1,586 Views)

Re: Script is not recording using Ajax protocol in LR 9.5

Let me know the type of application u're working on to help me understand the situation better.

Occasional Visitor
shaik
Posts: 3
Registered: ‎04-25-2011
Message 7 of 9 (1,586 Views)

Re: Script is not recording using Ajax protocol in LR 9.5

 

I have analysed my application with 'protocol analyser' and it suggested Ajax protocol only. My application is  designed in J2EE.

I can able to record the script on other machine for the same application using Ajax protocol but on my machine I can not? In both machines, I was administrator only. Here, I have two questions.......

1) Is there any user priviliges specific to Load runner that prohibiting me not to generate the script after recording? If yes, how to figure it out?

2) Do we require any additional software when we are using Ajax protocol?

 

Thanks for your support.

Advisor
Vivi_1
Posts: 22
Registered: ‎04-14-2011
Message 8 of 9 (1,586 Views)

Re: Script is not recording using Ajax protocol in LR 9.5

You may require user privilege to install the components of LoadRunner but not to run them unless you restrict the access for a particular user. I hope anyone of the following will solve your issue

 

1.Makesure you're using ajax (click and script) protocol.
2.Makesure your application interacts with the server on that particular machine.
3.Take a look at your runtime settings in VUgen, especially the proxy settings. Select the 'same settings as default browser' option.
4.Checkout your Recording options before you start recording.
Navigate to Recording Options > Network > Port Mapping > Try recording with different capture levels.
If u still encounter problems in ajax protocol then I'd suggest to switch to LR11 ajax truclient protocol. Hope that will solve your problems, Ajax truclient protocol in LR11 is much better than the one in LR 9.5.

 

 

Occasional Visitor
Ekamban
Posts: 1
Registered: ‎03-26-2012
Message 9 of 9 (1,290 Views)

Re: Script is not recording using Ajax protocol in LR 9.5

Please use VUGen 11. It will supports Ajax protocols.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.