SSL protocol error when attempting to read with host (1890 Views)
Reply
Valued Contributor
Pathan
Posts: 99
Registered: ‎07-24-2012
Message 1 of 5 (1,890 Views)

SSL protocol error when attempting to read with host

Hi,

 

While running the script in Performance Center i am getting the below errors.

 

"SSL protocol error when attempting to read with host"

 

Does any one experienced this error before? If so, would you please share me the details for the work around?

 

 

Thanks,

Pathan

Honored Contributor
shiv_p
Posts: 2,860
Registered: ‎04-23-2008
Message 2 of 5 (1,868 Views)

Re: SSL protocol error when attempting to read with host

Provide more details...like error code.

 

Add the following statement to the beginning of the script:

web_set_sockets_option("SSL_VERSION", "3"); 

 

This forces the SSL connection to the server to use version 3 of the SSL protocol rather than letting the server suggest a version during the connection handshake.

Occasional Visitor
VaibhavZodge
Posts: 2
Registered: ‎04-19-2011
Message 3 of 5 (379 Views)

Re: SSL protocol error when attempting to read with host

Try to put below code at the start of of script

 

use web_set_sockets_option("SSL_VERSION", "TLS");

Visitor
Rogard Ross
Posts: 3
Registered: ‎10-13-2009
Message 4 of 5 (224 Views)

Re: SSL protocol error when attempting to read with host

I had the same issue.     The suggestion to use 

web_set_sockets_option("SSL_VERSION", "TLS");

worked

Advisor
SSGUY
Posts: 18
Registered: ‎11-12-2012
Message 5 of 5 (129 Views)

Re: SSL protocol error when attempting to read with host

We had same issue on vugen 11.50,  we tried the following option which worked for us. 

 

Run-Time Settings -> Preferences -> Select "WinInet Replay Engine instead of Sockets (Windows Only)."

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.