Re: Loadrunner V11 and ESRI ARCMap V10 - Any Knowledge (665 Views)
Reply
Member
mikecollins_1
Posts: 3
Registered: ‎06-03-2011
Message 1 of 7 (777 Views)

Loadrunner V11 and ESRI ARCMap V10 - Any Knowledge

Anybody out there got any knowledge of working Loadrunner with ESRI ARCMap V10 GIS software?

 

I have just run up the protocol adviser and as soon as the application is launched if fails with the following:

 

ARCMap.exe - Application Error

The exception Illegal Instruction

An attempt was made to execute an illegal instruction.

(0xc000001d) occurred in the application at location 0x0024f175.

 

Something basic I'm missing perhaps?

 

Thanks.

 

 

HP Expert
Suerte13cr
Posts: 736
Registered: ‎09-14-2011
Message 2 of 7 (756 Views)

Re: Loadrunner V11 and ESRI ARCMap V10 - Any Knowledge

Hi Mike,

 

You have to make sure DEP is completely off not just disabled, doing /NOEXECUTE=ALWAYSOFF in the boot.ini file. This requires a restart when changing.

 

This will not work on 64 bit OS.

 

Regards,

Mario

HP LR/PC Support

If you are customer you can try posting on our internal forums for more personalized support.

LoadRunner:
http://h30499.www3.hp.com/t5/LoadRunner-Support-Customer/bd-p/loadrunner-support-customer-forum

Performance Center:
http://h30499.www3.hp.com/t5/Performance-Center-Support/bd-p/performance-center-support-customer

How to:
http://www.youtube.com/watch?v=4ChlysWupWM

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Member
mikecollins_1
Posts: 3
Registered: ‎06-03-2011
Message 3 of 7 (750 Views)

Re: Loadrunner V11 and ESRI ARCMap V10 - Any Knowledge

Checked and confimed that DEP is 'AlwaysOff' - Not a 64 bit machine.

 

Restart but error still occurs.

 

Any further suggestions welcomed!

HP Expert
Suerte13cr
Posts: 736
Registered: ‎09-14-2011
Message 4 of 7 (744 Views)

Re: Loadrunner V11 and ESRI ARCMap V10 - Any Knowledge

If you are using Citrix agent, try removing it. What OS are you using?

 

Regards,

Mario

HP LR/PC Support

If you are customer you can try posting on our internal forums for more personalized support.

LoadRunner:
http://h30499.www3.hp.com/t5/LoadRunner-Support-Customer/bd-p/loadrunner-support-customer-forum

Performance Center:
http://h30499.www3.hp.com/t5/Performance-Center-Support/bd-p/performance-center-support-customer

How to:
http://www.youtube.com/watch?v=4ChlysWupWM

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Member
mikecollins_1
Posts: 3
Registered: ‎06-03-2011
Message 5 of 7 (740 Views)

Re: Loadrunner V11 and ESRI ARCMap V10 - Any Knowledge

[ Edited ]

No Citrix involved.

MS Windows XP SP3

 

But having powered on the machine this morning the cold start has changed behaviour and the DEP boot.ini change must have had a bearing on this.

 

The application is still abending but recording is starting up and initial comms are captured. It would appear to be stopping around the license setup. So if anybody has knowledge of launching requirements or of working with ArcMap then any advice gratefully received.

HP Expert
Suerte13cr
Posts: 736
Registered: ‎09-14-2011
Message 6 of 7 (733 Views)

Re: Loadrunner V11 and ESRI ARCMap V10 - Any Knowledge

What protocol do you use to record?

 

Disable your antivirus and firewalls as these may affect as to how Vugen hooks into IE. Try checking also if you can go into Recording Options->Script->Uncheck "Track process created as COM local servers"

 

Regards,

Mario

HP LR/PC Support

If you are customer you can try posting on our internal forums for more personalized support.

LoadRunner:
http://h30499.www3.hp.com/t5/LoadRunner-Support-Customer/bd-p/loadrunner-support-customer-forum

Performance Center:
http://h30499.www3.hp.com/t5/Performance-Center-Support/bd-p/performance-center-support-customer

How to:
http://www.youtube.com/watch?v=4ChlysWupWM

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Contributor
looe
Posts: 19
Registered: ‎05-09-2012
Message 7 of 7 (665 Views)

Re: Loadrunner V11 and ESRI ARCMap V10 - Any Knowledge

Hi ,

 

I am also facing the same problem.

 

ArcMap v10 is running as a thick client, based of .net 3.5 sp1 framework.

Similar tool that i also need to load test is the ArcGIS explorer, also based of the same .net framwork

 

Testing Environment:

  • Win7 64bit
  • LR11 patch 4
  • DEP and UAC disabled

 

Issue:

 

  • Using protocol analyser
    • Map: app crash
    • Explorer: 62 events generated, upon clicking stop recording, Vugen fail to response and need to close

     

  • Use DCOM protocol
    • Map: app crash
    • Explorer: app hang

     

  • Use .net protocol
    • Map: no events captured
    • Explorer: 16 events captured, upon clicking stop recording, Vugen fail to response and need to close

 

Kindly advise.

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.