Loadrunner 11.52 "generator using over 80% CPU" (8733 Views)
Reply
Advisor
Posts: 13
Registered: ‎08-09-2013
Message 26 of 36 (1,942 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

On our systems, load generators as VM's running Windows Server 2008 R2; at suggestion of our operations folks, we removed OV agents & configured agent-less monitoring on controller & all load generator servers:  this seemed to help on most of our load testing applications, regarding "80% CPU" error, more than anything else we tried.  However, I'm now seeing "80%" generator CPU issue, again, with another HTTP app, involving WebFOCUS, with relatively small number of virtual users.  WebFOCUS application is one we've never load tested before-- so am investigating that...

Occasional Advisor
Posts: 7
Registered: ‎10-14-2013
Message 27 of 36 (1,882 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

Facing the same issue - Please find the details below

 

LR 11.52 patch 1

Protocol Used-Single/ Web(HTTP/HTML)

No of Users- 100

Running the Controller As Admin.

Please find the attached snapshots.

 

Kindly help asap.

HP Expert
Posts: 105
Registered: ‎08-10-2011
Message 28 of 36 (1,869 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

Hi nikil1043,

 


As I mentioned in previous posts this message was added in LR 11.50 so you would not see it in previous versions.

HP Expert
Posts: 105
Registered: ‎08-10-2011
Message 29 of 36 (1,868 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

Hi Nitiniit07,

 

Please make sure the following:

1) The CPU usage is caused by mmdrv process and not some other process such as Antivirus/Backup/IT script

2) The LG is not really overloaded, this is more tricky to check but try to see how much CPU a single vUser is using. The CPU usage depends on the script code and on the runtime settings. For example, make sure there is think time and no logging as these two things can increase the CPU usage.

 

If 1 and 2 didn't help please check the Hits per second graph. If it drops to 0 during the CPU 100% period please contact me directly at kozo@hp.com

 

In the past couple of months I spoke to many customers regarding this error message and all but one had problems 1 or 2 as described above. Only one customer encountered a real issue which we are investigating now.

 

Thanks,

Boris.

Advisor
Posts: 11
Registered: ‎05-08-2012
Message 30 of 36 (1,678 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

Hello

I guess i've found a workaround soln to this problem.

In the bin folder that is in LR installation folder (C:\Program Files\HP\LoadRunner\bin) there should be a file named: mdrv.exe.config

Could you rename this file to "mdrv.exe.config_" and try to rerun the vusers ?

Regards.
Occasional Advisor
Posts: 8
Registered: ‎09-14-2010
Message 31 of 36 (1,569 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

This mdrv.exe file is located on the generator, correct??

Do I just need to rename the existing file and then run the test again or do I first need to make a copy of the file and then rename the original?

Please let me know.

 

Thanks.

S_Z
Occasional Visitor
Posts: 1
Registered: ‎07-01-2014
Message 32 of 36 (962 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

I am geeting erroe message "CPU usage load generator has exceted 80%"

 

Load Runner version 11.52

 

install on windows 7.

 

need solution ASAP

Occasional Visitor
Posts: 1
Registered: ‎08-12-2014
Message 33 of 36 (836 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

I am having the same issue. I found some information on this blog - http://blogs.hexaware.com/quality-assurance-and-testing-services/loadrunner-runtime-settings-%E2%80%...

 

I'm trying to test this out setting my vusers to run as a thread instead of a process, but I can't figure out where to set that in my version of LR

 

We use version 11.52

 

Anyone have a clue where to set this? It's in the run time settings, but all of the screen shots I see are older versions of LR.

 

Thanks in advance for any help.

 

Teri

Occasional Visitor
Posts: 1
Registered: ‎01-27-2015
Message 34 of 36 (230 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

Hi boris

 

is this issue arrving when i am using vuser running as a process by using sap gui protocal.it's display's the cpu utlization crosses the 80 %.but trnasction are mainly passed.

 

we have increse the cpu utlization in my client machine then it's e solved?

 

Thanks in advance


_Buzzy wrote:

Hi Nitiniit07,

 

Please make sure the following:

1) The CPU usage is caused by mmdrv process and not some other process such as Antivirus/Backup/IT script

2) The LG is not really overloaded, this is more tricky to check but try to see how much CPU a single vUser is using. The CPU usage depends on the script code and on the runtime settings. For example, make sure there is think time and no logging as these two things can increase the CPU usage.

 

If 1 and 2 didn't help please check the Hits per second graph. If it drops to 0 during the CPU 100% period please contact me directly at kozo@hp.com

 

In the past couple of months I spoke to many customers regarding this error message and all but one had problems 1 or 2 as described above. Only one customer encountered a real issue which we are investigating now.

 

Thanks,

Boris.


 

 

Valued Contributor
Posts: 101
Registered: ‎07-16-2010
Message 35 of 36 (219 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

You can launch windows Task manager , Click on Performance Tab and click on Resource Monitor.

In Resource monitor click on CPU tab. Select Vugen/ mmdrv process and watch its resources. This way you can also see your multicore distribution as well as check Mem, disk and network.

 

If you are using perfmon then see how is your processor queue length is behaving. You need to monitor resources on machine little before and after test to identify these are real test peaks in your consistent runs.

 

 

Tnx!

Occasional Visitor
Posts: 2
Registered: ‎03-13-2015
Message 36 of 36 (100 Views)

Re: Loadrunner 11.52 "generator using over 80% CPU"

hi

 

I also have this problem, i find that when run the mmdrv.exe use many cpu resource. have u solved this problem, if u know how to solve it, please tell me . thank you very much!!!

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.