LoadRunner Scripts Issue on Icefaces JSF Framework (681 Views)
Reply
Visitor
mmsys
Posts: 2
Registered: ‎02-17-2014
Message 1 of 9 (681 Views)

LoadRunner Scripts Issue on Icefaces JSF Framework

[ Edited ]

Hi expert, 

I am working on a web application created on icefaces jsf framework, I am completely new on this framework. having lot of issues creating script, I need some hlep on this..

One problem i am having i am adding some customer information and email address and my script should send an email to customer id but its not and becuase of that its taking much less time to complete the transaction than expected but script is passed. 

Another problem: one page I have two tab button, first I am inputing some data for intra-country and saving those data then switching the tab button to international and inputing some data and saving it. then moving to next page, based on the data system should calculate some recommendation values. when I am running the script, it running fine but problem is it updating the intra-country data only but not updating the international data it taking the defualt data 0.0 for all fields. 

I tried all different protocol and using HTTP/HTML Url base scripting. using VuGen 11.52

need some help on deal with those problems on icefaces.

 

 

P.S. This thread has been moevd from Application Perf Mgmt (BAC / BSM) Support and News Forum to LoadRunner Support Forum. - Hp Forum moderator

HP Expert
PatWest
Posts: 836
Registered: ‎03-06-2008
Message 2 of 9 (647 Views)

Re: LoadRunner Scripts Issue on Icefaces JSF Framework

Honored Contributor
shiv_p
Posts: 2,860
Registered: ‎04-23-2008
Message 3 of 9 (620 Views)

Re: LoadRunner Scripts Issue on Icefaces JSF Framework

did you try replaying script with think time enabled? you can check this in 'run' option.

Occasional Advisor
mmsyss
Posts: 7
Registered: ‎04-01-2014
Message 4 of 9 (582 Views)

Re: Scriptsing Issues on EJB Load Testing..

Hi Expert,

I Need to do load testing of our Remote EJB service calls using Load runner. I am using VuGen 11.52 version.

Trying to use the EJB Detector to detect the running ejb's, I was able to run the EJB Detector on the Server but its showing No EJB is detect/ 0 EJB founds error.

 

 

Any Help on this issues? Didn't do EJB testing before.. Need some gudieline how to resolve this issues.

 

Our Web Application server is Weblogic 10 and all the servers is running on Red Hat Linux. And the EJB version is 3.0.

 

Any help will be appriciated. thanks

 

 

HP Expert
rleitons
Posts: 146
Registered: ‎07-21-2009
Message 5 of 9 (574 Views)

Re: Scriptsing Issues on EJB Load Testing..

HI, I suggest check this KB http://support.openview.hp.com/selfsolve/document/KM214626 to configure the EJB Detector.

We have a protocolo in LR11.5x to record this application (that I think you are using):

Protocol                                          Program         Supported Version             Supported Server

Enterprise Java Beans (EJB)   Java                              1.4                                   SUN J2EE SDK

                                                                                                  1.5                                BEA WebLogic 8.1

                                                                                                 1.6.x                           IBM WebSphere 5.X

 

I suggest check the KB information to check if the Detector was well configured.

 

Rodolfo.

Occasional Advisor
mmsyss
Posts: 7
Registered: ‎04-01-2014
Message 6 of 9 (559 Views)

Re: Scriptsing Issues on EJB Load Testing..

 

Hi Expert,

IS Load runner support Weblogic 10.3.5.0 version to test EJB using EJB Protocol?

Our Web Application server is Weblogic 10.3.5.0. 

 

any help on this will be appriciated. 

 

Trying to run EJB Detector on Application server, it is running but can't detect any ejb. getting message "Founb 0 EJB ."

Need help on proper environment setup for ejb detector on weblogic 10.3.5 version. 

thanks 

 

Visitor
mmsys
Posts: 2
Registered: ‎02-17-2014
Message 7 of 9 (541 Views)

Re: Scriptsing Issues AJAX TruClient Protocol


Hi Expert

I am using Ajax TruClient IE N Firefox both. having 2 issues:
I have been using last few month TruClient IE, was working fine, but since Out JSF Icefaces Version updated I am having a problem. When I am recording or replying my earlier recorded scripts, on one page specifically in the same page when I am clicking a button call "Continue" And application should move to next page, But everytime I am clicking that button, Truclient is not responding, it just can't going to the next page. I tried the same scripts on the dev enviroenmt with earlier version of code install, its working fine there. but having the issue when I am moving to UAT where new version of IceFaces Code. don't know what to do..plse help me out

Question: When I am using Ajax Truclicnet Firefox Protocol Scirpts, Running test frfom Performance Center, Do I need to Insatll Firefox 8.0.1 version in the LG machine Separately or not? having some usual test result. I don't have firefox install separately in my LG machine.

Plz Reply

Occasional Advisor
mmsyss
Posts: 7
Registered: ‎04-01-2014
Message 8 of 9 (522 Views)

Re: Scriptsing Issues on EJB Load Testing..

Hi Expert, 

Our Weblogic Version is 10.3.6 and EJB 3.0 running on Web Logic Application server. 

I am trying to use Enterprise Java Beans(EJB) Protocol to create my scripts to do the load test of our Remote EJB's.

 

Is Load Runner 11.52 or any other version support Weblogic 10.3.6 or EJB 3.0. If not then is there any other protocol of LR 11.52 can be use to test EJB Load testing ? 

 

Can we use any Java Protocols available in LR to test EJB Load testing?

 

any help will be appricated. 

 

Thanks 

mmsyss

 

HP Expert
rleitons
Posts: 146
Registered: ‎07-21-2009
Message 9 of 9 (506 Views)

Re: Scriptsing Issues on EJB Load Testing..

Hi

The last supported version is WebLogic 8.x and there was no development made at this area.

 

Rodolfo Leitón

HP LR/PC Support

 

If you are customer you can try posting on our internal forums for more personalized support.

 

For LoadRunner here.
For Performance Center here.

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

 

If you found this information useful please leave a kudo.

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.