IE Browser keeps on hanging during recording (947 Views)
Reply
Occasional Contributor
ArunShanmugam
Posts: 5
Registered: ‎11-29-2011
Message 1 of 3 (947 Views)

IE Browser keeps on hanging during recording

Hi All,

 

I am trying to record a scenario for an application, but it keeps hanging exactly after recording around 67 events.

Application is working fine manually.

Loadrunner version 9.52 ,IE 7, Protocol:Web(HTTP/HTML).

 

I have tried the following:

1)I have tried recording in URL mode

2)Unchecked "Track processes created as COM local servers" in the Recording Options > Script

Previously, The app used to hang at login itself. But after unchecking it, It is hanging while loading the next page.

3)Switched capture level to WinInet level data (I know it is not relevant to the issue, but just in case)

4)Enabled "Disable script debugging" in IE7 internet options.

But the problem persists.

HP Expert
Editus
Posts: 650
Registered: ‎04-06-2011
Message 2 of 3 (933 Views)

Re: IE Browser keeps on hanging during recording

This is security related, add a port mapping entry according to the server requirements or use wininet, if after doing this, e behavior is the same, please open a case with support

 

cheers

Occasional Contributor
ArunShanmugam
Posts: 5
Registered: ‎11-29-2011
Message 3 of 3 (921 Views)

Re: IE Browser keeps on hanging during recording

Sorry for the late update, There has been a lot going on. This is what I have tried,

 

Case 1- Changed Capture level to WinInet level

IE Browser keeps hanging exactly after recording around 67 events.

I tried the following, but the issue persists.

1)Tried recording in URL mode

2)Unchecked "Track processes created as COM local servers" in the Recording Options > Script

    Previously, The app used to hang at login itself. But after unchecking it, It is hanging while loading the next page.

3)Enabled "Disable script debugging" in IE7 internet options.

 

Case2- Capture level set to Socket level

The browser is not hanging at socket level,

But I am getting the error “Content was blocked because it was not signed by a valid security certificate.”

I tried the following in the IE7 browser, but the issue persists.

1)      Enabled “Don’t prompt for client certification selection when no certification” in Internet Options Security settings.

2)      Disabled “warn about certificate address mismatch” in advanced internet option.

3)      Disabled popup blocker, phishing filter etc.

No security certification error occurs when app is  accessed manually.

 

Case 3- Changed Capture level to Socket and WinInet level

Same as case 1

 

Case 4-

I have even tried portmapping ,

 Network->port mapping->click on new entry->Record type: direct->click on update.

 Launch a new recording.

Result is, the application is taking more than ten minutes to login, hence session time out occurs. Also,

No code is generated even though the events were recorded.

 

Editus, Thanks for your response. Yes I have opened a case with hp support.

 

Cheers

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.