Re: Graphs are not displaying any data in HP Controller and Analyser (133 Views)
Reply
Occasional Contributor
Sajjad_Ali
Posts: 6
Registered: ‎12-02-2013
Message 1 of 5 (188 Views)

Graphs are not displaying any data in HP Controller and Analyser

[ Edited ]

Hi, 

 

I'm Using HP LR 11 on windows 7 64 bit

 

While after running my script i'm unable to see data in most of graphs

 

data is only avaliable in the following graphs:

-Running Vusers

-Hits per Second

-Throughput

-HTTP Responses per Second

 

I need to see data in the all the graphs specially in "Transactions Graphs" section

 

See the below snapshot of my controller

ControllerSnapshot.jpg

 

 

Please help me to resolve this issue.

 

Also the count in "Passed Transactions & Failed Transactions" is always remain 0 whether error occurred or not.

 

Looking forward to the solution.

 

 

Regards,

Sajjad

Please use plain text.
HP Expert
vmanolova
Posts: 525
Registered: ‎05-24-2012
Message 2 of 5 (176 Views)

Re: Graphs are not displaying any data in HP Controller and Analyser

Hi,

Please check if the script contains transactions.

If it does not contain transactions and if you have not selected "Define each action as a transaction" in the Run-time settings -> Miscellaneous you will not see any data as in the screenshot you have provided.

 

Kind regards,

HP Support
If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please use plain text.
Occasional Contributor
Sajjad_Ali
Posts: 6
Registered: ‎12-02-2013
Message 3 of 5 (148 Views)

Re: Graphs are not displaying any data in HP Controller and Analyser

Hi,

 

Thanks a lot your help my issue has almost resolved now :-)

 

but still other graphs are not loading data like graphs under the following categories:

Spoiler
 

-System Resource Graphs

-Network Graphs

-Web Server Resource Graphs

-Web Application Server Graphs. etc.

 

looking forward to the reply.

 

Regards,

Sajjad

 

Please use plain text.
HP Expert
vmanolova
Posts: 525
Registered: ‎05-24-2012
Message 4 of 5 (139 Views)

Re: Graphs are not displaying any data in HP Controller and Analyser

Hi,

 

System Resource Graphs require that you specify the resources you want to measure before running the scenario.

For Web Server Resource Graphs  and Web Application Server Graphs you need to activate the online monitor for the server and specify which resources you want to measure before running the load test scenario.

 

For more  information on activating and configuring the monitors, refer to the HP LoadRunner Controller User Guide.

 

Kind regards,

HP Support
If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please use plain text.
Honored Contributor
shiv_p
Posts: 2,841
Registered: ‎04-23-2008
Message 5 of 5 (133 Views)

Re: Graphs are not displaying any data in HP Controller and Analyser

The monitors one's you see in blue color, they are already configured for you and hence you see the data.

 

You will need to configure the monitors if you need it for

 

-System Resource Graphs

-Network Graphs

-Web Server Resource Graphs

-Web Application Server Graphs. etc.

 

Refer monitor best practices which comes as part of the LR documentation for further details.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation