perl 5.18 build fails on hp ux 11iv3 (559 Views)
Reply
Valued Contributor
chindi
Posts: 368
Registered: ‎07-24-2008
Message 1 of 8 (559 Views)

perl 5.18 build fails on hp ux 11iv3

[ Edited ]

Hi ,

 

when am trying to install perl 5.18 on hpux 11iv3 am getting following problem ;

 

make is halting at ;

 

(Bundled) cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.
(Bundled) cc: warning 922: "+O2" is unsupported in the bundled compiler, ignored.
(Bundled) cc: warning 922: "+Onolimit" is unsupported in the bundled compiler, ignored.
"dump.c", line 784: error #2065: expected a ";"

 


19 errors detected in the compilation of "dump.c".
*** Error exit code 2

Stop.

 

 

Am using gcc installed form hpux site.

root #/opt/perl-5.18.0 >which gcc
/usr/local/bin/gcc
root #/opt/perl-5.18.0 >gc -v
sh: gc: not found.
root #/opt/perl-5.18.0 >gcc -v
Using built-in specs.
Target: ia64-hp-hpux11.31
Configured with: ../gcc/configure
Thread model: posix
gcc version 4.2.3

 

 

root #/opt/perl-5.18.0 >swlist -l product|grep -i comp

ACXX C.06.26.EVAL HP C/aC++ Compiler
C-ANSI-C C.06.26.EVAL HP C/aC++ Compiler

 

 

What am i missing here ?

 

 

P.S. This thread has been moved from HP-UX > System Administration to HP-UX > languages. - Hp Forum moderator

 

Acclaimed Contributor
Dennis Handly
Posts: 25,089
Registered: ‎03-06-2006
Message 2 of 8 (541 Views)

Re: perl 5.18 build fails on HP-UX 11.31

[ Edited ]

>(Bundled) cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

>What am I missing here?

 

You only have the bundled C compiler and you can't do development with it.

 

>"dump.c", line 784: error #2065: expected a ";"

 

What's on that line?

 

>ACXX C.06.26.EVAL HP C/aC++ Compiler
>C-ANSI-C C.06.26.EVAL HP C/aC++ Compiler

 

This Eval compiler has long expired.  You should immediately remove it from your system.

 

>Am using gcc installed from hpux site.

 

Then you need to tell make to use gcc and not cc.

Valued Contributor
chindi
Posts: 368
Registered: ‎07-24-2008
Message 3 of 8 (505 Views)

Re: perl 5.18 build fails on HP-UX 11.31

Hi Dennis ,

 

How do i tell make to use gcc ?

Acclaimed Contributor
Dennis Handly
Posts: 25,089
Registered: ‎03-06-2006
Message 4 of 8 (498 Views)

Re: perl 5.18 build fails on HP-UX 11.31

>How do I tell make to use gcc

 

There is probably a macro CC that you can set on the command line:  make ... CC=gcc ...

Frequent Advisor
RJHall
Posts: 30
Registered: ‎05-30-2013
Message 5 of 8 (478 Views)

Re: perl 5.18 build fails on HP-UX 11.31

>>How do I tell make to use gcc

 

> There is probably a macro CC that you can set on the command line:  make ... CC=gcc ...

 

If it's of any help, I used the following configuration for 64-bit Perl 5.16.3:

 

sh Configure -s \

 -Dcc=/opt/hp-gcc-4.6.2/bin/gcc \

 -Dmake=/opt/gmake-3.82/bin/make \

 -Duse64bitall -Dusethreads \

 -Doptimize='-O2' -Duselargefiles -Duselongdouble \

 -Dcf_email=root -Dperladmin=root \

 -Dprefix='/opt/perl-5.16.3'

 

There's probably a better way of doing this, but I typically copy the libgcc_s.so.0 into the application lib directory so that the gcc compiler bundle doesn't need to be loaded. Hence I modified the Makefile so:

 

To LDDLFLAGS I add: +b /usr/lib/hpux64:/opt/perl-5.16.3/lib

To CCDLFLAGS I add: -Wl,+b,/usr/lib/hpux64:/opt/per-5.16.3/lib

 

and I add -lgcc_s to the list of libraries to use during configuration. Finally I use a copy of Gnu make I have at /opt/gmake-3.82/bin/make to build it.

 

Frequent Advisor
RJHall
Posts: 30
Registered: ‎05-30-2013
Message 6 of 8 (477 Views)

Re: perl 5.18 build fails on HP-UX 11.31

Oops, make that:

 

To CCDLFLAGS I add: -Wl,+b,/usr/lib/hpux64:/opt/perl-5.16.3/lib

Honored Contributor
H.Merijn Brand (procura
Posts: 6,188
Registered: ‎10-13-1997
Message 7 of 8 (452 Views)

Re: perl 5.18 build fails on hp ux 11iv3

Is there a special reason to build 5.18.0? 5.18.1 was released on 2013-08-12.

 

I have a depot available for 5.16.3 *) which contains a threaded 64bitall longdouble perl built with gcc

*) http://mirrors.develooper.com/hpux/perl-5.16.3-11.31-ia64.sd.bz

 

As building all these depots take quite a bit of time, I cannot build all releases, but I plan to make 5.18.2 for all OS versions when it is released.

 

$ sh ./Configure -Dcc=gcc -Duse64bitall -Duselongdouble -Dusethreads -Duseithreads -des \

   -Dprefix=/opt/perl64 -Dinc_version_list=none

 

 

 

 

Enjoy, Have FUN! H.Merijn
Honored Contributor
H.Merijn Brand (procura
Posts: 6,188
Registered: ‎10-13-1997
Message 8 of 8 (408 Views)

Re: perl 5.18 build fails on hp ux 11iv3

I have just finished building depots for 5.18.2 for HP-UX 11.00 through 11.31. (10.20 will follow soon, too slow)

http://mirrors.develooper.com/hpux
Enjoy, Have FUN! H.Merijn
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.