Re: cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored. (325 Views)
Reply
Advisor
Tushar_hiwase
Posts: 29
Registered: ‎08-20-2012
Message 1 of 10 (414 Views)

cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

[ Edited ]

Hi,

 

I am trying to install/configure svn over apache in HPUX 11.31.

When i am trying to "make" inside my apache folder ie. /opt/httpd-2.4.6, getting below error.

 

(Bundled) cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

 

After googling, i found that need to install Ansi c compiler on my server.

I have downloaded the patch PHSS_40631 for ansi c compiler, and when trying to install it says
 

Patches in the source
         depot might already be on the target, or might be superseded
         by patches on the target, or might not apply to software on
         the target.
NOTE:    Cannot continue the "swinstall" task.

Help needed...

 

thanks,

tushar

 

 

P.S. This thread has been moved from HP-UX > System Administration to HP-UX > languages. - Hp Forum MOderator

Please use plain text.
Acclaimed Contributor
Dennis Handly
Posts: 24,849
Registered: ‎03-06-2006
Message 2 of 10 (393 Views)

Re: cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

[ Edited ]

>After googling, I found that need to install ANSI C compiler on my server.

 

That's correct.

 

>I have downloaded the patch PHSS_40631 for ANSI C compiler

 

You can't download just a patch, you must purchase the compiler.  Or try to build using gcc.

 

>When I am trying to "make" inside my apache folder ie. /opt/httpd-2.4.6, getting below error.

 

I only see a warning, perhaps you should ignore it.

 

Please use plain text.
Advisor
Tushar_hiwase
Posts: 29
Registered: ‎08-20-2012
Message 3 of 10 (384 Views)

Re: cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

Denis,

 

I can't ignore that warnings, as I have to configure svn server over apache webserver. As per documentation, only after successful "make" and "make install", it will load the module mod_dav_svn.so.

And without this module, I can't configure my svn server.

Even my ./configure is successfully executing.

 

/opt/httpd-2.4.6/configure --prefix=/usr/local/apache2 --with-apr=/usr/local/apr/bin/apr-1-config --with-apr-util=/usr/local/apr/bin/apu-1-config --enable-dav --enable-load-all-modules

 

but apachectl under /usr and /opt also not working.

 

bash-4.2# /usr/local/apache2/support/apachectl -v
bash: /usr/local/apache2/support/apachectl: Permission denied
bash-4.2#

 

bash-4.2# /opt/httpd-2.4.6/support/apachectl -v
bash: /opt/httpd-2.4.6/support/apachectl: Permission denied
bash-4.2#

 

 

thanks,

 

tushar

 

 

Please use plain text.
Acclaimed Contributor
Dennis Handly
Posts: 24,849
Registered: ‎03-06-2006
Message 4 of 10 (373 Views)

Re: cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

>I can't ignore that warnings

 

Why not?  I don't see a connection between that warning and your "Permission denied".

 

>only after successful "make" and "make install"

 

Were they successful?

Please use plain text.
Advisor
Tushar_hiwase
Posts: 29
Registered: ‎08-20-2012
Message 5 of 10 (361 Views)

Re: cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

Hi,

I think only successfull make and make install will create executables and mod_dav_svn.so also which is required for svn over apache.

But these are failing with below error.

(Bundled) cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.


Please use plain text.
Acclaimed Contributor
Dennis Handly
Posts: 24,849
Registered: ‎03-06-2006
Message 6 of 10 (353 Views)

Re: cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

>But these are failing with below error.

 

Again, this is NOT an error, just a warning.  Do you have any other error messages?

Please use plain text.
Advisor
Tushar_hiwase
Posts: 29
Registered: ‎08-20-2012
Message 7 of 10 (340 Views)

Re: cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

other errros are as below while "make"

ld: Unsatisfied symbol "ap_cfg_closefile" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "ap_cfg_getline" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "ap_hook_optional_fn_retrieve" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "apr_password_validate" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "ap_getword" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "apr_dynamic_fn_retrieve" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "ap_register_auth_provider" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "ap_set_file_slot" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "ap_pcfg_openfile" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "apr_palloc" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "ap_log_rerror_" in file .libs/mod_authn_file.o
ld: Unsatisfied symbol "ap_rwrite" in file .libs/mod_authn_file.o
ld: (Warning) Unsatisfied symbol "main" in file /usr/lib/hpux32/libc.so
1 warnings.
12 errors.
*** Error exit code 1

Stop.
*** Error exit code 1
Please use plain text.
Acclaimed Contributor
Dennis Handly
Posts: 24,849
Registered: ‎03-06-2006
Message 8 of 10 (334 Views)

Re: cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

>ld: (Warning) Unsatisfied symbol "main" in file /usr/lib/hpux32/libc.so

 

Again, you can't do development with the bundled C compiler.  You most likely have this "fatal" warning:

cc: warning 922: "-b" is unsupported in the bundled compiler, ignored.

 

This prevents you from building a shlib.  You could use "ld -b".

http://h30499.www3.hp.com/t5/Languages-and-Scripting/Error-compiling-Apache-Server-Bundled-cc-warnin...

Please use plain text.
Advisor
Tushar_hiwase
Posts: 29
Registered: ‎08-20-2012
Message 9 of 10 (327 Views)

Re: cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

Hi Denis,

I have installed gcc on server

bash-4.2# which gcc
/usr/local/bin/gcc
bash-4.2# gcc -v
Using built-in specs.
Target: ia64-hp-hpux11.31
Configured with: ../gcc/configure
Thread model: posix
gcc version 4.2.3
bash-4.2#

Below is my ./configure command which is running fine ie. without error

bash-4.2# ./configure --prefix=/usr/local/apache2 --prefix=/usr/local/bin/gcc --with-apr=/usr/local/apr/bin/apr-1-config --with-apr-util=/usr/local/apr/bin/apu-1-config --enable-dav --enable-load-all-modules

so where i have to use "ld -b" i.e. while "configure" or "make" ?

please suggest

Please use plain text.
Acclaimed Contributor
Dennis Handly
Posts: 24,849
Registered: ‎03-06-2006
Message 10 of 10 (325 Views)

Re: cc: warning 922: "-Ae" is unsupported in the bundled compiler, ignored.

>where I have to use "ld -b" i.e. while "configure" or "make"?

 

If you are using gcc, you don't need to worry about that.  "gcc -shared" will work.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation