Re: aCC on hp-ux 11.23 itanium (379 Views)
Reply
Regular Advisor
Asya
Posts: 120
Registered: ‎11-14-2001
Message 1 of 8 (379 Views)

aCC on hp-ux 11.23 itanium

Hi everyone,

I am trying to run a simple program on hp-ux 11.23 with aCC 6.20 installed. Here is my error message:

ld: Can't find library or mismatched ABI for -lunwind

Could it be related to missing patches? If so, do i get regular patches for 11.23? I went to patches database and didn't see any comments that would distinguish RISC and itanium depots. Should i install whatever is available?

Thank you!
Acclaimed Contributor
James R. Ferguson
Posts: 21,184
Registered: ‎07-06-2000
Message 2 of 8 (379 Views)

Re: aCC on hp-ux 11.23 itanium

Hi:

A "mismatched ABI" error means that your are trying to link 32-bit and 64-bit objects. All objects must be one or the other bitness. The first object found on the command line is used by the linker to determine what bitness the remaining objects must be.

The latest linker patch should also be applied to enable distinguishing a truly mismatched bitness from a truly missing object.

http://www.itrc.hp.com/service/patch/patchDetail.do?patchid=PHCO_38573&sel={hpux:11.23,}&BC=main|search|

Regards!

...JRF...
Regular Advisor
Asya
Posts: 120
Registered: ‎11-14-2001
Message 3 of 8 (379 Views)

Re: aCC on hp-ux 11.23 itanium

James,

Thank you, but i am still getting the same error message.

Should i try installing the whole bundle for 11.23?

Thank you again.
Acclaimed Contributor
James R. Ferguson
Posts: 21,184
Registered: ‎07-06-2000
Message 4 of 8 (379 Views)

Re: aCC on hp-ux 11.23 itanium

Hi (again):

You might want to install the patch I suggested, is all.

Do you have a library (*.so) called 'unwind'?

Make sure your embedded linker path (+b ) is set or the '+s' linker switch with a SHLIB_PATH or LD_LIBRARY_PATH is set appropriately.

If so, use 'file' to verify that it is a 64-bit or 32-bit one. If the output of 'file' says "ELF-64" it's a 64-bit object.

Regards!

...JRF...

Regular Advisor
Asya
Posts: 120
Registered: ‎11-14-2001
Message 5 of 8 (379 Views)

Re: aCC on hp-ux 11.23 itanium

Thanks again:)

Do you have a library (*.so) called 'unwind'?
- yes i do.

Make sure your embedded linker path (+b ) is set or the '+s' linker switch with a SHLIB_PATH or LD_LIBRARY_PATH is set appropriately.
- How do i make sure that..? Where would i look?

Sorry for so many questions...
Regular Advisor
Asya
Posts: 120
Registered: ‎11-14-2001
Message 6 of 8 (379 Views)

Re: aCC on hp-ux 11.23 itanium

just to add.

I installed this by downloading depot. I didn't build it from the source.
Regular Advisor
Asya
Posts: 120
Registered: ‎11-14-2001
Message 7 of 8 (379 Views)

Re: aCC on hp-ux 11.23 itanium

Installing patches

PHSS_37552 PHSS_38134

solved the problem. Thank you very much for your help!
Acclaimed Contributor
Dennis Handly
Posts: 25,089
Registered: ‎03-06-2006
Message 8 of 8 (379 Views)

Re: aCC on hp-ux 11.23 itanium

>ld: Can't find library or mismatched ABI for -lunwind
>Could it be related to missing patches?

No, this error is impossible. About the only way to get this is if you compile with +DD64 but forget to link with +DD64.

>didn't see any comments that would distinguish PA-RISC and Integrity depots.

Except for compilers, core runtime patches are dual and contain both. It automatically installs the proper bits.

>JRF: The latest linker patch should also be applied to enable distinguishing a truly mismatched bitness from a truly missing object.

Yes, that was my enhancement request.

>Do you have a library (*.so) called unwind?

This should be on all IPF systems.
And SHLIB_PATH or LD_LIBRARY_PATH shouldn't be needed.

>PHSS_37552 PHSS_38134 solved the problem.

I'm not sure why they should?

See the following for recommended aC++ patches:
http://h21007.www2.hp.com/portal/site/dspp/menuitem.863c3e4cbcdc3f3515b49c108973a801/?ciid=8b080f1ba...

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.