Re: Unresolved pthread_attr_init on HP-UX (343 Views)
Reply
Visitor
John_K
Posts: 2
Registered: ‎04-09-2010
Message 1 of 3 (373 Views)
Accepted Solution

Unresolved pthread_attr_init on HPUX

[ Edited ]

Hello Experts,

 

I've run into a issue - apologies for burdening you with this - but I feel I'm probably one patch or PATH update from fixing this ! ;-)

 

I'm trying to get a - in this case simplified - program to run on HP-UX. It's built using XPADE on HP-IA and the resultant .out runs in the ( ARIES ? ) environment on there ( IA )  - but an attempt to run it on HP-UX gives

 

/usr/lib/dld.sl: Unresolved symbol: pthread_attr_init (code) from ./thread_risc.out

Abort Instruction ( core dumped )

 

A uname -a on the UX machine gives

 

HP-UX chtorh01 B.11.11 U 9000/785 2006705404 unlimited-user license

 

In other threads on here I see the output of the following commands often requested

 

ldd ./thread_risc.out

 

        /usr/lib/libdld.2 =>    /usr/lib/libdld.2
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/lib/libdld.2 =>    /usr/lib/libdld.2
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/lib/libcl.2 =>     /usr/lib/libcl.2
        /usr/lib/libisamstub.1 =>       /usr/lib/libisamstub.1
        /usr/lib/libdld.2 =>    /usr/lib/libdld.2
        /usr/lib/libm.2 =>      /usr/lib/libm.2
        /usr/lib/libCsup.2 =>   /usr/lib/libCsup.2
        /usr/lib/libstream.2 => /usr/lib/libstream.2
        /usr/lib/libstd.2 =>    /usr/lib/libstd.2
        /usr/lib/libpthread.1 =>        /usr/lib/libpthread.1

 

chatr ./thread_risc.out gives

./thread_risc.out:
         shared executable
         shared library dynamic path search:
             SHLIB_PATH     disabled  second
             embedded path  disabled  first  Not Defined
         shared library list:
             dynamic   /usr/lib/libpthread.1
             dynamic   /usr/lib/libstd.2
             dynamic   /usr/lib/libstream.2
             dynamic   /usr/lib/libCsup.2
             dynamic   /usr/lib/libm.2
             dynamic   /usr/lib/libcl.2
             dynamic   /usr/lib/libc.2
             static    /usr/lib/libdld.2
         shared library binding:
             deferred
         global hash table disabled
         plabel caching disabled
         global hash array size:1103
         global hash array nbuckets:3
         shared vtable support disabled
         explicit unloading enabled
         runtime checks disabled
         static branch prediction disabled
         executable from stack: D (default)
         kernel assisted branch prediction enabled
         lazy swap allocation disabled
         text segment locking disabled
         data segment locking disabled
         third quadrant private data space disabled
         fourth quadrant private data space disabled
         third quadrant global data space disabled
         data page size: D (default)
         instruction page size: D (default)
         nulptr references disabled
         shared library private mapping disabled
         shared library text merging disabled

 

A seach led to perhaps missing a patch and PHCO_33282 has been applied

 

and a  

/usr/sbin/swlist -l patch | grep PHCO_33282   

gives - amongst other output..

PHCO_33282  1.0 pthreadlibrary cumulative patch


I'm at the edge of my knowledge here so any help - pointers in the right direction gratefully received.

 

Thanks in advance,

John

 

 

P.S. This thread has been moved from HP-UX > Patches to HP-UX > Languages and Scripting - HP Forums Moderator 

 

 

Please use plain text.
Acclaimed Contributor
Dennis Handly
Posts: 24,880
Registered: ‎03-06-2006
Message 2 of 3 (362 Views)

Re: Unresolved pthread_attr_init on HP-UX

>but an attempt to run it on HP-UX gives

 

This is explicitly documented as not supported.

When you use XPADE, you can only run the application on Integrity boxes, under Aries.

 

Your particular problem is the same as compiling on 11.23 or 11.31 and trying to move to 11.11, even if all are PA-RISC.

Please use plain text.
Visitor
John_K
Posts: 2
Registered: ‎04-09-2010
Message 3 of 3 (343 Views)

Re: Unresolved pthread_attr_init on HP-UX

Thank you for your prompt response. I re-read the XPADE docs and now see my error ! ;-)

 

Thank you again for your help.

 

John K

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation