STLport 5.1.7 giving ld errors about :_HPMutexWrapper (144 Views)
Reply
Occasional Visitor
Meir242
Posts: 1
Registered: ‎11-14-2008
Message 1 of 2 (144 Views)

STLport 5.1.7 giving ld errors about :_HPMutexWrapper

Hello all
im porting application to use STLport 5.1.7
im using :
aCC: HP C/aC++ B3910B A.06.20
HP-UX hprx02 B.11.31 U ia64
and im getting ld errors like :

ld: Unsatisfied symbol "std::__rw_exception::_C_assign(char const*,unsigned long)" in file /home/bld/DevEnv/products/Core/Debug/lib/libGeneral.a[GeneralUtil.o]
ld: Unsatisfied symbol "std::__rw_exception::_C_assign(char const*,unsigned long)" in file /home/bld/DevEnv/products/Core/Debug/lib/libGeneral.a[GeneralUtil.o]
ld: Unsatisfied symbol "_HPMutexWrapper::lock(void*)" in file /home/bld/DevEnv/products/Core/Debug/lib/libGeneral.a[GeneralUtil.o]
ld: Unsatisfied symbol "_HPMutexWrapper::init(int)" in file /home/bld/DevEnv/products/Core/Debug/lib/libGeneral.a[GeneralUtil.o]

any idea why ?
Thanks
Please use plain text.
Acclaimed Contributor
Dennis Handly
Posts: 24,953
Registered: ‎03-06-2006
Message 2 of 2 (144 Views)

Re: STLport 5.1.7 giving ld errors about :_HPMutexWrapper

>I'm porting application to use STLport 5.1.7. I'm using: A.06.20

You either can use STLport with +nostl or use -AA. Your unsats occur because you are NOT using STLport for those sources.
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation