Re: Perl modules' compilation errors (395 Views)
Reply
Trusted Contributor
James Specht
Posts: 194
Registered: ‎11-11-2001
Message 1 of 11 (395 Views)
Accepted Solution

Perl modules' compilation errors

I'm trying to install perl modules and I am receiving the error below during most compiles. I've searched the web and it looks like HP-ux 11i has some problem with either the types.h lib or the socket.h lib, but no one has a solution to the problem. I tried the HP C compiler with no better results. I replaced the current socket.h lib with one saved from patch PHNE_28089, no difference. I tried compiling on a different HPux 11i system that has nothing but HPux software (everything is from the original install CD, minus patches of course) and I get the same result.

Does anyone have a solution or a direction to try that I am missing?

Error Message
********************************
# make
gcc -c -D_HPUX_SOURCE -fno-strict-aliasing -D_LARGEFILE_SOURCE -DVERSION=\"1.32\" -DXS_VERSION=\"1.32\" -fPIC "-I/usr/local/lib/perl5/5.8.0/PA-RISC2.0/CORE" -Wall -Wno-comment -DDBI_NO_THREADS Perl.c
In file included from /usr/local/lib/perl5/5.8.0/PA-RISC2.0/CORE/perl.h:681,
from DBIXS.h:19,
from Perl.xs:1:
/usr/include/sys/socket.h:484: parse error before "sendfile"
/usr/include/sys/socket.h:485: parse error before "bsize_t"
/usr/include/sys/socket.h:486: parse error before "sendpath"
/usr/include/sys/socket.h:487: parse error before "bsize_t"
*** Error exit code 1

Stop.
#
********************************
Hardward HP K450
********************************
Software Versions
HP-UX 11.11
B3901BA B.11.11.04 HP C/ANSI C
bison 1.875
flex 2.5.4a
gcc 3.2
libiconv 1.8
make 3.79.1
mysql 3.23.54a
ncurses 5.2
openldap 2.1.3
openssl 0.9.7
perl 5.8.0
zlib 1.1.4
"Everyone can be taught to sculpt: Michelangelo would have had to be taught how not to. So it is with the great programmers."
Honored Contributor
H.Merijn Brand (procura
Posts: 6,189
Registered: ‎10-13-1997
Message 2 of 11 (395 Views)

Re: Perl modules' compilation errors

I don't know if you will be happy with my reply, but from what you post, it looks like you've got a precompiled perl binary from somewhere that was built with gcc.

You *do* however have a HP C-ANSI-C compiler available, which causes my first proposal: Recompile perl from scratch! You will gain 25% speed and all modules you want to add are going to cause less trouble.

That being said, and knowing that it will take a lot of time, you could decide to uninstall this perl and reinstall my build from http://www.cmve.net/~merijn or https://www.beepz.com/personal/merijn that has a prebuild DBI included already, and is also Oracle prepared.

If neither is an option, I'd like to see the output of 'perl -V', because it is possible that the gcc perl is built with is 2.x, whereas you are using 3.2, which is quite different.

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
Trusted Contributor
James Specht
Posts: 194
Registered: ‎11-11-2001
Message 3 of 11 (395 Views)

Re: Perl modules' compilation errors

Here is the output from the perl -V. Also, I get all my binaries from the software porting center for HPux.

Summary of my perl5 (revision 5.0 version 8 subversion 0) configuration:
Platform:
osname=hpux, osvers=11.00, archname=PA-RISC2.0
uname='hp-ux quioch b.11.00 a 9000780 2012209406 two-user license '
config_args='-d -e -Dcc=gcc -Dprefix=/usr/local useposix=true'
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc='gcc', ccflags ='-D_HPUX_SOURCE -fno-strict-aliasing -D_LARGEFILE_SOURCE',
optimize='',
cppflags='-D_HPUX_SOURCE -D_HPUX_SOURCE -fno-strict-aliasing'
ccversion='', gccversion='3.2', gccosandvers='hpux11.00'
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=4
alignbytes=8, prototype=define
Linker and Libraries:
ld='/usr/bin/ld', ldflags =' -L/usr/local/lib -L/opt/local/lib'
libpth=/usr/local/lib /opt/local/lib /lib /usr/lib /usr/ccs/lib
libs=-lcl -lpthread -lnsl -lnm -lndbm -lgdbm -ldb -lmalloc -ldld -lm -lc -lndir -lcrypt -lsec
perllibs=-lcl -lpthread -lnsl -lnm -lmalloc -ldld -lm -lc -lndir -lcrypt -lsec
libc=/lib/libc.sl, so=sl, useshrplib=false, libperl=libperl.a
gnulibc_version=''
Dynamic Linking:
dlsrc=dl_hpux.xs, dlext=sl, d_dlsymun=undef, ccdlflags='-Wl,-E -Wl,-B,deferred '
cccdlflags='-fPIC', lddlflags='-b -L/usr/local/lib -L/opt/local/lib'


Characteristics of this binary (from libperl):
Compile-time options: USE_LARGE_FILES
Built under hpux
Compiled at Aug 29 2002 16:13:57
@INC:
/usr/local/lib/perl5/5.8.0/PA-RISC2.0
/usr/local/lib/perl5/5.8.0
/usr/local/lib/perl5/site_perl/5.8.0/PA-RISC2.0
/usr/local/lib/perl5/site_perl/5.8.0
/usr/local/lib/perl5/site_perl
"Everyone can be taught to sculpt: Michelangelo would have had to be taught how not to. So it is with the great programmers."
Honored Contributor
H.Merijn Brand (procura
Posts: 6,189
Registered: ‎10-13-1997
Message 4 of 11 (395 Views)

Re: Perl modules' compilation errors

I've mailed the porter of both perl and gcc of the porting center to have a look at your question. As long as you don't recompile everything yourself, I cannot help at this point, since I don't have 11i. Sorry.

FWIW, the gcc you have should be OK for the tasks involved.

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
Trusted Contributor
James Specht
Posts: 194
Registered: ‎11-11-2001
Message 5 of 11 (395 Views)

Re: Perl modules' compilation errors

Thanks for all your help. I'm looking into the issue of having a gcc compiled on 11.00 vs 11.11. Some of the itrc boards talk about this being a problem with the socket.h file changes between 11.00 and 11.11. Right now I am downloading the source for gcc and will compile it on the system to see if this fixes anything.
"Everyone can be taught to sculpt: Michelangelo would have had to be taught how not to. So it is with the great programmers."
Honored Contributor
H.Merijn Brand (procura
Posts: 6,189
Registered: ‎10-13-1997
Message 6 of 11 (395 Views)

Re: Perl modules' compilation errors

on http://www.cmve.net/~merijn or https://www.beepz.com/personal/merijn you can get both precompiled gcc and perl with DBI for 11.00 if that might be of any help

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
Honored Contributor
H.Merijn Brand (procura
Posts: 6,189
Registered: ‎10-13-1997
Message 7 of 11 (395 Views)

Re: Perl modules' compilation errors

Here's his disappointing answer:

--8<---
Hi

Sorry sending you this, But for some reason I can 't login to ITRC to respond
to James 's question.

The Binary on the Archive have been tested on 11.00 and 11.20 (IA64) and 11.22
(IA64) platforms. Like yourself we don't have any access to 11i(11.11) platform.

Some probelm has been reported in regard gcc on 11i, But we can 't confirm
anything till we test the program ourself.

Which modules is he trying to compile?

Thanks

__mehdi
-->8---

I did answer his questions. Hope he can chime in later.

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
Trusted Contributor
James Specht
Posts: 194
Registered: ‎11-11-2001
Message 8 of 11 (395 Views)

Re: Perl modules' compilation errors

It works now! I had to recompile gcc from the source at the porting center. There are two threads I found in itrc that talk about the problems with 11.00 and 11.11, which I listed below if you wish to read them. I appreciate all your help.

If there is anything I can do to help on the 11i front let me know. I have 4 11i boxes, two are test environments.

http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0xbdd191ccb36bd611abdb0090277a778c,00.html

http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0xbbc9996c5988d5118ff10090279cd0f9,00.htm
"Everyone can be taught to sculpt: Michelangelo would have had to be taught how not to. So it is with the great programmers."
Honored Contributor
H.Merijn Brand (procura
Posts: 6,189
Registered: ‎10-13-1997
Message 9 of 11 (395 Views)

Re: Perl modules' compilation errors

any chance for a telnet option? I'd love to be able to extend my download section with 11i builds.

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
Regular Advisor
Mehdi_1
Posts: 107
Registered: ‎05-21-2001
Message 10 of 11 (395 Views)

Re: Perl modules' compilation errors

Hi James

Sorry about yesterday. Somehow I couldn't login to respond to your problem. But Merijn kindly forwarded my email.

I am glad your problem has been solved, I had the feeling gcc is the problem.


Thanks

__Mehdi
Trusted Contributor
James Specht
Posts: 194
Registered: ‎11-11-2001
Message 11 of 11 (395 Views)

Re: Perl modules' compilation errors

procura,
If you are serious about your request, no telnet access but ssh through vpn is possible, shoot me an email at jspecht@owens.edu and we can discuss it. Once again thanks for your help.
"Everyone can be taught to sculpt: Michelangelo would have had to be taught how not to. So it is with the great programmers."
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.