Re: JVM hangs and SIGQUIT fails to dump threads (164 Views)
Reply
Occasional Visitor
Aviv Bronshtein
Posts: 1
Registered: ‎07-21-2006
Message 1 of 2 (164 Views)

JVM hangs and SIGQUIT fails to dump threads

Hi,

For some time now I have a java process (JRE 1.3) on Tru64 Unix that every 3 days or so hangs. I've tried to inspect the hanging with a redirection of the stderr to a file and sending the SIGQUIT signal (kill -3 ) to it. After the redirection I've tried to signal the process and as excpected it dumped its threads to the file. When finally the process got stuck again I've tried to signal it again and unfortunately the process wrote to the file "Dumping threads..." and no additional output was generated. Does anyone have any ideas what can I do to inspect what caused the JVM to hang so thoroughly or something more powerful than sending the SIGQUIT signal?
Please use plain text.
Occasional Contributor
John Turnbull
Posts: 4
Registered: ‎02-02-2006
Message 2 of 2 (164 Views)

Re: JVM hangs and SIGQUIT fails to dump threads

Hi Aviv, this is probably not much help, but I'm experiencing somethnig similar where the jvm is hung up garbage collecting. If you have access to the java flags of the process your investigating, adding "-Xverbosegc:file:nameoffile" to the java options will help to confirm this.
NB the output of this is not timestamped so you'll need to tail it while observing the hang.
I got a semblance of a thread dump by looping a kill -3 which eventually produced output when the jvm came briefly out of gc, but I'm having great dificulty interpretting it - about to raise a query about that.
John
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation